HASS.IO -> transfer from SD card to SSD or USB

I have also Sabrent usb3.0 Sata-usb converter. Same thing happened to me. It is not about Hassio. It acts same with Rasberry OS. For power considerations, I spliced the usb cable and gave 5V directly to Sabrent. When powering sabrent after boot screen gives error, it always works!

So I concluded that it is a compatibility issue, specially a powering timing issue.

And bought the cheapest usb3.0 - sata converter (the ones without a case). It works like a charm. It always boots, in any OS that is compatible to SSD.

So, buy another usb-sata converter and test that. Probably your problem will be solved.

1 Like

hello i have the same problem with my adapter Ugreen ,
Please, Can you put an image of your adapter with the modification that you did ?
Thanks a lot

Sabrent SSD box is in the office right now. And due to pandemic, in my country, it is illegal to get out at weekends. So I can send a photo on Monday.

But the procedure is pretty simple. I cut the cable’s outer shell, found the black and red cables. Black is ground. Red is +5V.

If you are going to power ssd with raspberry’s own power, then there is no need to temper with the ground cable. Only thing you need to do is cut the red cable and connect the ssd side of it to the same 5V input of raspberry.

But if you plan to power the ssd with another power supply (like a phone charger), than Charger’s ground and raspberry’s ground should be connected. Easy way for it is peeling off the black wire, connecting a wire there and connect the other end to the ground of raspberry’s input.

If you connect the power (+5V) after raspberry tries to boot, my usb-ssd adapter always work.

But this effort does not worth it. Because the cheapest usb3.0 converter I bought in the local store worked like a charm without any modifications. It does not even have a brand. :grinning:

It is this one: https://tr.aliexpress.com/item/4001075130228.html?spm=a2g0o.productlist.0.0.3c0f33a3fbhRDu&algo_pvid=ae101049-907a-4860-8230-bd5c4afde959&algo_expid=ae101049-907a-4860-8230-bd5c4afde959-0&btsid=0bb0622e16071242457372908e9fcc&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_

After 2.5 hours, I finally got it to work.

Device: Raspberry Pi 2 Model B Rev 1.1
Type: a3ssd
HDD: Crucial BX500 240GB
Adapter: Seagate Backup Plus dock (originally for 3.5" 1TB HDD)


  • Flash hassos_rpi2-4.19.img.gz to the SSD using balenaEtcher.
  • Copy bootcode.bin to an empty FAT32 formatted SD card.
  • Insert the SD card in the Raspberry Pi 2.
  • Connect the SSD to the Raspberry Pi 2.
  • Power up the Raspberry Pi 2.
  • Wait 10-20 minutes for Home Assistant to boot.

Well i’ve been reading for hours but have lost track of all the ways to connect a USB to a Rpi 4B.
I still don understand the current status of the SSD over USB support.

I’m currently running Hassos from an image I flashed on a SD (Supervisor 2020.12.6 and HA 4.16).
Is USB boot now native supported or do I still need to jump through hoops to get this working?

In other words, can I just flash the default image HA offers to a SSD, plug it into a USB-3 port?

I have used this guide: Installing Home Assistant on a RPi 4b 8GB with SSD boot which was clear to me. In 2 hours was running on SSD with restored configuration.
My understanding is that officially Raspberry is making boot from SSD connected to USB (EEPROM needs to updated) on RPi 4. Home Assistant official OS version does NOT support it and you need to use beta version 5.x in order to use it.


I think I rather stick to the stable versions, I want the least headache possible because thats the reason I want to run it from a SSD in the first place.

So I guess best way to do this now is the way @miguelrochefort did it…Just copy a bootcode.bin to a SD card, seems pretty straightforward to me?

Version 5.7 is marked as RC. :slight_smile:

I have been using Rpi4 boot SSD since version 5.0.
Despite all the versions released, I’m today at version 5.7 and I haven’t had any problems with HassOS all along.

So have I.
Not all SSDs and adaptors are compatible though and I guess this will not change with the stable version.

Well I guess I’m going to give it a try first then…

1 Like

I don‘t think that the SSD will be the problem, it is always the controller that the Pi don‘t like.

I thought so too in the beginning. But many comments on my RPi4 SSD boot installation guide told me otherwise.

Looks like 5.8 was just released as stable production.

Yes I only noticed, it is weird that it has not yet appeared in HA as an update.

Well, I had a feeling this was true, but it looks like the updater/notifications only update once a day:

Okay, I updated this version manually and I’ll see what happens in the next version.

strange is that ssd boot is not mentioned in blog article describing new os features

And usb ssd boot doesn’t work now. One step forward, two steps back

1 Like

Indeed killed my install :frowning: