HASS OS 6.0 VDI => After Upgrade fails every boot: Failed to start grow file system on /mnt/data

After the upgrade to HASS OS 6.0 i get the following during every boot:

CTRL-D continues with the boot and every works fine IMO.

What can i do to fix that issue?

UPDATE - FIX:

Press <enter> when the system stops during boot
systemctl stop systemd-journald
umount -A /dev/disk/by-label/hassos-data
fsck.ext4 /dev/disk/by-label/hassos-data
Keep pressing <enter> through all the prompts
5 Likes

It tells you what to do, As it says systemctl status... Run the command.

Sorry, did that already, forgot to screenshot it:

Doesn’t really help. “Operation not permitted”

Sorry forget your screenshots, that’s not how text works.

Sorry but I currently can only connect via (web)VNC, that’s why they are screenshots. Doesn’t change the messages…

This might not help you, but i had this error a while ago when updating one of the 6.x beta releases.
The only thing that helped was to revert to a snapshot that i created in virtualbox before the update.
The second try worked without issues.

I’ve got the same issue. I didn’t get a VM backup before I updated. I do have a snapshot and older backup so could potentially revert but may try to wait it out :slightly_frowning_face:

Reverting and retrying results in the same error.

Is it possible to create a new VDI from the current version and restore from the backup within HA or is anything lost?

I got the same issue. Seems to work fine to boot it with ctrl+d, but it’s a hassle to log in to the machine and do that each time i reboot.

I just updated to 6.0 on Rasp4 - i have no monitor on it but it wont start - i have no idea whats going on…
Is it possible to hook up a monitor to the rasp?
Edit - ye not possible - is dead :frowning:

Yes but you need a micro HDMI cable or adaptor. You could first try to plug a keyboard in and press CTRL-D after 30 seconds after starting it. Should skip that error if its the same. Afterwards you can check in the logfile.

Do you have a similar setup with virtual machine or something else?

I hooked up the rasp to my monitor - i remembered i ordered a hdmi with micro connector - i think the sd card got corrupted in the process since there is no activity from the drive-led (flashes twice briefly on power-on)… Going to download the qcow2 image and start it on my unraid-rig… i hope my 3 month old full snapshot works - not much changes since then but my node-red tinkering is gone im afraid.

I run the Home Assistant OS VDI in VirtualBox too.

Seems to be the situation where this issue is caused. What would be the next step, raise some bug report on Github?

Get the Google Drive Snapshot addon next time, i’ve got automated backups running every night, and keep one for every week the last four weeks, and one for every month for the last 6 months.

FWIW, there is an issue tracking this error: Failed to start Grow File System on /mnt/data · Issue #1426 · home-assistant/operating-system · GitHub

1 Like

This is not cool -Got the qcow2 image working under kvm (unraid) - All the entities were still in my deconz stick. The 3 month old snapshot I had was usable - The changes that were not on the snapshot are from 2 weeks ago. System is back up and running - i never go back to rasp and I wont recommend it unless you can clone your sd-card easily…

Guy on Github issue posted the fix (reason was corrupted filesystem):

Press <enter> when the system stops during boot
systemctl stop systemd-journald
umount -A /dev/disk/by-label/hassos-data
fsck.ext4 /dev/disk/by-label/hassos-data
Keep pressing <enter> through all the prompts
8 Likes

@Tscherno did that work for you too?