Home Assistant Community

Hassapp: An alternative iOS app to empower your HA

ios
Tags: #<Tag:0x00007f37545cb100>
#41

Looks great. I would like to help too.

0 Likes

#42

Looks awesome. Would like to test it out.

0 Likes

#43

Would love to join beta

0 Likes

#44

I would like to try the beta !

0 Likes

#45

I’d like to try beta too, gracias

0 Likes

#46

Happy to be a beta tester as well. Thanks.

0 Likes

#47

Would be happy to help beta testing as well.

Thanks,

0 Likes

#48

Ok, thanks. Looks like I’m a little behind the times with my vintage device :smiley:

0 Likes

#49

Great - downloaded.
1st impressions is that it is very slick - great job!

Some comments:

  1. When creating a room it would be nice to do auto 1st letter capitalisation
  2. I wonder if there is any way that we can tag a card or a view in lovelace as a view in your app?
  3. Consider to support a picture-elements card for floorplan with hotzones/icons - this is a nice UI on mobile to support lots of interactivity

Will provide more comments as/when I play some more…

1 Like

#50

Playing with it now, overall this is a pretty promising start. The setup was very simple and well done, the user interface looks quite nice, settings screen is laid out well, and Siri integration is cool.

Some feedback:

  • If you are pressing the settings button on “Living Room” for example, it should take you directly to the “Room detail - Living Room” section rather than the main settings view (you’d still be able to go to settings by pressing the back button in top). This would make it faster to configure all your rooms.
  • There is currently no way to re-order rooms, when you press the Edit button you can delete a room but not re-arrange it by dragging it up or down the list. I added my Kitchen first but that’s the room with least devices and now it’s the first page.
  • The same goes for devices inside each room. You could toggle them on or off but not re-order them currently.
1 Like

#51

Glad to hear that you like it @SeanM! Regarding the first comment and as mentioned in the test notes, both the room reordering and device reordering are still WIP.
Regarding the first point, not sure about the UX there. The settings should never be discoverable backwards but always being the starting point. I might think about another alternative there though.

Thank you very much SeanM, this is really valuable and I appreciate it! :clap:

0 Likes

#52

No problem and I agree with your response. But maybe instead have an edit button in the top right (either in place or next to the map marker icon). Or a manage devices button in the bottom of the room pages.

Right now it takes like 4 taps and scrolls (Settings -> Rooms -> Sean Room -> Scroll to bottom -> Manage devices) when there could be some button to take you directly to the manage devices page for that room.

One more suggestion, maybe on the manage devices page you can group everything by domain and alphabetically on top of that. So all the media_players would be together, all the lights would be together, switches, etc and then sorted alphabetically on top of that grouping. I have a large number of entities and devices and this would help add them easier.

But like I said before very promising start, this has a lot of potential and works very well for a first alpha. Good job :slight_smile:

0 Likes

#53

Not a good start here. Created a room but it’s not finding any devices. I type in something to find and nothing happens.

0 Likes

#54

I have the same Problem. I tried the local IP and my dyndns. Same issue. I can successfully Login and can create a Group but cannot add devices.

Daranto

0 Likes

#55

I’ve deleted the app and re-installed. Turned wifi off on my phone and tried again. Still not working. I log in with a SSL on a custom domain (which should be the exact same result as using duckdns). The app logs in fine, seems my HA fine in settings and has the correct HA version number. I can add rooms, but not add devices. Also, in settings there are no zones.

0 Likes

#56

Same issue here. I can add rooms but cannot find devices to add.

0 Likes

#57

A very promising start here for me (ios 12.2 latest beta). All works good and well. I will update my opinion after I have used it for a bit more.

0 Likes

#58

Would love to take part in the trial. New here and can’t quite work out how to PM you @kikettas

0 Likes

#59

I already tracked the issue here, seems to be a recurrent issue for more people. Feel free to add this description there, so it gets more detailed. :+1:

2 Likes

#60

I’m having the same issue, no devices are showing up.

And as a suggestion if possible, will there be a way to hide certain rooms for each user? It would be great to have my kids room only show their stuff. And limit them access to my cameras or Tv etc.

This is something that is definitely lacking in the Apple home app.

2 Likes