Hassio External access plus HA Dashboard


I have managed to install the Dashboard and was working fine, then I have managed to setup external access with Duck DNS and Let’s encrypt. But obviously the Dashboard stops working as it would need you to go to a different port (80) but the external access sends everything to :8123.

Anyone has any suggestion how to enable both to work? (If I could get the dashboard to work only from local netwrok that is fine too)


Either open the port that you need for external access, or simply browse to the desired port only from local network.
so instead http://yoururl:8123 go the the port that the dashboard needs

Well I tried but it doesn’t work at all as dashboard doesn’t support https and as soon as I have external access setup enabling https the http stops working. :frowning:

So before worked now it doesn’t only https working but that is not supported by the dashboard according to the error message. :frowning:

If you use the NGINX addon you can have both https and http enabled at the same time :slight_smile:

Ah ok I will look ok into that. Have you got a link to the hassio guide by any chance? :slight_smile:

I don’t seem to find any guide on how to do that. :frowning:

Simply install the addon: NGINX Home Assistant SSL proxy.

Then configure it like this:

  "domain": "yourdns.duckdns.org",
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"

Then comment out the SSL in the HTTP section of the configuration.yaml and forward external port 443 to hassio port 443 on your router

1 Like

Thanks, I have tried it but it wont start in the logs it says:

ERROR (SyncWorker_6) [hassio.dock] Can’t start addon_core_nginx_proxy -> 500 Server Error: Internal Server Error (“driver failed programming external connectivity on endpoint addon_core_nginx_proxy (c2e8e2ed6b986f13cd7975207e885e239a5e8ee5776a2e73ba41785b911f1a2c): Bind for failed: port is already allocated”)

I think it is the allocation for the dashboard. But I am not confident with the conteiner technology so I appreciate any advice.

If thats the case simply assign the dashboard a different port :slight_smile:

Sadly the dashboard only works on 80 that is a limitation :frowning:

Found a solution: My continuous struggle with HADashboard

Three is a new version of the dashboard that is on pot 5050 so it Resolved my issue.