Hassio.io tab missing

Hi guys,

Some urgent help wanted. In the last few hours I commented out the discovery: in the configuration file and when I restarted the has.io tab is missing from the left menu. After some searching about what I did, I should have put hassio: if commenting out the discovery. I thought I would access the configuration files at home after work via samba but that’s not even working. So I can’t access the configuration folder through samba or through the configurator add on. I have tried putting the memory card directly into the PC to access the configuration file but cannot find the files needed. I just want to access the configuration file to uncomment the discovery.

Can anyone advise me on how to do this?

I guess I could access from ssh but I have no idea of the commands.

You need to have hassio: or discovery in your config. If you commented out discovery and you don’t have hassio, just add hassio:

1 Like

did you already used samba successfully before? if so please try to access the samba share using the IPv4 address instead of using the devices name.

Yes I have used the samba before. What do you mean use the ipv4?

Well my bad, didn’t fully read your comment

What version of HA did you upgrade from?

If you upgraded from 0.74 and below, you are using ResinOS with Hassio. This means that all your OS commands will be broken because 0.74+ uses hassOS and you don’t have that.

Only way to fix that problem is to reinstall hassio from the ground up.

As @Florian said, if you want to access your instance, you can’t use your hostname anymore because it can’t be resolved. You’ll need to use your ip address (ipv4).

Internet Protocol version 4, which is what is used most places. It looks something like this on your local network 192.168.xxx.xxx. IPv6 is the new one that is hexidecimal and longer like this: 2001:0db8:85a3:0000:0000:8a2e:0370:7334 written in anticipation of the world having more than 6 billion devices connected to the Internet at the same time. :slight_smile:

Yes I know I need to have either hassio: or discover: but I can’t access my configuration file to add hassio: or uncomment discovery. I had samba set up on PC but now it’s all disappeared. Only way I can access the pi is through SSH putty but I have no idea on the codes

First, you need to have a password for samba share. It default starts with null.

  "workgroup": "WORKGROUP",
  "username": "petro",
  "password": null, #<-------- CANNOT BE NULL OR WILL NOT START
  "interface": "",
  "allow_hosts": [

Second, if you upgraded from prior to 0.74 to above 0.74 you will only be able to access your pi’s directories (samba) with your IP address. I.e. 192.168.1.x

Occasionally my hass.io disappears from my left side panel also. It comes back when I do a screen refresh (Function-F5 in my case on a Ubuntu running Chrome box)

I just did an upgrade to the latest version. From the previous version. Not sure the number.

I had a password setup for samba share. Tried using the IP address and I just get “it’s site can’t be reached”

You say I may have to rebuild from the ground up. Can he backup still be used or are they lost too?

do me a favor, go to this area:

Is your host system blank w/ no buttons?

Yes, snapshot should work.

There is no tab for has.io

It depends on where your backups are. If they are on the SD, and you reload HA from scratch, they are toast. If they are on another machine, yes. I just did the same thing (scratched my SD card, did a fresh install, immediately reconfigured samba, restored a snapshot and voila, back in biz).

have you cleared your cache and refreshed the page and restarted after adding hassio: to your config?

I haven’t added hassio: to my config. This I what I am trying to do but I can’t get on to my configuration.yaml file to add it.

My backups are on the SD card.

catch 22 i see.

so when you go to \\ip, nothing comes up?

I’m not sure how you added the password when upgrading then… On upgrade password got wiped or at least should have.