HASSIO network down after router reboot

Everytime I reboot my router HASSIO loses its connection to the network. If I unplug the network cable and reconnect it comes back on. Similarly I can reboot HASSIO and it comes back up.
Any ideas?

Do you have a fixed IP address on your router for Hassio ? If not and you are using DHCP it is possible that you will need the old MAC address in your routers ARP table to expire before Hassio and your router handshake again.

Using a fixed IP address is the best way forward - if you already have then what happens if you power cycle the router instead of a reboot as the power will always go down on a power cycle and Hassio should see that.

Yes I have a static IP set in my router. I’ve tried both a power cycle and reboot. Same result in HASSIO.
I’m also using a wired connection as I thought it may have something to do with WIFI.

Why are you having to reboot your router so frequently? I would look into that first.

I don’t think it should matter how often my router is rebooted. I’m just trying to figure out if it’s in an issue with HASSIO or maybe my RPI3 board.

2 Likes

It just highlights a bigger issue.

1 Like

If you know how to run a ping command start pinging your pi then reboot your router again. Once it is back up does it only reply once you reseat the lan cable?

What happens if you move to another port on your router and try again?

Does the same issue happen to other devices connected to your router when you reboot it?

HASSIO seems to be the only device affected. Below is a terminal session where I was able to ping HASSIO @ 192.168.1.9 and open ssh.
After a router reboot I can no longer ping 192.168.1.9 but I could still ssh in.

PING 192.168.1.9 (192.168.1.9): 56 data bytes
64 bytes from 192.168.1.9: icmp_seq=0 ttl=64 time=2.251 ms
64 bytes from 192.168.1.9: icmp_seq=1 ttl=64 time=3.437 ms
64 bytes from 192.168.1.9: icmp_seq=2 ttl=64 time=29.862 ms
--- 192.168.1.9 ping statistics ---

3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 2.251/11.850/29.862/12.746 ms

MacBook:~ Darren$ ssh [email protected]
[exited]
Connection to hassio closed.

*Router rebooted

MacBook:~ Darren$ ping 192.168.1.9

PING 192.168.1.9 (192.168.1.9): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
--- 192.168.1.9 ping statistics ---

4 packets transmitted, 0 packets received, 100.0% packet loss

MacBook:~ Darren$ ssh [email protected]
[exited]
Connection to hassio closed.
1 Like

Looks like I can still connect via IPv6 after a router reboot but not IPv4. I’m going to try a “my-network” file and see if that changes anything.

That is very strange. What router and model do you have ?

I do not have an issue like that at all - I have a TP Link Archer C2 for reference - cheap and cheerful for my cable provider but it works.

I’m using a tp-link archer c2600 with LEDE. HASSIO on my RPI3 is the only device affected.
I used a usb to install a my-network file with my wifi config and that seems to be working fine.

Glad you got it sorted.

first post perfectly describe my issue but I have the raspberry connected via LAN, how can I solve the problem?

I had to stick with wifi to keep HASS up. Haven’t tried going back to LAN since the problem started,

Same problem here. I am afraid it’s hass.io issue. Before installing hass.io the same hardware worked fine over LAN and once a week router reboot.

I am having this issue also. Does anyone have an idea of how to troubleshoot this. I could do wifi but it seems unnecessary since my pi is beside the router.

Same issue here. On an RPI 4 4gb model. I don’t want to switch to WiFi when the rpi is next to the router. I want the reliability of wired connection.
My router is an ASUS RT-AC68U with latest firmware (router firmware was updated a couple of days ago but even on previous router firmware I had this same issue).

EDIT: rather stupidly, I forgot to try access the IP address of hassio rather than dns name after router reboot. I will give it a go later when the family aren’t all up and on the net to see if it’s just the name that cant connect or ip address to.

UPDATR 2: I’ve rebooted router (and Linksys Velop WiFi nodes). Can’t access http://hassio:8123 but I can get into it from the IP address

1 Like

I’m newbie in Home Assitant. I installed hassio on RPi3 two months ago. I immediately noticed that when rebooting or restart the router, hassio loses the network.
I set a static IP address for hassio in the router.
Then I set a static IP address for hassio (“my-network” and “import from usb”).
I tried changing router.
Nothing helps. After rebooting the router, hassio loses the network.
I see that the problem is not only mine. Has anyone found solution?

Same here. didn’t find any solution.
The only way I find to get around this issue, is by restarting Hassio if pinging the router failed for more than 10 minutes, but this is very dirty way.

1 Like

I hope that I have found solution to this problem.
I configure network not using import from USB Flash, but directly in the “hassos-boot” partition.
On SD card with Hassio, in FAT partition “hassos-boot”, create folder “CONFIG”, in it folder “network”, in it file “my-network” with the contents of known manual, and completely reboot device.
For example my content:

[connection]
id=my-network
uuid=ee48278a-b3a2-4d6b-868e-6030c424c927
type=802-3-ethernet

[ipv4]
method=manual
address=192.168.1.120/24;192.168.1.1
dns=8.8.8.8;8.8.4.4;


[ipv6]
addr-gen-mode=stable-privacy
method=auto

I have two Raspberry Pi 3B. One as reserve. I checked this method on both.

PS: If Windows PC does not see “hassos-boot” partition on the SD card with hassio installed, assign it the letter in “Disk Management”.

1 Like