Hassio nginx-proxy gets ignored

My setup is windows 10 with hassio running in a hyper-v vm as service.
All is running smothly and love it.
Only problem is that i kind of cant get nginx to route… somehow home assistant is ignoring the configs.

I have a duck https://xxx.duckdns.org/ which is available and acessable from outside.
In the router network forwarding i am forwarding all traffic from 433 to the vm network ip 433 port and 80 to 80

And it works like a charm.
Problem is that it seems that home assistant is coming before the ngnix and when try to create a custom folder with a reverse proxy on a folder home asistant gets the request and returns a 404.

How can i get the nginx to route the traffic not the ha?

Tried both addons
Nginx Proxy Manager
NGINX Home Assistant SSL proxy

Do the same, they say they read the sub folder config but don`t route it…

I tried all kind of hacks

with / on begiing with / on end…
And for the simple plugin i edited the config to read the costum config

with config like here Hass.io + Configurator + NGINX + Let's Encrypt = Problem im missing somthing crucial and probably simple… Anyone any ideas???
it is as if nginx is not running at all… i can deactivate both addons and i still can acess ha from outside. Strange.