Hassio on PI4 with official SSD released bios support

Hi, I’m another USB boot freak but really want to run on fully released version at all times (a secure boring guy…). Is there any time estimate when the 5.X version is the one to use under such circumstances?
Thanks

1 Like

OMG! Thanks! Was tearing my hair out. My SSK JMS586 128gb SSD boots in USB3 port with 5.5 just fine… But had issues with Conbee2 not working… Sometimes it just hangs at the UI interface loading screen. Tried deConz but to no avail.

Plugged the Conbee into a usb hub and now it works! (unlike the video, mine always shows the firmware is connected.)

Great to hear that it helped!

I’m currently experiencing the same issue as BVE.

HA 5.3 will boot fine if the SSD is plugged into a USB 2.0 port, or even if plugged in to a USB 3.0 port via a USB 2.0 extension cable. But straight to the USB 3.0 port, or via a USB 3.0 extension cable and no boot.

Setup is a RPi 4B Rev 1.2 (eeprom updated) with the following;

ELUTENG USB to SSD Adapter

Kingston 120GB A400 SSD

It sounds like your enclosure is not supported and will need quirks to work. I use a proper SSD enclosure and that works fine after being updated using the manufacturers update. See here

Thanks. But both the adapter and SSD are confirmed compatible based on this list.
https://storage.jamesachambers.com/popular/

Additionally the adapter is confirmed working on this guide. Installing Home Assistant on a RPi 4b 8GB with SSD boot

Same for me, have you read the post #58 ? :

https://community.home-assistant.io/t/hassio-on-pi4-with-official-ssd-released-bios-support/205935/58?u=olivier974

work great for me, i have a JMicron adapter, look like yours and boot great on USB3! :wink:

OK, It seems I had a ‘dodgy’ Eluteng adapter.

According to Andrew G’s post here the incompatible ones can be identified by the Eluteng logo being on a sticker on the underside.

My Kingspec SSD arrived today, which works perfectly. booting from SSD on USB 3.0.

Just wanted to report that I had success with the following setup:

  1. Followed the directions here to install Raspberry Pi OS first (I used 2020-08-20-raspios-buster-armhf-lite.zip) and configure USB boot
  2. Used belenaEtcher to flash the SSD with the latest 5.x build (hassos_rpi4-64-5.5.img.gz at the time of writing)
  3. Booted off the SSD no problem! Configured a bunch of integrations and so far so good.

I performed a “ha os update --version 5.5” to upgrade from 5.4 and when it rebooted, I now get that it is looking for the SD CARD and will not boot. I can take and load the default 5.5 image to another SSD and it boots fine. Any ideas on recovering the failed update?

How to proceed with this, which command to type in. I do not know which IP address has HomeAssistant, and can not enter the browser with homeassistant.local: 8123 or homeassistant: 8123. How to find the IP address? this is Raspberry Pi 4 / 2Gb firmware hassos_rpi-64 …5.3 img.gz and is on 120Gb SSD SanDisk

Fixed.
After installation, I connected RPi4-RJ45 to router to be able to configure HAssistant with ADDON and now works as it should, hope so!

Has anyone else upgraded from OS 5.2 with SSD+Pi working to OS 5.3? I see two folks posted positive news but wanted to see if everyone has tried it and whether it was as smooth as the above two users indicated.

I had a working set-up on OS 5.2 for a month or so. Then upgraded to 5.5. The process was very smooth and without problems. But after ± 24h the system locked up. This kept happening every day or so. Rolled back to 5.2 and problem is gone. Me I’m staying on 5.2 for now.

Looks like they just released 5.8 as stable production.

Yes saw that today.

But also got a person with problems, his installation wouldn’t start up anymore.
There was a short blink on the ssd and then it stopped, he went back to 5.4 ( seems like there was a problem with his raspberry, version 5.4 doesn’t work…he is going to try a sd card again)

later today I will give it a try, and see if I can get 5.8 to work.

I tried to update to version 5.8 using the UI. But as @DavyRoswinkel mentioned, also on my Pi4 the HomeAssistant did’t start up anymore. I’ll check what’s possible …

I updated and it works fine for me.
My friend is back on a sdcard, as the ssd doesn’t seem to work anymore.
Broken or damaged ssd?? Or wrong settings for the Raspberry to bootup?? I don’t know yet.

I was able to fix the SSD boot problem after upgrading the OS from 5.4 to 5.8: For unknown reason, the boot partition of the SSD drive wasn’t updated correctly. Hence, I executed the following steps:

  • Download HassIO 5.8 image
  • Create an SD card with the new OS 5.8
  • Booting up HA with the new OS on the SD card
  • Shutdown the Pi
  • Copy the files of the SD card boot partition to the SSD boot partition (partition still existed after the OS update from 5.4 to 5.8)
  • Reconnect the SSD to the Pi4
  • HA boots from the SSD again as before.

I understand, that booting HA from SSD is not supported (yet). Hence, booting from the SD card and keeping the data files on the SSD might be hassle free for future updates.

1 Like

It is supported: Installing Home Assistant on a RPi 4b 8GB with SSD boot