Hassio on PI4 with official SSD released bios support

Here it is: https://github.com/raspberrypi/rpi-eeprom/blob/2a8c2e77c34d16554956e5ca56697eba9611d2ad/firmware/release-notes.md

2 Likes

Calvin, many thanks for this.
As stated it is the ‘Stable’ release but is still a ‘Pre-Production’ release (ie does not have the ‘easy installation’ method that should soon be released, though having had to install the new cooling firmware manually in a quite agricultural manner, so maybe this is as good as it gets).
Thanks Again

I use scandisk also and every year I make the habit of imaging the sd to a new sd the cost being £10 and about 30 mins worth of inconvenience. However agree when a production stable release of the bios update is available for my PI4 I may move over to SSD, more so for speed but also some added reliability. Bear in mind any storage can fail at any time- i’ve spent close to 2 years with developing my hassio build and would be devastated loosing it, I keep weekly backups on my NAS, my pc hard disk and cloud storage just to make sure :slight_smile:

1 Like

same here making HA snapshots to cloud but still no good feeling about SD (due to bad experiances)
So thereofre hope that when bios is official there will be a hassio image with USB support

Can you share the install? is that docker based?
Like to find supervicor for docker installation

Hi yes, it’s Docker based. The instructions to get the RPi 4B to boot is here:

It’s been updated to reflect the stable version of the eeprom that supports USB Boot released the other day. The instructions for the HA Supervised install are here:

Good luck, although you shouldn’t need it. I’m using the Geekworm X857 NVMe tray and an ASENNA msata 120GB SSD, both from amazon. Incidentally, the Bruphny aluminium case with fan, also from there, fits perfectly with the 4B and SSD tray combination and gives a decent temperature reduction.

3 Likes

Thanks john your installation works really nice but when I boot with SSD the Zigbee conbee 2 stick shows in deconz firmware NOT connected, tried many things but can’t get it working, with SD all ok but SSD conbee / deconz troubles :frowning:

Hi Peter, I don’t know anything about Zigbee. I’m just wondering if the USB ports are connected to RaspOS rather than the Docker container. Here’s an article that deals with connecting a USB port to a docker container.

1 Like

My knowledge does not go far enough at this time to check if the deconz container hads access to the USB and that specified stick shows as /dev/serial thing :roll_eyes:
/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2213773-if00

And did not find a syntax to allow the deconz container to access that or see if it is blocked or not connected for passtrough
Tomorrow some further testing …

Hi Peter, I have the same issue with Conbee. For me the problem seems to manifest when I use the USB 3.0 ports for both the conbee and the usb drive. If I switch to the USB 2.0 ports for both things and leave the usb 3.0 ports clear it works well. I’m guessing it’s a power issue, maybe the Pi is not getting enough juice… I haven’t investigated further.

Looking forward to hear what you might find about this. :slight_smile:

Hi Iuri,

I created a bug topix at github, lets see what they are telling, and I prefer not to use usb 2 for my SSD, thayt would harm performance quit a bit and don’t know if the USB PI firmware boot is working on USB 2

P.s. did used my 65W power warp charger of my one plus phone, same result

1 Like

Fix deCONZ and Conbee stick not working when using with an SSD on a Raspberry Pi

1 Like

@john5 ask me a question I doing this procedure I install the image of the hassio in the ssd that he will boot the HA perlo SSD?

Hi Glaucer,

yes - this procedure is to install on a RPi 4B. If you are installing on a 3B or 3B+, it is much simpler, as they can both boot straight from an SSD without firmware updates. However, the USB 2.0 on the 3B/3B+ limits the transfer speed of the SSD .

Hello @glaucer,

have you succeed in?

I try the tutorial, step by step, but at the end, when i remove the sd card, the RPI4 boot and do nothing after the boot…no activity on the ssd adapter.

I try the Hassos 4.11 fresh image and i try my 0.111.1 (working) cloned from a sdcard without any success…

Any luck?

The 5.1 release seems to have resolved some of the USB to NVMe compatibility issues. I had tried two different USB 3.0 UASP capable adapters (SSK’s SHE-C325 and Plugable’s USBC-NVME) and both wouldn’t boot with a Samsung 970 EVO 500GB (MZ-V7E500BW) SSD. The Plugable adapter will now boot (though it acted weird at first…throwing a website 500 error as it lost the USB drive, then when I rebooted it to solve that issue, it said it was unable to find the USB SSD 60+ times before booting). The SSK device will still not boot. Stops at the “Read start4.elf” process.

I would like to report my experience.
Currently running HASSOS 5.1 64GB on a Raspberry Pi 4b 8GB and booting from a Kingston A400 SSD SA400S37/960G (Yes 960GB because… …i can! I am planning using home assistant as a file server also) with a Sabrent SSD enclosure, on a RSHTECH USB active Hub (with external power).
I restored my backup from my last snapshot created before i start the procedure with moving to ssd boot.
That means, in less than an hour moved from a SD to SSD having exactly the same “smart home server” that i had before… WORTH IT!
I will give my feedback again if something goes wrong…

PSA: While not Hassio specific there seems to be interference from the Pi4 USB3 ports when using an SSD (or perhaps only with some USB3 cables?). Using a hub or short USB extension cable seems to fix it. I tried two different sticks before figuring out the issue. Both would startup and could be seen but I could never add a node.

1 Like

And …something went wrong…
Suddenly there was no feedback from Pi as the system went down. Rebooted and after waiting some minutes with no connection on Home Assistant, i went back to SD Card.
I guess i will wait a little until the HASSOS 5 gets grown up :slight_smile:

I’ve just migrated to 5.1 64 on Rasperry Pi 4. booting from a Toshiba X10 Portable SSD 250GB. Did a backup and partial restore from 4.12. Did a restore on everything apart from the OS - so not a wipe and restore. Had some issues getting Maria DB back up (recorder, log, history issues). Uninstall/Reinstall of Maria then started Maria - pasted old config into recorder.yaml and Maria config then checked logs all good.

Will report back - looks like all entities imported ok - all integrations good. MQTT sending messages ok.