Hassio on PI4 with official SSD released bios support

Hello @glaucer,

have you succeed in?

I try the tutorial, step by step, but at the end, when i remove the sd card, the RPI4 boot and do nothing after the boot…no activity on the ssd adapter.

I try the Hassos 4.11 fresh image and i try my 0.111.1 (working) cloned from a sdcard without any success…

Any luck?

The 5.1 release seems to have resolved some of the USB to NVMe compatibility issues. I had tried two different USB 3.0 UASP capable adapters (SSK’s SHE-C325 and Plugable’s USBC-NVME) and both wouldn’t boot with a Samsung 970 EVO 500GB (MZ-V7E500BW) SSD. The Plugable adapter will now boot (though it acted weird at first…throwing a website 500 error as it lost the USB drive, then when I rebooted it to solve that issue, it said it was unable to find the USB SSD 60+ times before booting). The SSK device will still not boot. Stops at the “Read start4.elf” process.

I would like to report my experience.
Currently running HASSOS 5.1 64GB on a Raspberry Pi 4b 8GB and booting from a Kingston A400 SSD SA400S37/960G (Yes 960GB because… …i can! I am planning using home assistant as a file server also) with a Sabrent SSD enclosure, on a RSHTECH USB active Hub (with external power).
I restored my backup from my last snapshot created before i start the procedure with moving to ssd boot.
That means, in less than an hour moved from a SD to SSD having exactly the same “smart home server” that i had before… WORTH IT!
I will give my feedback again if something goes wrong…

PSA: While not Hassio specific there seems to be interference from the Pi4 USB3 ports when using an SSD (or perhaps only with some USB3 cables?). Using a hub or short USB extension cable seems to fix it. I tried two different sticks before figuring out the issue. Both would startup and could be seen but I could never add a node.

1 Like

And …something went wrong…
Suddenly there was no feedback from Pi as the system went down. Rebooted and after waiting some minutes with no connection on Home Assistant, i went back to SD Card.
I guess i will wait a little until the HASSOS 5 gets grown up :slight_smile:

I’ve just migrated to 5.1 64 on Rasperry Pi 4. booting from a Toshiba X10 Portable SSD 250GB. Did a backup and partial restore from 4.12. Did a restore on everything apart from the OS - so not a wipe and restore. Had some issues getting Maria DB back up (recorder, log, history issues). Uninstall/Reinstall of Maria then started Maria - pasted old config into recorder.yaml and Maria config then checked logs all good.

Will report back - looks like all entities imported ok - all integrations good. MQTT sending messages ok.

Hi James, how are things for you now, a week later? Can you confirm your install is full HassoOS, not supervised install? I’m about to begin on the SD card to SSD journey.

I can confirm that I have been running Home Assistant OS (5.1 64 bit) on a Rpi 4 using a USB3 drive for a week. NO SD card. So far I am extremely happy. No issues and system seems to be faster and stable.
Check this guide. It’s in German but I use google to translate it.

https://forum.smartapfel.de/forum/thread/6048-anleitung-installation-von-home-assistant-auf-einem-pi4b-mit-einer-über-usb-ange/?postID=90748#post90748

Since August 1, 2020 so far good.
You can use following: PI4 HASSOS
You can use
Development 5 build 0 or Development 5 build 1

Please elaborate how exactly…

Check this guide. It’s in German but I use google to translate it.

https://forum.smartapfel.de/forum/thread/6048-anleitung-installation-von-home-assistant-auf-einem-pi4b-mit-einer-über-usb-ange/?postID=90748#post90748

I did same on PI4 4 GB and 8GB. Use following steps:

  1. Boot from a standard microSD card with the latest Raspberry Pi OS on it.
  2. Update your OS and firmware by typing:
        sudo apt update
        sudo apt full-upgrade
        sudo rpi-update
  1. Edited the rpi-eeprom-update file and changed the “critical” value for the FIRMWARE_RELEASE_STATUS option to “stable”, using sudo nano /etc/default/rpi-eeprom-update.
  2. Install the latest bootloader by typing:
       sudo rpi-eeprom-update -d -a
  1. Reboot the Pi and check the bootloader version by opening Terminal and running:
       vcgencmd bootloader_version

Result:

       Jul 16 2020 16:15:46
       version 45291ce619884192a6622bef8948fb5151c2b456 (release)
       timestamp 1594912546

After rebooting PI you’ll see:
pi4

  1. Download HassOS 5.2 (latest) for PI4 64 bit.
  2. Use balenaEtcher to burn image “HassOS 5.0” to SSD drive.
  3. Turn off PI, remove SD card connect SSD.
  4. Turn PI on.
  5. Navigate to http://PI4_IP_Address:8123
  6. Wait for setup to finish.
  7. After about 5 min it’s done.
8 Likes

Vlad

Thank you for such a clear walkthrough!

Followed this process and it worked perfectly with HassOS 5.2.

Only difference was that after eeprom update the bootloader version was dated 3rd September not 16 July - so maybe there is an updated version?

I restored everything from RasPi3B snapshot (other than 0.114 OS).

It has only been a couple of hours but all add-ins are currently working without any issues:

  • Node-red
  • UniFi controller
  • deconz (with Conbee II on an extension lead - all sensors and lights working)
  • Mosquitto broker (all entities showing as available)
  • File editor (and also Notepad++ with SSH)
  • Samba share
  • Home assistant Google Drive Back up

Hardware used:

  • RasPi4 4gb
  • Crucial BX500
  • Simplecom SE221 Enclosure

This SSD and enclosure also previously worked on my RasPi3B.

If it is of any use to someone, the following custom cards also working without issue (all were previously installed manually on RasPi3b, and restored from snapshot - I did try to link but as a new user I couldn’t have more than 2 links):

  • auto-entities
  • battery-entity
  • bom-weather-card
  • fan-control-entity-row
  • simple-thermostat

And these integrations in addition to those mentioned above:

  • Daikin AC
  • Google Cast
  • Logitech Harmony hub
  • TP-Link Kasa Smart

Hope the above is useful for someone.

Once again, thanks to the community for all the help and assistance in making this work.

Rob

Rob, it’s updated version.
Glad it’s helps.
Thank you.

Since I have a nvme drive that I’m not using,I’m thinking about using it for HA install. I have a couple items I’m looking at,but wanted to make sure that they would work. Going to use the instructions.
Boot SSD
SSD Board
Power
Enclosure
Power adapter

You should probably verify that the piggyback board that hosts the NVME drive supports UASP for the storage access. (That’s USB- attached SCSI protocol.) It will give you better performance than the plain vanilla “USB Mass Storage Bulk-Only Transport” storage interface since the host OS can have multiple queued I/O requests pending against the device, improving the throughput. The Raspian kernels on the Raspberry Pi support this; I have no idea what HASS-OS uses as a Linux kernel and if it has this support turned on.

That product page on Amazon seems to not mention UASP support, so that’s a little notable by its absence.

1 Like

Found this on their wiki page…
Q7:Does the X872 interface support UASP?

A7:This is not tested. Here is the chip information for your reference: The JMS583 supports TRIM to the SSD and can transmit and receive data by both of USB Mass Storage Class Bulk-Only Transport (BOT) and USB Attached SCSI Protocol (UASP) to and from the host respectively.

Everything seems to be working at the moment. I had a SSD and adapter from a previous project and they worked fine.
SSD
Adapter

I followed the directions here…Boot from SSD

I stopped at “The second command will show us what boot order we are using. We are looking for 0xf41 as the BOOT_ORDER value.” After this I shutdown removed the sd card and plugged in the SSD and booted up.

Everything booted as if I was still using the sd card. Have to see how things are in a few days.

Hello,
Any ideas what is happening here?
Just started to migrate to the ssd following the steps by vlad…
I’m using kingston a400 120GB and fujtech ssd case (jmicron jms578 chip)

Is your ssd connected to USB3? Try USB2
You might also consider disabling microSD checks to avoid flooding output/logs by those mmc0:sdhci register dumps.

BTW do you guys know, what is causing, that Pi4 boots from SSD for the first time, but after reboot (power toggle) it never boot again reseting itself again and again?