HASSIO on RESINOS on ODROID-XU4 is this possible?


I am currently running HomeAssistant / Hassio on a rpi3, but would like to run it on an ODROID-XU4 - is this possible ? RESINOS is available for the ODROID, how simple would it be/what would be required to get Hassio running on this setup ?


I have HASSIO running on an ODroid XU4 using DietPi and docker. The Hassio instance is housed in the docker image.

Are you happy with the odroid? I am currently looking into it. Would a native home assistant in a virtual env work? And do you think the gpio could be addressed from home assistant? Perhaps with the Shifter Shield.

Could you explain how you got that setup running? I tried using the hassio_install script but getting an error about missing landingpage image

If you install DietPi OS, they have Home Assistant as a package in their package manager to get it going. I use to do docker + hassio, but dropped and use the Home Assitant package now it since I gained no benefit from putting it in docker or the community addons that only added security issues.

So far my ODroid XU4 has worked flawlessly with no hiccups. I’m extremely happy with it :slight_smile:

My end game is to have everything containerized on my Odroid. But I’ve ran into the problem I stated above.

Looks like I’ll have to do it all manually. If I find it too problematic I will probably go the direction you ended up going.

Thanks for the reply:)