HassIO stops responding every so often

Originally I had HA installed on a standalone rPi4B-1GB with SSD.

I tried moving deCONZ over to Docker on my Open Media Vault (OMV) rPi4B-8GB server with SSD, but HA still hung after a while.

Ended up moving HA over to Docker on my OMV server as well. HA now running smoothly again.

Same problem here. Rasp 4 4 Gb RAM. Every 8-12 hours it freeze. No CPU or memory spikes

1 Like

It would appear there a bug in more recent builds.

Pie 4 8gig running on a ssd.

No spikes no apparent error just the freeze.

2 Likes

I bought a Home Assistant Blue, and for the past 3 weeks, I have been experiencing the same thing. Home Assistant becomes unresponsive and must unplug and plug back in for it to start working again. I am not sure if it has to do with heat, which I doubt, but there is something going on.

1 Like

I had a very similar problem. Downgrading back to HassOS 5.4 solved the problem for me.
Ever since (3 weeks ago), it has been stable and no more network issues. Everything after 5.4 makes it unstable.

Nothing I could track indicated any issue: temp OK, power supply OK, memory OK, network otherwise stable, SSD on USB hub with own power source … You name it I tried it.

There are multiple Git issues raised, but none seem to make progress nor show any indication that someone is working on getting it resolved.
It is suggested that the logs to resolve it are not provided, yet I have seen Git issues where logs were included, but nothing moving. I’m not an expert, so I can’t judge if the logs are sufficient and what is required.

2 Likes

I’m running an Rpi4 8GB boot SSD and I’ve never had a problem. I started with version 5.0 and gradually went through all the versions. Today, Rpi is working on Home Assistant OS 6.1 and the system is stable.

My Raspberry Pi 4B (8GB, running from SSD) was running for months without any problems until it stopped responding every so often. After a lot of trail-and-error I found out that the InfluxDB addon was the culprit. In hindsight the problems started after I installed the addon.

I nailed it down to the official Ring integration. When turning it off it has been running for weeks just fine.

Not having Ring integration enabled nor installed. But I have the same problems: Freezing.

I’m not mad, that no one is working on it (as far as I see, it’s very difficult). But I think, it’s pretty bad, that - at least from my point of view - there is no way to debugg that. And as far as I know, Home Assistant OS has not enabled monitor output (I couldn’t get it working on my Pi4). SSH Access is either available for developers or through a SSH Container (which is not the same view on the system for debugging hardware related issues). There is also no way to send all (system and home assistant) logs to a remote syslog server (this really makes me angry). All Logs are also cleared after a freeze+reboot. There are no ways to send an alarm on critical memory, cpu, temperature nor failed system procedures (like I/O errors). And as far as I understand, the dev team isn’t interesseted in giving people this options to be able to debugg such stuff - as far as I remember, they are not working on a “remote syslog” feature at the moment. Why?

Did anyone tried that?

Regards,
Jens

3 Likes

Just a check-in after more than 2 months with a 2GB swap: not a single hang up, memory stable in 70-85% range and never exceeding 90%. I am now certain that exhausted system memory was the cause of my issues, although I acknowledge that there may be other factors at play for other people.

3 Likes

Mine Home Assistant version on Pi 4 with SSD is also still hanging after a day. I tried to do the reboot fix, reboot the system every 24 hours but that doesn’t help. Still hangs after a full day. And the strange thing is that I see when it hangs that it uses the internet a lot. You can see on the router the UTP connection led is blinking

My pi4 4gb ram and SSD also now suddenly ran into issues after running fine for over a year.
It’s quite warm when it becomes unresponsive and stays warm (fans ramp up). I cannot SSH into the pi anymore, although I can ping the device. I also cannot access the logs over the network anymore. Rebooting helps, but ofc then there are no more logs available.

I just can say, that I have constantly the same issue.
My setup is based on RPI4 8GB with SSD boot and HassOS. (few months ago I had RPI3 with SD card).
Im using few integrations like Adguard, Node-Red, Zigbee.
Don’t know what is the reason - but the operating system is unresponsive, even scheduled restart does not solve the issue.

From the logs I see:

  • Failed to to call /network/info -

  • Failed to to call /resolution/info -

  • Failed to to call /os/info -

  • Failed to to call /addons -

  • Failed to to call /store -

  • Client error on /resolution/info request Cannot connect to host 172.30.32.2:80 ssl:default [Connect call failed (‘172.30.32.2’, 80)]

  • Client error on /os/info …

  • Client error on /addons …

  • Client error on /store …

  • Client error on /info …

  • Error executing query: (sqlite3.OperationalError) disk I/O error (Background on this error at: https://sqlalche.me/e/14/e3q8)

The funny thing is that it somehow works - like some (not all) scripts invoked from lovelace card that send a command to Broadlink work, but I can’t for instance connect to SSH

i do the same - restarting my Pi at 3:00 am - but from time to time it still happens.

And if it happens the leds of the network-interface still light up after disconneting it from the switch. that shows, that the network-interface-driver seems to get stuck.

some other users also report this. if you could reproduce it … we are not alone… :wink:

Same thing here. Restart at 01.00 am every day but occasionally get stuck anyway

After removing the InfluxDB addon the time between hangs increased, but they still happened every so often. I decided to monitor the CPU temperature via Glances. After moving my Pi to a different location the mean temperature dropped approximately 10 °C. After that no more hangs anymore.

what temperature did you get before temperature drop?

Monitor your RAM usage! As soon as my RPi3 has less than 50–100 MB of free memory, the CPU load goes up, then the temperature rises and finally the Pi becomes unavailable.

I found out, that the history recorder was the cause. My DB was 65 MB in size even when I had only 24h before auto-purge. It seems the sqlite keeps a copy in memory all the time.

I added an SQL sensor to find out, which where the worst memory hogs:


sensor:
      - name: DB worst entity
        query: 'select sum(l) as bytes, entity_id, count(l) as "count" from (select length(attributes) as l, entity_id from states order by l) group by entity_id order by bytes desc limit 1'
        column: 'entity_id'

(Or you could open the database e.g. with SQLiteStudio and enter that query.)

Turned out, that it was no good idea to have the Squeezebox media players in history, because each entry is around 4 kb.

After removing the media players from the recorder, the database is only 12 MB and now I do not have any RAM issues any longer.

recorder:
  exclude:
    domains:
      - media_player
1 Like

I have the exact same problem. I have been using HassIO since the beginning on a Raspberry Pi 4 8GB model with a SD card.

No CPU or memory spikes, no apparent error just the freeze :frowning:

Guys watch out temperature. My rpi4 CPU was around 70 ° (which is quite normal), but after I cooled down to 35 ° it stopped the error with the HA freeze.
I think that probably it was a faulty temperature sensor on the RPI CPU.