Hassio VMDK in ESXi 6.5?

Why another container for nodered? If you use hassio plus the addon it is in another container anyway.

Try to update the apt cache first.
sudo apt-get update && sudo apt-get install telnet
(yeps, it’s getting a bit offtopic here :thinking:)

No, the node-red connection to home assistant is not via mqtt.


All ok, now.

I tried and this is the result:

[email protected]:/usr/src/node-red# telnet 8123
Connected to
Escape character is '^]'.
^CConnection closed by foreign host.
[email protected]:/usr/src/node-red# telnet 1883
telnet: Unable to connect to remote host: Connection refused
[email protected]:/usr/src/node-red# telnet 1883
Connected to
Escape character is '^]'.
^CConnection closed by foreign host.
[email protected]:/usr/src/node-red#

I tried first the HA port, 8123 and seems ok, than MQTT, but was not installed within HASSIO.
Then I installed it and it’s working

So seems all should be ok, but…

I did not answer your message because of the message of @nickrout stating that node-red is not connected via MQTT. As far as I know node-red is just MQTT in and out. So that is why I stated that it is just another connection to the MQTT broker. But is it working now?

Nope, it’s not working

In the meantime I have opened a specific thread on this

The node-red integration with home assistant uses the ha api, not mqtt.

Thanks for clarifying that. Very nice implemention method.
Haven’t played with node red since I switched to HA (from Domoticz) a few weeks ago.

I see you have a lot of replies over there. Hope it works out for you in the end.

1 Like

I am trying to do this as well and also use the iOS app. I can get HASS,io up and running fine via the vmdk from https://www.home-assistant.io/hassio/installation/. But i am running into what i think are ipv6 issues due to the ipv6 of the provisioning stack layer. I have ipv6 turned off on the default TCP/ip layer but i guess esxi 6.7 use ipv6 for the provisioning layer which.

I think this is creating an issue for the authentication procedure of the iOS app and i am running into the invalid uri redirect bug. Have any of you guys run into that as well?

For reference the thread below is the bug i am running into:

figured it out. Apparently at least for me my base url was misconfigured.

Solved the problem that it is hanging on fast init done. Just change the controller location to SATA

Not sure what im doing wrong here but cannot import that vmdk file…

i get this error…

[[email protected]:~] vmkfstools -i hassos_ova-2.12.vmdk hassio.vmdk
DiskLib_Check() failed for source disk The system cannot find the file specified (25).

Hi @Antasp3136

I’m not using ESXi and neither Hassio VMDK

I moved to Proxmox as virtualizer and installed Hassio in Docker

How do you like proxmox? Is the performance good? Do you have any other vms running on it?

Im thinking of setting up the baremetal version of hyperv server and using the windows admin center tool to manage it. Ive messed with it before and it works well really good performance and setting up vms overall is easier… Esp if you want to copy a vhdx file to another system and just attach it and go.

I like very much Proxmox. I have never used before ESXi, so for me Proxmox is simpler for what I have to do.
I have two VMs with Hassio, one for test and one for production.
And another very light with just Linux.
Hassio has a lot of add-ons, starting from motioneye.

If you’re still looking you could be a guinea pig for this guide.

I was running into the same problem and I think I figured it out. I created my vm as ubuntu x64, 2 cores, 4 gb ram, deleted default disk and added the converted disk like you set. I changed the disk from scsi to ide 0 master. Changed boot to EFI. Then I was able to boot the guest using the hassio vmdk in esxi 6.7

How do you disable it on the vm / Esxi ?