HassOS does not support RPI 4 - 8GB

ah, got it, used this and it seems to come up

Thank you so much!

Sounds like a STUPID noobs question BUT:
Where can one download the pre-release image for PI 4 8GB?

Thanks again for everything you and your team do!

1 Like

Click on assets and download the correct image.


Thanks @ASNNetworks!

New to HomeAssistant and bought the 8GB Raspberry Pi 4B.

Using the Pi OS I ran the boot loader update utility to grab the soon to be released version suggested by eric73 and updated the board. I then flashed the HA 4.11 version from the HomeAssistant web site and it is running fine.


Do you have any instruction for that? Thank you

1 Like

Here is what I did (as best that I can recall)

  • updated Pi OS to get the current EEPROM utility

  • edit ‘sudo nano /etc/default/rpi-eeprom-update’ and change from ‘critical’ to ‘beta’
    $ sudo nano /etc/default/rpi-eeprom-update’

  • run and confirm you see the updated July version
    $ sudo rpi-eeprom-update

    CURRENT: Thu 16 Apr 17:11:26 UTC 2020 (1587057086)
    LATEST: Thu 16 Jul 15:15:46 UTC 2020 (1594912546)

  • Install the updated EEPROM image and reboot
    $ sudo rpi-eeprom-update -a
    $ sudo reboot

  • Check it is installed
    $ sudo rpi-eeprom-update

    CURRENT: Thu 16 Jul 15:15:46 UTC 2020 (1594912546)
    LATEST: Thu 16 Jul 15:15:46 UTC 2020 (1594912546)

I then flashed the latest HomeAssistant image on the SD card and it worked as it should.

1 Like

Any update on this? I tried the steps above from @sillygoose and it did indeed update to the latest eeprom (July 31 in my case), but when I try booting to HA it still just boots to the same screen as mentioned by the OP. I have tried HASSOS versions 4.12 and 5.1. Both had the same result.

Just wanted to post an update in case someone else has this problem. I ended up trying the 64-bit version of 5.1 and that got me past this issue. Apparently the 32-bit version still doesn’t work.
Specifically, I downloaded this image.

I’m using PI4 - 8GB + SSD.
Installed HassOS 5.0 for PI4 64 bit on SSD.
Good and fast.
I used build 0 Development 5 build 0

1 Like

There is a newer version of the following step-by-step guide in the Community Guides section:

So the following text is outdated!

Step by step guide to run HA on a RPi 4 8Gb with SSD boot

Update the boot EEPROM firmware

RPi 4 has a boot EEPROM (while RPi 3 did not!). You have to update that EEPROM to the latest firmware (2020-09-03) which enables USB boot. To update the EEPROM you have to temporarily install Raspberry OS. I used an SD card for this. The steps are described here: https://www.raspberrypi.org/documentation/hardware/raspberrypi/booteeprom.md
The basic steps are:

Edit the rpi-eeprom-update file and change the FIRMWARE_RELEASE_STATUS from “critical” to “stable”:

sudo nano /etc/default/rpi-eeprom-update

Change the file, save and exit nano. Then…

sudo apt update
sudo apt full-upgrade
sudo reboot

Let the system reboot. Then check the EEPROM version using…

sudo rpi-eeprom-update

This should at least report firmware 2020-09-03.

Launch raspi-config

sudo raspi-config

then Boot options --> Boot Rom Version --> latest -> Ok -->
when the system asks to “Reset boot ROM to defaults” select No (!!!) to use the latest boot ROM.
–> Boot Order --> USB Boot --> Ok --> Finish --> Reboot

Flash Home Assistant to SSD
Now download the latest Home Assistant 5.x OS from here:

Look for the latest “Development 5 build X” (5.2 at the time of this writing).
Open the “Assets” panel under the list of changes to see the downloads.
Find the image hassos_rpi4-64-5.X.img.gz - make sure it is rpi4 (not rpi3) and 64 bit.

Use Balena etcher or a similar tool to flash the image onto your SSD.
(Yes Balena can flash to SSD, not only SD!)

Start Home Assistant

Plug the SSD into the Pi, take out any remaining SD card and boot.
Check http://homeassistant:8123 on your network or use Port 8123 with the IP that your router’s DHCP has assigned.

WAIT. WAIT more. It takes at least 30 minutes!!!
Check http://homeassistant:8123 on your network or use Port 8123 with the IP that your router’s DHCP has assigned. WAIT more.
The boot time is extremely long. And it stays long with each reboot!
UPDATE 2020-09-27:
If you find that the boot process takes extremely long please consider this solution: @maxym mentioned in this thread that long boot times can be circumvented by attaching the SSD through USB 2 instead of USB 3. I can confirm this! So I suggest that if your system takes 30 minutes or longer to boot, then power off, switch over to USB 2 and try again. Hopefully these boot time meditations on USB 3 will disappear with the stable version of HA OS 5.
UPDATE 2020-09-28:
I finally found that the long boot times on the USB 3.0 ports are related to certain features of the chipset in the SATA to USB 3 adapter. I use a Sabrent EC-SSHD which is based on a JMicron JMS583 chip. Sabrent offers a firmeware update for the adaptor that solves the issue. After the update HA boots within 3 minutes from my SSD connected to USB 3.0. I guess other vendors of JMS583 based products will offer similar updates. So if you find that your USB 3.0 boot times are too long I suggest that you first check whether USB 2 is faster. If this is the case then look for an update for your adapter firmware – or stay with USB 2.

Once started the system works flawlessly and is extremely fast and stable!
HA restarts are very fast too (they are no reboots as one might think).

Updated the posting above to mention a finding of @maxym in this thread that long boot times on RPi4 may be connected to the usage of the USB 3 ports. If this happens to you try to use the USB 2 ports. This helped me a lot and loss in transfer rate is not very noticable.

Out of curiosity if i just want to use the 8gb raspberry pi 4 with an sd card i don’t need to install the new EEPROM right? Also can i use the 8gb raspberry pi 4 with Development 5 build 2?

Yes and yes. I tried this before I installed the SSD.
But I guess you are aware that the SD wears rather quickly under HAs constant database writes and that HA is much faster with SSD.

I copied my step-by-step guide above to the Community Guides section:

It now also includes a new solution for long boot times. This solution is based on a firmware update for the JMicron JMS583 bridge chip in some SATA to USB 3 adapters and casings.

Hi there, I have flashed Hassos 5.0 on my USB drive and tried booting on raspi4 model b 8gb, it went fine at start and is stuck at a position where I am completely blank to how to solve this. Also facing same issue with HassOS 4.13 rpi4 64 bit. Also facing similar issue with 4.13. The error is shown in the attached images:

I am not a linux expert so not understanding all these error messages…now it’s giving error “Dockers:437 blocked for more than 120 seconds”…

Have the same error!

Just buy an original Samsung Class10 SDcard. Mine solved by changing an SDcard…earlier one was fake samsung SD card. When your SDcard is corrupted or of slow speed than Class10, then this issue occurs.