HassOS using HyperV - abandoned. And Harmony missing :(

Hi all,

I’ve casually been tinkering with HassIO for a few months, but with the new HassOS 3 release and a Christmas holiday, I thought I’d go for a clean installation from scratch. Unfortunately I’ve had to abandon it, because:

  1. I followed the instructions at Hass.io On Hyper-V - Step By Step to create a new HassOS Hyper-V virtual machine on my Windows Server 2016 Essentials box using the “hassos_ova-3.7.vhdx”. It seemed to work OK, and I could go on to create a user etc. through the web interface. Good!

  2. Home Assistant correctly discovered all my Google Chomecast devices I have around the house, but didn’t discover my Logitech Harmony Hub. Furthermore, when I went to manually add the Harmony through the GUI, there’s no sign of Logitech or Harmony devices to choose from. Am I going mad? What would cause Harmony to be missing from the long list of potential devices to integrate?

  3. I tried restarting the VM. It doesn’t reboot all the way, instead becoming stuck on a “HassOS Boot Menu” in which “1: Autoboot” doesn’t. “2: Boot system 0” did work for a couple of reboots, but now just causes the VM to turn off. “3: Boot system 1” doesn’t.

I’ve deleted the VM and re-created it a couple of times now. The above is all repeatable for me. Does it work for anyone else?

Perhaps I should back off from HassOS / HassIO / Home Assistant for another few months? Any suggestions gratefully received! Thanks!

@DavidLewis welcome to the forum. I have had similar results running in virtualbox on windows. I don’t recommend it at all.

Do you have an old computer lying around you could install Ubuntu on ?

@nickrout thanks. Yes, I do have an old laptop I could use, but it seems a shame not to use the server I already have… Why do you suggest Ubuntu rather than HassOS? I’m so confused - HassOS is supposed to work specifically in Hyper-V, isn’t it?

And what about the fact that Logitech Harmony is missing from the long list of devices for manual integration - surely that’s not Hyper-V related?

It could be, does multicast work with hyper-v.

Not every integration is available via the GUI. A lot of integrations require yaml configuration.

I ran HA on hyper-v for a long time. I highly recommend you to go the proxmox or esxi way simply because of the fact that hyper-v doesn’t support usb passthrough without paying a hefty license price. Both Proxmox and ESXI support this out of the box.

Ahhh, I don’t know. Thanks for the pointer; having read around the subject, I think I’m having mDNS problems with my router.

I hadn’t appreciated that - thanks for pointing it out :slightly_smiling_face:

1 Like

I’ve such a lot to learn! Thanks for the suggestion. I’ll probably try Proxmox…

I am new to HA - 3 weeks now. I started first on Pi but quickly moved to the latest VHDX version on my Win 10 box and will soon move it to my production 2019 server farm. I found the ability to snapshot, backup, and revert changes in HyperV while I develop essential, not to mention the speed bump over Pi. I now have Elk M1, Insteon, ISY, Denon, Epson, and full Alexa custom integrations all up and running flawlessly. I have zero boot or discovery issues. I have not needed to do USB pass-through yet. I don’t foresee any licensing issues, rather, functional ones that I might need to overcome. Great article about HyperV passthrough here and a great solution I may use called VirtualHere (for a one-off USB-to-serial solution I may need here https://www.virtualhere.com/. So far I have no plans to revert anything back to Pi or anything else, smooth sailing.

FYI, moved my Win10VM over to Win2019 Hyper-V and had an issue where my ISY integration would not work. Everything else worked fine, even though the Intel CPU’s and memory I allocated on the HyoerV were different. I decided to continue developing on Win10 for right now and troubleshoot the issue later as my move to 2019 was to enhance backups via DPM. Not concerned that I wont find the issue when I do the migration however. Everything else still perfect on HyperV Win10.

I do all my reboots through the web interface where practical, I have seen occasional errors on boot especially if I’ve shut the VM down from Hyper-V manager. I suspect it doesn’t cleanly stop all the services etc if you do it from there.
You’re using a newer VHDX than I’ve tried there - it must have been updated recently. Seeing this, I might hold off on migrating to the newer one myself…

It’s not abandoned. On https://github.com/home-assistant/operating-system/releases/tag/5.12 you Can download the .vhdx.xz file. Exact it with winrar and you are good to go.