Home Assistant Community

Have I bricked my device

#1

Been getting my first system set up over the last week (Node-Red, Tuya, HA entties) and just added z-wave. Was super happy when I got my first z-wave sensor talking to the aeotec z-wave stick.

Then, did a restart. My devices were gone. Tried to remove the z-wave configuration to re-do it, then the entire system won’t start. Can ping , no web on port 8123.

Unfortunately, I don’t have SSH access or SMB (SSH I had set it to manually start)

Have I completely hosed myself out of the system and need to rebuild?

I cannot seem to capture all the debugs though

I also tried this

but no matter what I do, I cannot get SSH or the UI to load…

Have I broken my setup?

#2

#3

Seems to me you simply broke your configuration. Fix it and it will be fine.

#4

Hi Moe. That’s the problem, I don’t know how to get into my configuration with SSH and Samba. I’ve been digging around, tried to load authorized_keys by USB and the commands.

#5

You have access to the terminal. What’s the problem with fixing the file?

#6

Please except my noobness, but there is only a subset of commands I can issue from the hassio>. prompt, none of them include vi/cat/nano/ls/find. etc

When I go into the supervisor mode, it’s even less.

I’m at a loss.

#7

Correct. You need to get into the command line, not the hassio command.

Why would you go into the supervisor container?

You will initially be logged in to Hass.io CLI for HassOS where you can perform normal CLI functions. If you need access to the host system use the ‘login’ command. Hass.io OS is a hypervisor for Docker.

#8

Hi M0e… I’m able to login # to my system.

Although I’m able to see the logs (shows Connection Refused) in the supervisor_logs, the container bash isn’t accesble as it says “Container _______ is not running” from here - https://developers.home-assistant.io/docs/en/hassio_debugging.html

I cannot seem to find a config folder nor any directory containing the yaml files.

#9

It’s there somewhere. I don’t know the exact paths in HassOS but if you dig through the directories it’s there.

It has nothing to do with the supervisor so stop going down that road.

Edit the config files on the host.

#10

as root (the # prompt),
go to the base config directory: cd /config
then do an ls to list the files. You will find all your *.yaml files there

#11

also, when there. the text file editor nano is available to you which acts alot like vi

#12

and while I’m thinkin’ about it. At this time, don’t go into hassio yet… ignore that prompt, it’s just the default banner page. You want to keep yourself at the “#” prompt for now.

#13

Thanks Moe and Dixey.

Unfortunately I don’t have a /config directory and nano doesn’t work despite being able to “login”

I’m familar with the editors (vi/nano) and how to navigate.
Any change my install is strange?
It’s the image for the raspberry that i’ve installed on my raspberry pi 3b+

#14

/config is only available if you’re logged in to the SSH add-on (or if your docker exec in the home assistant container).

The actual path is mounted elsewhere, and it becomes blatantly obvious what that path is if you start looking around…df -h?

No. It’s standard, but you have to understand what’s going on in the background. It’s running docker.

#15

When hassio is installed this way there is no /config. It is somewhere under /usr. As a rough and ready search do

 find /usr|grep configuration.yaml

EDIT - ignore this post, I thought I was in another thread.

#16

Inside the container it’s /config. That means nothing outside the container.

I don’t run hassio and don’t have time to dig through the code, but on hassio on a generic Linux docker install it’s /usr/share/hassio

#17

I’m at a loss. I cannot seem to find anything.

Please note, this is console access to a Raspberry PI running the hassio image.

#18

It looks like you are in the host. Most probably you can now go to /use/share/hassio/homeassistant to edit the configuration.yaml

If you prefer a GUI you can run midnight commander in the host (sudo apt-get install mc) by running “sudo mc”. Then you will be able to browse and edit files a bit similar to Windows.

#19

Pretty sure that’s only for a normal Linux distro running docker. HassOS is /mnt/data I’m pretty sure.

#20

fversteegen,
There is not /usr/share/hassio folder.
Also, there is no sudo or apt-get commands

m0e,

are you aware of any documentation on the location of those files. My finders are truly breaking from going into directories and typing “ls”

I think there is no way to gain access to the system via console, as hassio > or # prompt.