Having issues with zigbee network and hardware

Hey everyone.

I am having issues with my zigbee network.

It all started when I tried adding a Aqara motion sensor.
I can pair the motion sensor, but it won’t share any states.
Everything just says N/A.

Now, I have noticed that my other motion sensors work intermittently.
And, my zigbee Yale lock won’t respond to the lock/unlock commands I have on my dashboard.
The states are correct, so it knows when it is locked or not, but it won’t unlock or lock if I command it to.

I am not sure if these are related or not, but it seems funky that it all started at the same time.

I am using mosquitto and Zigbee2MQTT with a sonoff USB stick.

Is the USB stick on a USB extension to avoid interference? And are the devices close-ish to it?

1 Like

How are the WiFi signal levels at all of the devices? -40db to -60db is good signal level, -60 to -70db marginal, more than that and things start to happen.

Zigbee is not WiFi. Wifi signals at the device only exacerbates problems

@BadPlayer in addition to the extension cord / USB hub as Michael asked. How far are your devices. What kind of devices are they? (model number matters) Are they line powered or battery devices?

What channel is your zigbee installation using? What channel is your 2.4Ghz wifi using? And do you have any USB3 hard drives plugged into the same machine or near your zigbee coordinator?

Depending on location, it could be close to rf signal issues since there are some working in that band. If wifi is so well in use both the 2.4 GHz and the 5Ghz. I wanted them to basically see what the area looked like for those signals.

This is where zigbee signal operate in around the world: zigbee channels-2.4GHz,868MHz,915MHz zigbee channels

Oh, I forgot about the old cordless phones that operate in the 900 MHz range too. I have two sets in use here for my old land line.

I have so much wireless in use that clocks and watch that use the radio time sync began to no longer sync anymore. So I thinking saturation from our high tech world.

The usb stick does have an extension.

The devices are closeish.

My house is only 28x50 and everything is within that.

The LQI of the working items are between 70 and 175.

The devices are

2 Aqara motion sensors.
Not the new P1, but this one.

3 Aqara contact sensors, like this.

1 Yale Assure deadbolt lock, like this.

They are all battery zigbee devices.

Zigbee channel is 11.
Wifi channels are auto.

No USB3 hard drives anywhere.
Well, the PI 4 I am using to host home assistant has a USB SSD drive as the main drive in a argon one M.2 case.

Here is my zigbee network.

Not sure why the door lock says 0 when the devices page says 174.

Ah good ol auto wifi channels. Wifi will ABSOLUTELY drown out zigbee if they are on overlapping channels. The zigbee / fifi channel overlap map has been posted tons of times on the site so I’ll refrain. But short version this could absolutely cause the issue.

Start with seeing if you can set your 2.4 Ghz wifi to channel 11.

Zigbee 11 and wifi 11 are not the same channel 11 they do not overlap.

Yhe rest of your devices are all battery powered so they don’t act as repeaters. If you had a few powered repeaters it could help the signal as well. But start by ensuring your WiFi is forced to a non overlapping channel and see if it gets better.

I changed my 2.4 Ghz wifi to channel 11.

I will give it a bit to do it’s thing and maybe try tomorrow.

Thanks for the tip.

1 Like

Now, I can get the motion sensor to start the interview, but it doesn’t complete the interview.

Must not be the right fit for the job.

As nathancu noted, I see no mains powered devices to act as repeaters. Lqi of 61 isn’t great.

Did you follow the directions here and hold the inclusion button for 5 seconds?


Also, aqara/xiaomi devices are not fully zigbee compliant and can have issues with other devices. Although this post is from hubitat, it notes other zigbee devices known to have issues, and ones that work with aqara. I have Aqara devices and have added 3 ikea tradfri outlets. They are on the list of devices known to work with aqara, and really helped make things more reliable in my zigbee network.

I thought that zigbee devices could hop off each other?

1 Like

If they comply with the zigbee protocol then yes. The problem is the Aqara ones don’t “fully” comply so they have issues with some other zigbee devices.

1 Like

Only if they’re line powered. You only have battery powered devices


Okay, I plan to get some plug in presence sensors so that should help.

1 Like

First thing to try when this happens is to re-pair the device without deleting it. I had to do so with several Aqara devices. Seems like somtimes they pair but don’t complete the interview completely. Once fully paired, I’ve never had an issue.

That really sounds like RF interference.

The z2m default of zigbee channel 11 can be really bad. It directly overlaps WiFi Channel 1..

Best options are zigbee channels 15, 20, 25 & 26 since they fall in between the 20mhz bands of WiFi channels 1, 6 & 11 most routers will use. 26 is probably best with regard for interference for the US, but there is a chance you’ll stumble upon a zigbee device that won’t support zigbee 26.

In a dense environment, nothing is safe though. Neighbors may be using 40mhz bands, or channels other than 1,6,11. Still, it is best to optimize for the channels you use locally.

I would change zigbee channels while you only have a handful of devices to re-pair. Move away from Auto for the WiFi and change zigbee accordingly.

A local SSD could be the worst kind of USB3 interference, make good use of the extension cable.

The “E” or “P” variant? The “P” is hands down the best z2m option in my testing. Support for the “E” EZSP chip is still a work in progress for z2m. It has been surprising how many pairing issues I have with the “E” compared to the “P.” I haven’t so far had a definitive issue with the “E” once a device is paired but the pairing issues give me pause. I should build up a larger “E” test net, but don’t really have a need. My main cc2652p based z2m instance has been rock solid.

I have tried this, even close to the USB stick.
I am beginning to think the sensor is bad.

I think it is too, now that I know a bit more about the zigbee network.

I’m not really in a dense environment. I am out in the country.
When I check for networks, I only see 3 others, and they are very faint.

I am on channel 11 for zigbee and 11 for wifi now.

I have the Pi sitting on a shelf in the roughly middle of the house.
I just command stripped the USB dongle under the shelf, on the opposite side of the PI.
That would be about as far apart as I can get them.

P variant, with the Texas Instruments processor.

I am just so confused because everything was working so well together.

I thought ZigBee would be more reliable than this.

Like I said above, I have the Home Assistant Pi on a shelf in the middleish of the house.
It has line of sight to the kitchen motion sensor. About 25’.
It doesn’t have line of sight to the door lock, but it is about the same distance to the kitchen sensor.

The outside motion sensor is just on the other side of the wall from the door lock.
That is being temperamental also.
This is the one with the 58 LQI.

Thinking more about it, it seems like all this started happening after I upgraded Zigbee2MQTT.

I am on the latest version and have more devices, and haven’t noticed any issues with the latest several updates. Although a software update to zigbee2mqtt causing your issues can’t be ruled out, I believe your issues started when you tried to add the extra Aqara device. Its possible there could be some bug in the update, especially with adding a new aqara device, as someone else noted issues with re-adding aqara devices. You may want to monitor the attached github issue for a resolution, and possibly post your logs when you try to include to add to it.

As I noted above though, as you add more battery powered devices to the zigbee network, with no mains powered devices to act as repeaters, the network will become more unstable. Pair this with the Aqara devices that don’t meet the zigbee standard exactly and that will compound the problems. I had your exact issues that started happening when I was adding more battery powered devices, and adding the 3 ikea tradfri’s made them all pretty much go away.

Is the firmware updated? Firmware and update instructions here- Supported Adapters | Zigbee2MQTT