Having trouble linking HA and Node-Red

I just finished installing Home Assistant on my Ubuntu Server 18.04 box in a Python VENV. All is working great, and I’m able to make changes as I need. Let’s Encrypt has also been enabled, and my router is portforwarding 8123 to the HA landing page.

Now, I also installed Node-red on the same server, but I’m having some trouble getting it linked to HA. I added the server credentials as below, but I keep getting the error.


I did some research, and found other people with the same issue. However, after I deploy, any nodes linked to HA still show disconnected, so I have a feeling it’s not working right, especially since the entities don’t auto-populate when I type.

How can I be sure that HA and Node-red are talking? I have Node-red running on port 1880 as normal, and it’s not forwarding outside my network.

I’m going to assume that you are trying to connect locally and not from outside of your network, if so try using the local ip address like so: http:\

I did, and no luck.

I was able to get it connected when I disabled SSL on HA, but I’d obviously like to find a way to keep that enabled.

This is where a reverse proxy wins. You don’t have to enable SSL on your HA, and you still get SSL externally

Can you explain how this should be setup? I look over several NGINX tutorials yesterday, but I couldn’t wrap my head around the flow of it.

Basically, you configure an NGINX reverse proxy, using the Home Assistant tutorials as a guide. You disable the SSL component in HA, and you configure NGINX to only allow SSL connections. It proxies requests back through the internal IP address and port of your HA, so all communication that hits NGINX is SSL, and anything internal can be open (assuming you trust your local network)

1 Like