Node Red GET /HOMEASSISTANT/... error

Simple install error…but I’m chasing my tail. Any suggestions appreciated.

  1. clean build of HassIO (0.69.1), config wifi, boot - no issues
    pi3, removed zwave stick. hassio.local resolves correctly (as does IP)
    HassIO now asks for password on startup, using ‘password’, opens fine

  2. install add-ons for samba (easy config file access) & Node-Red (via notoriousbdg)
    start node red from add-on details - “Open Web UI”
    No problems. Node-Red UI comes up (v 0.18.6), prompts for default UN/PW. (no mods to config yet)

  3. add home-assistant to the palette - (node-red-contrib-home-assistant v0.3.2)

  4. drag ‘call service’ node - double-click it (red triangle visible on the node)
    Log in to hassio.local:1880 pop up. (the node-red port – use node red default un/pw)

Popup shows “Cannot GET /homeassistant/services” - fades out.

  1. Add new server… using defaults -
    base url (http://hassio.local:8123)
    Password: (blank)

Will not connect to Home Assistant

  • Tried all forms of base url (IP, hassio.local:8123, hassio.local:8123/api…)
  • Tried with and without password -
  • Tried adding password to secrets.yaml (changed from ‘welcome’ to ‘password’) and uncommented line in configuration.yaml.
  • Tried adding password directly to configuration.yaml, bypassing secrets.yaml lookup
  • Tested API access to hassio.local:8123/api via curl (works)
  • Confirmed supervisor is at v 103.2 (thanks @frenck, but no luck)

This is as clean and basic as I can make it.


1 Like

Solved - work around (from a tip in the discord channel from cavemanzzz)

Add an Inject Node (string “Hello Word”) and wired to Debug node.
Deployed it and confirmed basic nodes working
BAM! home-assistant now accessing correctly.

bloody hell – lost many many hours googling and scratching my head.

There is a bug in there but it can be worked around for now.


Hey DanK,
I’m pretty new to this, and I’m getting the same error you mentioned. Can you give me some more details on you work around/solution.


In my case…something, anything, needed to be deployed, then I could configure the server.

1 Like

Wow! You just saved me a headache as I was struggling with the exact same issue. Thank you so much!

Thank you! Thank you! Thank you! I was ready to throw it to the scrap yard until your work around worked!

Wow, just wow. It works! Thanks!

Wow! That did the trick. We should report this bug, will save lots of tome to lots of people.

Thanks for that.

I can´t thank you enough! You have spared me so much headache :slight_smile: This trick works like a charm.

Hmm it doesn’t work for me :(, all I ever get is node not deployed because the server can’t connect.
(Ubuntu 18.04 on a desktop PC running docker)

You should be able to deploy non-HA flows. You don’t need the HA plugin to use the add-on for generic flows (and would be pointless.) But getting any flow working and tested that doesn’t use the plug-in…then the plugin started working for me.

Thank you. You saved my day!

Good grief
I have wasted so much time with this
This cannot possibly be the answer
EDIT:(yes, in fact it is the answer)

This issue is still present and the solution still works. Using latest Node-RED and Home Assistant docker versions as of this writing.

bump… I spent an hour failing to understand why node-red could not connect to HA. Deploying anything worked…