HeatIt thermostat from Fibaro HC2 climate card does not control the correct device


I think I found a bug, but I’ll post here first. The Thermostat card does not control the right HeatIt sub device on my Fibaro Home Center 2. Please see attached screenshot.

Here is the yaml code:

type: grid
  - type: thermostat
    entity: climate.stue_termostat_97
    polling_intensity: 1
  - type: thermostat
    entity: climate.soverom_termostat_79
    polling_intensity: 1
  - type: thermostat
    entity: climate.soverom_78_0_1_156
columns: 2

![Home Assistant HeatIt thermostat Fibaro climate card does not use the correct Fibaro device narrated
The third entity is a bit mysterious, and so is HeatIt thermostats in Fibaro HC2, but they work ok if I just use the first two sub devices.

Did you ever find out what the reason is? I do have the same issue with Heltun thermostat. Each mode has it’s own id in Fibaro (so Heat, Dry Air, Cooling etc) and pops up as a separate icon in Fibaro HC2. Now the Heat icon/thermostat in HC2 is not corresponding with the Lovelace.

When I have time I will put my screen dumps into this post. To be continued…

I have further researched the issue and written it into a new thread:

Although there are different devices being used, I believe the issue is caused by the integration between Fibaro and HA.

1 Like

After a few updates (don’t know which one) devices and entities correspond :blush:

HA also shows correct room temperature from the Heatit thermostats and when eregy save is enabled.

But the set temperature is not correct, 18 on lovelace card, 23 in fibaro home center 2. Please see attached screenshots and yaml code:

type: thermostat
entity: climate.stue_termostat_183

I suppose this issue has never been resolved. Is that correct? I also still have the problem with the integration between thermostats Fibaro and HA… see my other thread… I hope someone can dig into this issue…