Heiman smoke detector doesn't report smoke detection

I got a Heiman smoke detector. I connected it via deCONZ, and Home Assistant is correctly reading it as a smoke sensor as a binary entity, which occasionally updates to report “No smoke detected”.

However, the entity is unresponsive when I test it with the test button, and even when I trigger the alarm with actual smoke. It just doesn’t update the entity.

I’m not sure how to debug this. Anyone had a similar problem? Did I get a faulty unit?

Also, can anyone confirm that the test button is supposed to trigger he HA entity? Just so I don’t have to get out the candle constantly to test it.

1 Like

I have the same problem, the dectector used to work and report to HA some time ago if the test was triggered but nothing now. In phoscon it reports as device unreachable.


I am quite new to Hass (from Slovenia so not native in ENGL).
In the last two months I managed with a big help of a perfect guides to create few integrations, add add-ons, automations, dashboard with animated background, etc.

But this smoke detector is killing me for the last few days:(

So what I did till now:

  • managed to integrate smoke detector using Conbee II and ZHA (raspberry pie 3+)
  • smoke detector is integrated but does not swtich from mode “clear” so it can not trigger notification or be part of any automation (the sensor is working - it was tested with smoke and button)
  • what I tried is also to change status manually in Developer tools - it worked
  • I saw a guide for zigbe2MQTT integration. So I also added MQTT but it can not be installed as I am already using ZHA on same USB Conbee II (on which I have already 20+ devices, automations) so I do not wan’t completely switch to zigbee2MQTT


Many users with same issue:

Do we have any clear solution to this? :confused:

I am thinking of buying CC2531 and add it on another USB port and conect to zigbee2MQTT. WIll it work? :slight_smile:

Hi @real_ist!

Yes, as it is long standing issue of ZHA not supporting these HS1SA-E smoke detectors you will be better of integrating with Zigbee2MQTT. I’m on my process to refactor (rename) all my 80 devices and hundreds of entitites and then move them from ZHA to Zigbee2MQTT. It is a pain, as I already have done it one time other way round - started with Zigbee2MQTT and moved everything to ZHA. And now need to move all again, because of smoke sensors.

My thought process not to intorduce second Zigbee coordinator USB-stick is that it brings yet another thing to manage or troubleshoot. The 2.4GHz band is already so congested (neighbours have their 2.4GHz stuff too) that it is better to try to fit all Zigbee radio channels with only one stick.

If you implement two USB coordinators, I would like to hear was you succesful!


yes, I ordered and also received CC2531…BUT…it needs to be flashed. I even do not know what flash means or how to perform this.

In meantime I discovered that HS1SA-E smoke detectors can be integrated via Deconz. So I moved all my devices to Deconz (also Conbee II). I also managed to integrate Siren from Heiman via Deconz.

I realy hope this post may help anyone. I spent few hours discovering this but managed at the end. Fingers crossed that this Deconz integration will work w/o any issues. Everyone recomends ZHA but unfortunatelly for Heimnar HS1SA-E smoke detector it does not work (yet).

If any help will be needed I am available (but I am not sure how much support I can offer as I am completely new to HASS…)



Hi @real_ist ,

Just wondering if the smoke alarms are still working for you a year later?

Mine have been working fine up until recently. I have two of them, discovered in Deconz with a RaspBee hat. They were appearing fine in Home Assistant, but recently the status is just “unknown” and the test mode doesn’t change from “clear” no matter what I do on the alarms themselves.

Is it still working for you?

Wondering to if it is still working. My smoke alarms do show up, but no status change when I test them physically.


I have seven of these in my home, five are still reporting their state, two have been ‘unknown’ for weeks now, tried resetting them but with little luck…
haven’t tested the automation, activate a central mounted alarm, since I first installed them. But reading these messages I think the automation does not be work anymore…

What are you using as your zigbee controller? I’m having better luck using a Conbee USB stick and zigbee2mqtt