Help! I can't figure out what is corrupt!

Please help! I can’t figure out what is causing these issues. I keep getting this notification of an error, except everything was running just fine, until it wasn’t.

the following integrations and platforms could not be set up:

cloud (Show logs)
mobile_app (Show logs)
default_config (Show logs)
Please check your config and logs.

2023-07-27 22:41:06.694 ERROR (MainThread) [homeassistant.setup] Setup failed for cloud: Unable to import component: cannot import name ‘DEFAULT_CIPHERS’ from ‘urllib3.util.ssl_’ (/usr/local/lib/python3.11/site-packages/urllib3/util/
2023-07-27 22:41:38.870 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of default_config. Setup failed for dependencies: cloud, mobile_app
2023-07-27 22:41:38.884 ERROR (MainThread) [homeassistant.setup] Setup failed for default_config: (DependencyError(…), ‘Could not setup dependencies: cloud, mobile_app’)

1 Like

What version are you on?

This was reported during the current beta testing.

Either downgrade to the current stable core version (2023.7.3) or remove the following integrations:


Or upgrade to the b1 release which should now be available. Please confine beta release discussions to the Home Assistant #beta Discord channel if you continue to have issues with a beta release.

That’s not enough. The issue isnt just with the beta. I have the same issue with the following system:

Home Assistant 2023.7.3
Supervisor 2023.07.1
Operating System 10.3
Frontend 20230705.1 - latest

So you either need to uninstall the offending integration (Pirateweather in my case), or run pip install --upgrade 'urllib3<2' as suggested in the github issue. I just did the downgrade and it worked.

Frenck locked the issue in github, so I can’t add to it that this isnt just a beta issue.

1 Like

Thanks for the clarification James.

I’m also getting the same problem with:

I stupidly decided to upgrade to 2023.7.3 from 2023.7.2 without doing a backup first, thankfully my last backup was only 2 weeks ago so I reverted to that and have the issue after a second reboot (needed due to Sonoff not authenticating).
I now can’t reboot as I get:
Failed to restart Home Assistant
The system cannot restart because the configuration is not valid: Component error: mobile_app - cannot import name ‘DEFAULT_CIPHERS’ from ‘urllib3.util.ssl_’ (/usr/local/lib/python3.11/site-packages/urllib3/util/

Update: I’ve almost worked this off, I removed the Pirateweather integration from Settings > Devices & Services, Then removed the integration from HACS. Finally from the (Advanced SSH & Web) Terminal, I did, “ha core rebuild”.
Along the way I tried downgrading the urlib3 using docker exec -it homeassistant pip install --upgrade 'urllib3<2' as a hail mary but I’m not sure that step is entirely neccessary.
Once I managed a successfull reboot I updated everything and took a Full backup before updating the core.
My only issue now is my iOS mobile app is getting a wierd “This redirect is not supported by your Home Assistant instance” while my wife’s works perfectly?
Possibly time for a delete and reinstall on the phone… I’ll wait a while before that though.


Throw my hat in on this one, my attempts to restore from backup fail. Alas creating a backup before every update does me no good here.

I had this issue with PW on HA. upgraded to beta and it seems to be solved

Had the same bug introduced by installing PirateWeather on a fresh installation today (literally my first HACS integration).

This was the solution that fixed my errors, full removal of PirateWeather then ‘ha core rebuild’ in terminal. Thanks.

1 Like