Help Needed with Zigbee

Hello fellow Smart Homers,

I am reaching out to you to get some help on a very strange problem i have with Zigbee devices disconnecting. While they show as active in Home assistant they are not working. Here is a list of zigbee devices i have:

2x Aqara Buttons (model: WXKG11LM)
2x Sonoff Motion Sensors (model: SNZB-03)
3x Sonoff contact sensors (model: SNZB-04)
1x Danfoss Ally radiator valve (model: 014G2460)
Gateway: Sonoff Zigbee bridge (flashed with Tasmota)

As we have pets, during vacation we arrange with members of the family to take care of them and when they open the door, i receive a notification on my phone. Unfortunately, i stopped receiving the notification and that’s how i noticed that there is something wrong. At first, i thought that the batteries finished. I could not receive the notification for 3 days and then suddenly i got again.

After my return home, none of the motion activated lights were working. The sensor blinks, but home assistant says that the sensors are clear. This was happening in HA 2022.7. So i took the following actions:

  1. I inserted new batteries to all devices
  2. I updated Tasmota on the bridge to the latest version
  3. I unpaired and paired again all Zigbee devices
  4. I updated HA to the latest version

Unfortunately, the problem continues even after the above. It seems random, but after sometime, i enter my Kitchen expecting the lights to turn on and they don’t. when i check the history of the sensor, i see that it hasn’t registered a motion but it is not “unavailable”. Same thing happens with the buttons, i press them and nothing.

If at that point, i restart Home Assistant, it seems to work again for about 30 min and then they disconnect again.

For a week i am trying to find a solution and i am not sure where the problem is. It cannot be on the sensors because i would consider it impossible for them to break all at once. It can be the gateway but Tasmota is accessible and seems working, also, if it was the gateway, HA would register the devices as unavailable and they wouldn’t work after a restart.

Is there anyone that can guide me on how to troubleshoot this issue?

Thanks in advance

The documentation for Home Assistant’s ZigBee integration includes a note indicating that it’s not recommended to use a Wifi based ZigBee coordinator that employs the Silicon Labs EmberZNet chip. It specifically mentions the Sonoff ZBBridge.

The reason it’s not recommended is because it can be unstable.

Hello Taras,

Thank you very much for taking the time to respond. I have seen that before buying the Sonoff Zigbee Bridge but while searching i have noticed many people have it and there very little problems with it. I have the bridge from November last year and not a single day i had a problem with it… I was in fact so happy that everything worked so seamlessly and the stability was great. Maybe i was just lucky so far.

What would be your recommendation for a ZB Bridge?

Kind Regards

Glad to hear it works so well for everyone including you. If the ZBBridge isn’t responsible for the recent stability problems then I don’t know what else is the cause. Hopefully someone else can help you pinpoint the source.

I can’t provide a personal recommendation for any ZigBee coordinator compatible with ZHA (because I don’t use it) but this one described here appears to be popular:

Well, it used to work well for me, not any more… I didn’t change anything when that issue appeared and that’s why it is so difficult to troubleshoot. I don’t see the bridge disconnecting from my router, most probably, the devices disconnect from the bridge, but it needs time until it shows as unavailable.

I forgot to say that i am running HA as a virtual machine on a Intel NUC so if i go to a USB solution i need to confirm that the VM will see it.

Thanks again!

If you insist on using a Zigbee bridge instead of USB then recommend ZigStar and Tube’s products:

but better is to use a USB adapter with very long USB extension cable

Thanks for the recommendations… My problem is not the type of the device but rather the fact if it’s gonna be recognized on the virtual machine.

I don’t want to install only home assistant on the NUC because on the same machine I run a plex server, an FTP server and hyperion.

Any USB will work with a VM, you will need to do a passthrough. It depends on what type of Virtualisation software you are using, the method might be different.

1 Like

Exactly! Most virtualisation hypervisor software offers USB pass-through options enabled per USB port for the VM (virtual machine), and when you use that only the guest virtual machine actually see the device connected to that USB device. As far as the host running the virtualisation hypervisor the USB adapter will not be seen at all as USB pass-through feature in virtualisation hypervisor software completly redirects the USB port to the virtual machine so it looks like it is directly connected to it as if it was a physical machine. See → and do a google search for your virtualisation hypervisor software of choice AND “usb passthrough” →

I use Virtual Box but there is an option.

Note that you also really need to buy a powered USB 2.0 hub (for USB 3.x to USB 2.0 conversion) if your computer only has USB 3.x ports as having RF adapter to a USB 3.0 port will cause serious interfernce, so want to connect it to a USB 2.0 port instead, read best practice →

This PC was purchased in 2012 so it has only USB 2.0 ports. It is this one: Are you a human? but it’s still able to run what i need. :slight_smile:

Should be good enough to be honest. I have a similar celeron and usage is typically below 8%