Help - Nest Integration Error 400: invaled_request

I’m trying to integrate my nest devices.

I’m stuck at the device setup section. At that point, I receive an error (see screenshot). In the Nest - Home Assistant instructions, there is a warning dialogue at this step, and the user has the option to “proceed anyway”. But, I don’t have that option.

Steps taken:

  1. Reviewed a prior community post on the issue (Nest integration, for Nest Learning Thermostat , results in error 400: invalid_request), but didn’t find my solution there. The person talks about adding a subscriber ID to the config file. But, the post is old enough that I’m not sure this is advisable.
  2. Tried 3 different web browsers (chrome, firefox, edge).
  3. Confirmed I created the “Desktop” type client ID.
  4. Confirmed I entered the correct Project ID in the yaml. That is, the one from the Google Device Access Console.
  5. Went over the HA instructions again twice more.
  6. I’m attaching the error screenshot, as well as, screenshots of the Google Cloud Platform Credentials page, Google Device Access Console Page, and config file.

Can anyone help me figure out where I’ve gone wrong?

In the troubleshooting section of Google’s Oath information page, it talks about making sure to add your email as a test user. Looking into that…

Additional steps taken:

  1. Reviewed the troubleshooting sections from HA and google (Authorize an Account  |  Device Access  |  Google Developers).
  2. Removed a pre-existing SmartThings web Nest integration.
  3. Deleted everything (OAuth client and Device Access Console project).
  4. Repeated the setup procedure outlined by Nest - Home Assistant. This time making absolutely sure the test user email was entered.

Same Error 400 result.

I just discovered this is an active issue and it’s already been addressed on this forum, here: Nest Authorization Error Error 400: invalid_request

Will put a watch on it.