Help with IP camera amcrest

HI,

I have the test / amcrest camera: here is my configuration:

# Cameras
camera:
  - platform: amcrest
    host: 10.10.1.224
    port: 9080
    name: kitchen
    username: user
    password: pass

here is the error i get:

Error: HTTPConnectionPool(host='10.10.1.224', port=9080): Max retries exceeded with url: /cgi-bin/global.cgi?action=getCurrentTime (Caused by ReadTimeoutError("HTTPConnectionPool(host='10.10.1.224', port=9080): Read timed out. (read timeout=3.0)",))

You will need to restart hass after fixing.

please help.

Is your camera using port 9080?

yes, i have it configured port 9080

Although not a solution, what happens if you go with your browser to the following URL:
http://10.10.1.224:9080//cgi-bin/global.cgi?action=getCurrentTime

1 Like

Thanks! that helped.

Did you get your Amcrest camera going? I just got an IP2M-841W and I’m having a lot of trouble.

yes, but i cant get more than 1 to work… if I add the second one in the config file it seems HA wont come up…

do you have 1 or more?

No. I only have the one camera. I tried adding it and it just looks awful.

have you checked if its one of the supported models? what exactly is the error?

Yes, I checked compatibility on this list:

It’s the IP2M-841W, so it should be good.

I tried copying how you had yours set up with the port number and everything.

 - platform: amcrest
   host: 192.168.1.3
   port: 9080
   name: Lincoln
   stream_source: snapshot
   username: !secret camera_username
   password: !secret camera_password

With this config I get the following error in Home Assistant:

17-04-06 23:06:50 WARNING (Thread-7) [requests.packages.urllib3.connectionpool] Retrying (Retry(total=2, connect=None, read=None, redirect=None)) after connection broken by 'ReadTimeoutError("HTTPConnectionPool(host='192.168.1.3', port=9080): Read timed out. (read timeout=3.0)",)': /cgi-bin/snapshot.cgi?=channel=0

I’ll get a still image with that config, then after a while the camera crashes.

I’ve also tried using low resolution rather than a snapshot stream source. With that config the video feed is horrible in quality and only stays up for about 5 seconds before it freezes.

what happens if you leave the above out…? I am not using it and seems to work ok…

If I don’t specify stream_source or resolution then I don’t get any picture at all since the camera doesn’t use MJPEG encoding.

only other thing i can think of checking is the port your camera is running on is that http port? i used the amcrest ip cam software to check these ports…

i had 9080 show up as tcp port (configured in my android App), and 9083 show up as http port…

The port was the http port. By default it was port 80. I manually changed it to 9080.

Before I changed the port number or anything I was getting the same error that you were. What did you have to do to fix that?

in my instance the camera per its software was running on tcp 9080 and http 9083.

this was “news” to me since i though i was only running it on 9080 the port config i had changed from 80…

i update my configs in HA to use 9083 instead of 9080.

Did you solve the issue?

I am about to buy the same camera but I wanted to ensure it works with HA.

Any feedback on the camera with HA?

Thanks

The camera works with HA, but there are some issues with it right now with the live feed. The developer has been working on it, and I think he’s got a workaround, though I haven’t tested it yet. Here’s the thread where it’s discussed:

@kembo @shivan

Guys, I posted a PR today to generate the stream via RTSP via ffmpeg.

This will be a good workaround while aiohttp does not support HTTPDigest authentication for the newer firmware.

I’ve been using this solution for a couple weeks now and it works great in low resolution. When I try it in high resolution the picture locks up. Is there something I can do to try and improve it?

Thanks again for all your hard work.