Help with wall panel please, can't see any sensors

I can’s see any sensor, i’ll be great full for help

at the configuration.yaml I do not have

secret: !include secrets.yaml

because I get this message :

Integration error: secret - Integration ‘secret’ not found.

at my secrets.yaml:

firetab_rest: http://[ip]:2323/?cmd=deviceInfo&type=json&password=***

firetab_screen_on: "/usr/bin/curl -X POST 'http://[ip]:2323/?cmd=screenOn&type=json&password=***'"

firetab_screen_off: "/usr/bin/curl -X POST 'http://[ip]:2323/?cmd=screenOff&type=json&password=***'"

firetab_screen_state: '/usr/bin/curl --silent -X GET "http://[ip]:2323/?password=***" |grep "Screen status" |grep "on\|off" |sed "s/<[^>]*>//g" |sed "s/Screen status//g" |sed "s/Turn on//g" |sed "s/Turn off//g"'

and at sensors.yaml

I got these:

- platform: rest

name: firetab


- batteryLevel

- kioskMode

- screenBrightness

- motionDetectorState

- maintenanceMode

- appFreeMemory

- appUsedMemory

- totalFreeMemory

- totalUsedMemory

- hostname4

- ip4

- mac

- locationLatitude

- locationLongitude

- locationAltitude

- startUrl

- currentPage

resource: !secret firetab_rest

value_template: '{{ value_json.isScreenOn }}'

Seems like indentation got messed up in your post. I’m assuming you have the correct indentation in the actual config files.

Does it work without !secret? Try putting the full URL after resource: and see if that works. You can deal with moving it to secrets.yaml later. Try surrounding the URL with double quotes.

secret: !include secrets.yaml

This does not need to be included in configuration.yaml as it’s part of the core config.
Source: Weird secrets.yaml behaviour

1 Like