HELP! Z-wave switches turning on by themselves

I am running the the newest version of Hassio (88.0) on an RPi3. I have an aeotec z-stick in the pi to control my z-wave devices. I have about half a dozen multi-sensors, and half a dozen smart switches. Some of the smart switches are GE, the remaining are Inovelli. Up to about a day ago, I have loved them and had little problems with them. Recently though, they’ve been turning on by themselves in the middle of the night. It’s repeatedly too, I’ll go to turn them off, and they’ll be on a minute later.

I thought maybe some automation has gone crazy, so I figured for isolation sake I’d unplug the z-stick from the pi, at least for the night. No luck, the lights still came on. I completely unplugged the Pi with HASS on it, the lights still came on… In my 2am rage to go to sleep, I chucked the multi-sensors that was in the bedroom out in the hallway, that seemed to prevent the lights from coming back on.

Has anyone else experienced something like this? Does anyone know what’s going on? How do I get this back to normal? Thanks for any help you can provide.

1 Like

Seems like you linked the motion detector directly to your zwave lights instead of through an automation in Home assistant. Z-wave can work purely with hardware, without a controller… if you set it up that way.

That’s what I was thinking. What is weird is I haven’t messed with anything z-wave, in months. It must have somehow linked itself. I’ll try and reset my z-wave network and see where that gets me. Thanks

oof, resetting means you’ll have to reinclude them. That doesn’t seem fun. EDIT: Unless I’m thinking of something different.

Yeah, that’s why I was hoping there was some easy problem that I was blind to. Re-including a dozen z-wave components is still more fun than the lights in the house come on in the middle of the night, repetitively.

I believe the link would reside inside the mutlisensors. So if you have access to their configuration, you may be able to remove it. It might be referred to as “group” or “scene”.

1 Like

Good idea, I’ll try that first. Thanks for the help @petro! I’ll reply here when I find what works.

Well it seems that I’m not alone. I have exactly the same problem with my zwave multisensors. I have no automations controlling my zwave wall plugs still somehow the motion sensor triggers the wall plug to turn on and off.

It started yesterday. I’m in 0.88.1. Can it be something in 0.88.* release that made the zwave devices to be in groups?

I have already ungrouped the devices but it didn’t help. It could be though because I haven’t restarted home assistant.

Update It seems that after restarting home assistant everything is back to normal

1 Like

As a follow up, I tried to remove node group associations but the multi-sensor didn’t say it had any. I then looked at the z-wave documentation further and stumbled upon something called a “Broadcast group”. Apparently my device got into the ‘broadcast group’, and whenever it triggers with motion, it will send out a broadcast which turns on all the lights.

To fix it; per the documentation go to services
service: zwave.chang_association
service data:

{“association”: “remove”, “node_id”: <node_id to remove>, “group”: 1, “target_node_id”: 255}

make sure the sensor is awake when removing, I had to press the pair button every 1 second or so to keep it awake while removing the association. This fixed the problem. Hope this can help anyone else who experiencing problems!

1 Like

I have also an issue with Z-wave devices being triggered since 0.92 (has not changed in 0.93). When opening or closing the garage door, this triggers all my Z-wave Roller Shutters and Z-Wave lights - which is utterly annoying.

This was working without any issue for more than a year?

Any idea what might cause it ans how to resolve wouldbe welcome.

Your devices are associated together.
To fix unassociate them via the zWave config or use the services menu.


Dear firstof9,

Thank you for your answer, but I struggle to get it unassociated.

In the services menu when I put the line found in the post from jtilles above:

{“association”: “remove”, “node_id”: <node_id to remove>, “group”: 1, “target_node_id”: 255}

I get a “invalid json” message (obviouly I put the node id number).

The Garage door is not a Z-Wave device and is not linked to my Home Assistant setup.

For any Roller Shutter I have three Groups:

  1. Switch click
  2. Switch hold
  3. Lifeline

For the first two there are no other Nodes in the group
For “Lifeline” there is only the Aeotec Stick in the group.

Try removing it through the z-wave panel. You’ll need to make sure the roller shutters are awake when you remove it. I think the broadcast (255) is under the lifeline group. I would activate the shutters than repetitively try to remove the association.

What is your garage door connected to then?

My Mistake,

I completely forgot I have a Z-Wave Garage Door Sensor insalled since a year or two but do not use.

By looking at the issue, it is clearly linked to the Vision ZD2012 Sensor. Will investigate association with that node.

I have the following group - 1: All reports
Other Nodes in this group:
Aeotec ZW090 Z-Stick Gen5 (Node: 1 Complete)
Unknown Node (255: (0 ? 255.0 : 255))
Max Associations: 5

Removing broadcast does not work - will try the previous solution proposed by jtilles.

Edit 2:
The issue with the invalid json was linked to the double quotes in the line provided by jtilles hereabove, the correct line is:

{"association":"remove", "node_id": 5, "group": 1, "target_node_id": 255}

The line: Unknown Node (255: (0 ? 255.0 : 255)) has disappeared and there is no ghost anymore in the house :laughing:.

Many thanks firstof9, you put me on the right track to find the solution.

Same thing just happened to me last night. Working for months then my 2 Z wave switches just turned on and off randomly.

Turned out they were in sync with my battery powered 4-in-1 sensor motion. It was telling them on and off based on its state. This was in the logs, but for some reason HA was not seeing the sensor at all.

My big question is: what is HA doing that adds these group associations? Or are they always there and the HA config somehow suppresses the functionality? My problem started after a power outage, and was definitely not there beforehand.

It’s not doing anything.


There’s the key, zWave is setup to continue working even when the controller drops off the network. You’d need to dive into the specifications from Silicon Labs as to the why, how, and whens.

I guess that makes sense, after the power outage the controller was the only thing not powered. If they have a default “failsafe” mode that is stupid simple yes/no = on/off then it would have been in that state after our outage.

I will say it did not want to go back to normal, though. Tried several reboots, heals, and so on before removing the sensor node (which I accidentally removed the controller and now need to rebuild it – DOH!). I’ll poke around all the settings after I get the network back and definitely remove that 255 group so hopefully it won’t come back again.

I’m actually relieved it is not HA, because I have no idea how I could have handled the server shutdown / power outage better (UPS, shutdown when it got low, manually restarted well after power came back on).


I believe I am experiencing the same issue(ZWave Switch Turning On By Itself). I don’t know how my switch is being triggered though. How can I search the zwcfg file to find out which nodes are grouped together? I have 60 zwave devices which makes narrowing it down experimentally a bit more difficult. I just tried to activate all the devices I could think of and wasn’t able to reproduce the issue. It has happened twice now with similar symptoms. Thanks.

Go through each device and check their associations.