History panel not recording after updating to 0.43.2

Since I updated to 0.43.2, my history doesn’t show things correctly. I have all z-wave devices.

My automations are working, but the history doesn’t show what happened. For example, my lights just turned on at sundown, but this doesn’t show in the history. Basically, all of my history shows as constant without changes. This is new.

After checking my History Panel, as opposed to the graphs that come up when clicking on an entity_id in a card, I am seeing the same thing here after upgrading to .43.2

I’m going to check GitHub and see if anyone has reported this issue.

Do you see history when you click on the entity id in the cards for your devices? I see it there, but not on the history panel. In fact, it looks like everything stopped recording history right around the time I upgraded.

Edit: Modified your title slightly - let’s see if we can find some more users to verify this. We may have to create an issue on GitHub.

Mine seems to be working ok

1 Like

Will have to check on entity cards.

The other thing I noticed is that my z-wave events also don’t show in the log.

The initial start up state changes are there, but not, for example, switches turning on or off.

What does the logger/history sections of your config look like? Can you post them?

Also, what db platform are you on? I am on MySQL.

The history does not seem to be correct in the entity cards, either.

Logbook section:

# View all events in a logbook

History section:

# Enables support for tracking state changes over time.
      - sun.sun
      - light.kids_room_level_3_0
      - switch.garage_light_switch_5_0
      - switch.front_porch_switch_6_0
      - switch.aeotec_dsc06106_smart_energy_switch_switch_7_0
      - switch.master_switch_8_0
      - switch.back_porch_switch_9_0
      - switch.family_room_switch_10_0
      - switch.kitchen_switch_11_0
      - switch.loft_switch_13_0
      - switch.nook_switch_14_0
      - switch.dad_office_switch_15_0

Neither of these have changed recently, and this all seemed to work fine before the upgrade.

I do not seem to have any “database” related configuration, so I’m not sure what the defaults would be. It’s not anything I can recall working on or having to set up.

I tried deleting the database file home-assistant_v2.db, in case of corruption or similar. But it had no effect.

By the way, my problems are significantly deeper than things not showing up in history.

My z-wave devices are not behaving correctly at all. They don’t get initialized with correct state, they respond once to being toggled in the UI, but then the state indicator flips back to the incorrect state, at which point they become unresponsive.

My “instant update” switches do not update correctly anymore.

All of this worked previously.

Downgrading to 0.43.1, and then to 0.43.0, did not change any of this new broken behavior.

Downgrading to 0.42.4 causes my z-wave network to not work at all.

grepping the log for zwave says:

INFO:homeassistant.components.zwave:Starting ZWave network.
INFO:homeassistant.core:Bus:Handling <Event zwave.network_start[L]>
WARNING:homeassistant.components.zwave:zwave not ready after 30 seconds, continuing anyway
INFO:homeassistant.components.zwave:final network state: 0 Network is stopped

It sounds a bit like you’ve got some fundamental issue going on. Have you tried a fresh install on a new SD card, just to rule out either a faulty SD card or a corrupted install?

I’m experiencing the same issue too since I upgraded to 0.43.1, where HA has been showing wrong device status and some of my automation scripts are constantly turning off by themselves. I’ve upgraded to 0.43.2, thinking that would take care of those issue, but that didn’t solve them.

1 Like

This seems to be a mix of both new problems in HA and something more fundamentally wrong with my setup. I have had 3 people confirm they’re seeing the history issue as well.

After a great deal of experimentation yesterday, I ordered a new z-wave stick to make sure this isn’t a hardware issue.

Well this is interesting. I had recently added a USB extender cable, thinking it would help get my z-wave stick to a better location with less RF interference with the computer. But once I removed it and plugged the stick directly into the USB port, my z-wave network became mostly functional again. I regained accurate states on startup, and the states update correctly when I manually use my instant update equipped switches. Progress!

These events also appeared in the Logbook! So, scratch the issue regarding no events in the logbook.

I will update tomorrow on the history recording.

1 Like

Makes sense, but you’d think a USB extension would be wired one to one with the port. If I can find mine (I thought I had one laying around in the “cable bin”) I’ll have to test this out.

In my case, the problem mysteriously cured itself overnight. I haven’t restarted HA or rebooted the Pi (up for 28 days plus) so I am not sure what happened. The db seems to have been recording the data whole time as best as I can tell.

Happy it seems to be ending well for both of us, maybe we can help @mistrovly too!

I did a quick scan of the latest three pages of the Github issues and haven’t seen anything related.

Are you getting any error messages you can share?

Unfortunately I have not been able to see a lot of activity on logbook since I re-installed everything about an hour ago. But one that is still showing and bugging me, is my automation scripts are constantly turning themselves off. The funny thing is, there are no error on the log.

Looking into it over at the thread you created for it. :wink:

I appreciate that you took the time to look into that for me. Below is an example of one of the automation script that kept on turning off.
- alias: Turn off Kitchen Light After 15 mns
platform: state
entity_id: group.kitchen
from: ‘off’
to: ‘on’
hours: 0
minutes: 15
seconds: 0
service: homeassistant.turn_off
entity_id: group.kitchen
Please feel to correct any mistake

Two things - First, post this info in the other thread since it isn’t related here. This keeps the info together.

Second - Post your code using the preformatted text option. This will help others to check for proper pacing and formatting. Highlight your code block in the post editor after you paste it in and then press the preformatted text button as indicated in the image below:

I’ll take a look at it over there once you’re done.

  • alias: Turn off Kitchen Light After 15 mns
    platform: state
    entity_id: group.kitchen
    from: ‘off’
    to: ‘on’
    hours: 0
    minutes: 15
    seconds: 0
    service: homeassistant.turn_off
    entity_id: group.kitchenPreformatted text