Hive Integration

I’m wondering if anyone could help me?

This is the error I’m having, I previously had the hive component working about 6 months ago before Zigbee2Mqtt came out but I’ve recently purchased a thermostat to integrated into HA and keep seeing this error.

Error during setup of component hive
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/", line 148, in _async_setup_component
    component.setup, hass, processed_config)  # type: ignore
  File "/usr/local/lib/python3.6/concurrent/futures/", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/", line 64, in setup
  File "/usr/local/lib/python3.6/site-packages/pyhiveapi/", line 748, in initialise_api
    if product["parent"] == device["props"]["zone"]:
KeyError: 'zone'

Hi @scottdarby

I am guessing you have the most recent thermostat that Hive sell not the V1?

I have just tried an API call with my data and both those fields are in the data being returned from Hive so it should work.

Are you in the Hive trial or just still have the normal app?

EDIT - Also do you have multiple thermostats or 1?


I appreciate all your help but i’ve just re-installed hassOS/hassio and this has fixed the issue for me.

I downloaded the most recent version of etcher and the image from the official site, re-flashed it onto the SD card, setup the static IP and setup the hive credentials and it looks like it’s working!

Bit annoying i had to do it this way but luckily i didn’t set a lot up previously so it’s not too much of a bother for me :slight_smile:

Turns it out was an error on Hives end, they deleted a few old devices and updated firmware and now it works fine!

Just a quick update on Hive.
They have announced that they are working on TRVs. Planned release is first half of 2019.

Should prove interesting for room by room control.

Hi @ronan

Where do you hear about the Hive announcements? I looked on google and couldn’t find anything.

hi @Khole

Its on the Hive Uservoice site:

I think I added my voice to the requests for TRVs years ago and got emailed yesterday. As above ^^


With the release of Home Assistant 0.86.0 this includes two PRs for Hive, one fixes the error some have been getting which end with the line in the log:

TypeError: ‘<=’ not supported between instances of ‘str’ and ‘int’

The other PR adds Entity Registration to all the Hive Entities, which means you can now go in to the GUI, click on a Hive Entity click on the cog:

Change the Entity ID and / or friendly name then save:

Also for those that mentioned the temperature value decimal places, I have updated in the library the returned temperature values so that they are all returned to one decimal place

Finally, for those using the custom component to add the extra sensors, this too has been updated to enable the Entity Registration for those extra Custom Component Entities:
(right click save as on the link)

1 Like

@Khole I have the V1 and I’m getting very limited device information (status of the thermostat but no temperatures etc). Is this just a function of the old version I have and a good reason to upgrade?


Please post a google image of the thermostat. Just so I know we are talking about the same V1 thermostat.

If it is the one I am thinking off then we have never added support for the V1 thermostat.


I’ve since been told by Hive that I’m not even as far as the V1. I’ve got the original remote thermostat that works perfectly with the Hive app but is clearly in need of upgrading.

@Khole I’ve been offered a ‘reasonable’ price from Hive for the v2 Thermostat but is that enough or do I need to replace the hub and/or wireless reciever as well in order to get proper integration with Home Assistant?

Hi @DeCarabas

Thanks for posting those. That is definitely the V1 I was thinking of and unfortunately it is the one we don’t support.

I think hive only really became noticed when they started branching out past thermostats to other devices. And that’s when a lot of People invested in them.

Your the first person on the forum to ask about support for the V1 of the thermostat so my guess would be not many people have that version.

You could upgrade the system if you wanted but that’s completely up to you.

The other option would be to explain how you acces the device remotely, I’m guessing it will appear on

If it does then we can possibly look at adding support if you where ok with sharing your API data. I can explain how to do it but you will need to anonymise some of the data. There shouldn’t be personal information in there just unique references to the physical devices.

This decision is completely up to you and I am happy to explain how to get your data for you to look at. If you don’t want to that’s absolutely fine.



With regards to the hive upgrade I would imagine all the devices you posted will need updating. But hive will be the best to advise on that.

Thanks @Khole

I’ll definately go the upgrade route and then come back to forum if I have any new issues.

Thanks again.

Just to close the loop on this, I had the full Hive v2 install yesterday and everything is detected and working perfectly.

In case anybody goes the same route make sure that you are clear with the Hive people that this is a replacement of all of the pieces of kit. The engineer that arrived was told it was a V1 to V2 upgrade (i.e. change the thermostat in 5 minnutes) and was surprised when he saw what kit I had. Luckily I had double checked what I was paying for so was able to be clear it was hub, receiver and thermostat that were all being upgraded. The install took an hour.

1 Like

Since upgrading Home assistant to Version 88.1 i have lost all the entities for this custom component.
Has anyone else had the same as is there a solution?
still have home assistants native hive entities but not the custom ones.

any help much appreciated.

Hi @GuruPG

They have changed the folder structure for custom components since 0.88.0 so for the hive custom component, instead of:


you now need:

The existing version on GitHub still looks to be ok, it is just the name of the file and the folder you need to put it in which has changed.

I will update GitHub with the new folder structure

1 Like

new file and location for the custom component hive file updated on GitHub:

1 Like