Home Assistant Add-on: PSA Car Controller

I create an app to control and get info from PSA car (Peugeot, Opel, Citroën, DS, Vauxhall).
The app have an API, and a dashboard.
I also create an hassio addons for this app, so it can be easily install on a home assistant server.
You can find more information on the addons here and on this app here.



Looks like a great work you have been doing here. Thanks for it.

I am trying your addon, but I am facing an issue with the OTP configuration. I am not getting any SMS, so I am not sure how to proceed with it.

Could you try to help on this?


1 Like


I have updated the Addon to version 2.5.2 and it gets stuck and there’s no way to get it started. The process dies just after starting the container.

I got back to v2.5.1 and now I am not even able to get to the SMS check.

Here is what I am getting:

Hope you can help

Hi, same issue here.

I’ve commented over the issue directly on github, on this link https://github.com/flobz/psa_car_controller/issues/252#issue-1028007430

Thanks in advance.

installing went good, loging in went good,
but after 24h there is still no data in the tab,

also when I try to acces the web page as mentioned in the config it does nothing (i can see it has my vind and car model in the log this works)

when i reboot i also see it starts at

any advice?

I also see this in the logs so that part seems ok?
2021-11-20 18:14:17,171 :: INFO :: mqtt msg received: psa/RemoteServices/events/MPHRTServices/xxxxxxxxxxb’{“date”:“2021-11-20T17:14:13Z”,“etat_res_elec”:0,“precond_state”:{“available”:1,“programs”:{“program1”:{“hour”:34,“minute”:7,“on”:0,“day”:[0,0,0,0,0,0,0]},“program2”:{“hour”:34,“minute”:7,“on”:0,“day”:[0,0,0,0,0,0,0]},“program3”:{“hour”:34,“minute”:7,“on”:0,“day”:[0,0,0,0,0,0,0]},“program4”:{“hour”:34,“minute”:7,“on”:0,“day”:[0,0,0,0,0,0,0]}},“asap”:0,“status”:0},“charging_state”:{“program”:{“hour”:0,“minute”:1},“available”:1,“remaining_time”:630,“rate”:6,“cable_detected”:0,“soc_batt”:20,“autonomy_zev”:44,“type”:0,“hmi_state”:1,“mode”:0},“stolen_state”:0,“vin”:“xxxxxxxxxx”,“reason”:4,“signal_quality”:3,“sev_stop_date”:“2021-11-20T15:29:09Z”,“fds”:

1 Like

I just added this to my HA but have a few questions, I’m not sure if I have missed some step of installation?

I added the repository and installed the supervisor add on without an issue. I opened the web interface and was able to provide my Vauxhall account details, entered the OTP sent to my phone, and everything appeared to go through okay.

The web interface now shows placeholder graphs similar to the ones shown in the original post, but with no data.

Is there some additional step required to get this part working?

Many thanks.


The supervisor logs take a while to load, but looks like something is happening:

2021-11-23 08:44:36,748 :: INFO :: mqtt msg received: psa/RemoteServices/events/MPHRTServices/xxx b'{"date":"2021-11-23T08:44:31Z","etat_res_elec":0,"precond_state":{"available":1,"programs":{"program1":{"hour":34,"minute":7,"on":0,"day":[0,0,0,0,0,0,0]},"program2":{"hour":34,"minute":7,"on":0,"day":[0,0,0,0,0,0,0]},"program3":{"hour":34,"minute":7,"on":0,"day":[0,0,0,0,0,0,0]},"program4":{"hour":34,"minute":7,"on":0,"day":[0,0,0,0,0,0,0]}},"asap":1,"status":1,"aff":1},"charging_state":{"program":{"hour":0,"minute":0},"available":1,"remaining_time":0,"rate":0,"cable_detected":0,"soc_batt":99,"autonomy_zev":304,"type":0,"aff":1,"hmi_state":4,"mode":0},"stolen_state":0,"vin":"xxx","reason":3,"signal_quality":4,"sev_stop_date":"2021-11-22T20:57:57Z","fds":["NDR01","NAE01","NBM01","NCG01","NAO01","NAS01"],"sev_state":0,"obj_counter":7,"privacy_customer":0,"privacy_applicable":0,"privacy_applicable_max":2,"superlock_state":0}'

I think I am seeing the same thing as @jeroenvdd. There is an open issue on GitHub: Add-on loading some data, but gui seems incomplete / standalone webpage not reachable · Issue #278 · flobz/psa_car_controller · GitHub

needed update for opel/vauxhall latest version should be ok again

When running the add on via the supervisor and the service is running, how can I contact the REST API? I try to access via http://homeassistant.local:5000 but this does not work. I notice that in the add on configuration, the Host field seems to behave in an odd way, I am not able to put in the hostname or IP address of the Home Assistant instance running this add on. Entering the hostname clears it back to an empty field, and putting in an IP address retains only the first part of the address (ie 192 of 192.168.etc.etc) any thoughts?

I had the same “Problem”, till i recognized that the field is for the port and not the host ip, so i put 5000 in it and it worked.

So I installed the ha add-on because I would really like the car info on a dashboard. However, I am a little confused.

First, am I supposed to just hand over my credentials int the Config tab in order to get this integration to work? Not a token of some sort but my real username and password?

Second, to recieve an SMS, someone or something should know my mobile Phone number. Is it assumed (prerequisit) That you already have a mobile app up and running like the My Peugeot app?

Don’t get me wrong I really like someone made the effort to write the add-on and shares it, but for me it is not quite clear what to do and I’m kinda not so keen on just giving away a password to a piece of software. Or Shouldn’t I worry about that?

Hi, i like this app however in my excitement to get it running i paired the my wife’s car to my email, who subsequently repaired it to hers. I’ve repeated the remustering process fine and this worked, however have the same VIN number under both seems to cock everything up (un surprisingly). I’ve tried uninstalling and reinstalling the add on and i cannot get rid of the original config, can you help point me in the right direction? should i be looking to remove tables from my database? I’ve even looked in my maria db and found nothing!

Any help would be appreaciated

for everyone who is struggling to get the rest api running when logs from PSA addin are showing ( no help !)

2022-01-29 12:09:26,737 :: INFO :: update_data
 * Running on (Press CTRL+C to quit)

You need to find the internal ip address of the docker running the PSA addon . There must be a simpler way but I did this

I installed the terminal program

Logged into the terminal.
and ran ifconfig which will return the ip address of the docker IP address for the terminal in my case 172.30,33.1

I then ran curl to see if I could generate a response . I eventually found the correct IP on after running the curl program serveral times incrementing the ip address each time (up and down arrows help :slight_smile: )

Your milliage may vary depending on what addons you have installed

There must be simpler way ?

I’ve been using this addon for a cople of months now, but every month the addon stop work completly, and the only way to put it to work is removing and reinstalling the addon again, with that, I lose every Data I’ve
Btw, the addon is not syncing the trip and charge tables since yesterday
the ABR is not working at all
the Preconditioning is not working at all

My car is a e-C4

Is this still working? When I try to add the repo I get the following error.

@lonebaggie .

Yes there is… I struggled with this myself… the easy way is looking in the log files of the PSA addon and each line of the entry will start with the IP of the docker…

hope it helps you and others… :wink:



This addon now appears broken - can see activity on the github, but after install this is what we get:

2022-04-05 17:33:07,724 :: INFO :: update_data
2022-04-05 17:34:25,758 :: ERROR :: Traceback (most recent call last):
File "/psa_car_controller/libs/psa/setup/app_decoder.py", line 46, in firstLaunchConfig
token = res.json()["accessToken"]
KeyError: 'accessToken'

HOST_BRANDID : https://id-dcr.peugeot.com/mobile-services sitecode: AP_GB_ESP{"returnCode":"NEED_CREATION"}

Hello, really nice app. Installed via home assistant addons. I didn’t manage to setup the config.ini file. My HA app is running on HA OS so I can’t access the docker image. Any ideas?

Worked for me without any issue so far.
I have a Peugeot e2008.

The logs of the add-on show the ‘host name’ of container “Request 'http://b9f12d83-psacc:5000/…”

So I used b9f12d83-psacc in configuration.yaml as the IP for the request.

Hello all,

I installed the PSACC as addons in my HA 20 days ago. I can see data from the sensor from the json but I have no data in the dashboard in Summary, Trips and maps. Please someone have an idea how to solve it? Thanks!

Hi All,

I’ve had it working for 4 months, then yesterday my HA crashed which I managed to get it working. however psacc failed to run. So I uninstalled and reinstalled it.
using the same sensor.yml and configuration.yml as before, I have managed to re register my peugeot account and able to get the SMS for the token etc.
I can also see logs in PSA controllers and that it is getting information, e.g. battery level.
However, my dashboard is still showing nothing and when I go to entities, the entities for them are still unavailable.
Any ideas why?
Any pointers be much appreciated. Cheers