Home Assistant Add-ons missing from GUI


after the latest core update (Home Assistant 2023.2.1) the add-ons are missing from the GUI. They still seem to work for now, since my ZigBee devices keep working (DeconZ) and my Node-Red automations are still in place, but the configuration button is missing from the Settings menu and the sidebar doesn’t show the add-ons entries.

After some fiddeling, I discovered, that I can access the Add-ons via http://homeassistant.local:8123/hassio/dashboard
I could reach this URL by clicking on a deconz device, then on the add-on link and then using the “back” arrow in the GUI.

What went wrong? Is this by design and can it be helped?

My installation runs on a Raspberry Pi 4, I’ve used the recommended installation method, which should support add-ons (Home Assistant Operating System).

So there is no Settings → Add-ons menu item?

The side bar has not shown add-ons for quite some time.

What version did you update from?

I’ve installed the updates as they came out and did not skip a version. Also, there is no shutdown button, anymore…

Here, have a screenshot:

Check Settings → System → Repairs → Three dots top right → System Health (scroll down to see it all).

Seems this one is missing, too… The system information tells me, that my add-ons are still installed. Other than that, everything seems fine. 200 MB Database, low Memory, CPU, Disk usage…


Uhm. I don’t know why, but everything seems to be back to normal. The menu setting is there, the sidebar entries are back and I did not change a thing. Any idea what could cause this? I even checked the old screenshot, just to be sure…

No idea why it happened. I was going to ask if you had recently disabled default_config but that’s not it.

Browser issue perhaps?

Browser wasn’t it, the same issue was present on my smartphone and tablet (Homeassistant App). I think something crashed. There were some error notifications, maybe it fully crashed after some time and recovered with a restart. We might never know.

Thanks for the help!


I’ve had the problem again and there were some notifications that hassio and the raspberry-pi config were not working and could not be loaded. Well. Now I’m running everything on a Proxmox-Based virtualization environment and server hardware…
By the way, migrating to the other instance was phenomenally easy. The backup and restore system of home assistant is so damn mighty and easy. It was the fastest IT migration project I’ve ever done. Everything just works out of the box.

<3 Best home automatization software ever <3


Also having this issue on an rpi 4, sometimes after reboot I get an error rpi / hassio config failed to load - no changes on my end other than updating to 2023.2.1. Very frustrating when it happens, many things missing from gui - logs, restarting host, checking hardware status, add-ons disappeared (and the whole menu in settings). Only fix seems to be to hard reset the pi a few times and hope lol

1 Like

I’ve been having the same issues on RPi3, and I’m already on 2023.4.1.

Before your rebooting tip, I went to System Information and it was reporting my installation as container-based! A reboot from the UI did the trick - addons are back and it’s correctly identifying my setup as HAOS.

Go wonder… I guess I’ll have to open a bug report if this persists, not sure if there’s one already.

I’ve been experiencing the same issue since the latest update. Running HAOS on ESXi.
Restarting HASS makes it come back.

1 Like

Unsure if this is the same for other people but my issue was rectified by removing custom ui hacs intergration. Was driving me insane - no logs or issues pointed towards the integration, but it seemed the ui failing to initilise was due to custom ui not being up to date with the latest ha version. Removed it and haven’t had an issue since.

Have the same problem. Add-ons missing from GUI.

Home Assistant 2023.8.1
Frontend 20230802.0 - latest

restarted raspi 4 - no result and restarted HA from Gui (3 dots) couple of times, no effect.
Have no Addons in my Gui

Checked repairs → There are currently no repairs available

System information

Version core-2023.8.1
Installation Type Home Assistant Container
Development false
Supervisor false
Docker true
User root
Virtual Environment false
Python Version 3.11.4
Operating System Family Linux
Operating System Version 6.1.21-v8+
CPU Architecture aarch64
Timezone Europe/Berlin
Configuration Directory /config

Home Assistant Cloud


Logged In false
Reach Certificate Server ok
Reach Authentication Server ok
Reach Home Assistant Cloud ok
1 Like

Just wanted to say I’m also experiencing the same issue. Quite new to HA so don’t really have any diagnostic info to share without instructions. I’m currently running the stable release in docker.

Nevermind, I did some digging and it seems that docker is the key word in my case that’s not allowing me to use add-ons. Sorry for unnecessarily posting e-waste :slight_smile: .


Same here @teetandreas.
Not Option to debug either.

It’s strange because I had a fresh stable installation, without any customisation.

At the bottom line HA makes not a stable and serious impression.

As I start new - perhaps ioBroker is the better option I have no legacy yet to migrate

For using addons you have to use an installation method with supervisor to use addons (supervised install or haos).

Here are the methods listed with features of each:

I have the same problem with the disappearance of add-ons and I have not found a solution, please help!

this topic will explain

Hi, I have the same issue, the addon store is disappearing. If I try to add the community addon repo back it says it already exists. Tried a fresh install on my rpi4 with no luck. I also tried turning off the firewall with no luck. I can’t seem to find any open issue on github. No idea what’s going on. any updates?

1 Like