Home Assistant Add-ons missing from GUI

Same here @teetandreas.
Not Option to debug either.

It’s strange because I had a fresh stable installation, without any customisation.

At the bottom line HA makes not a stable and serious impression.

As I start new - perhaps ioBroker is the better option I have no legacy yet to migrate

For using addons you have to use an installation method with supervisor to use addons (supervised install or haos).

Here are the methods listed with features of each:

I have the same problem with the disappearance of add-ons and I have not found a solution, please help!

this topic will explain

Hi, I have the same issue, the addon store is disappearing. If I try to add the community addon repo back it says it already exists. Tried a fresh install on my rpi4 with no luck. I also tried turning off the firewall with no luck. I can’t seem to find any open issue on github. No idea what’s going on. any updates?

1 Like

Same issue here. But I found out, it is because I am running it in docker.
I guess I have to find another hosting solution.

Puh - the answer is : Add-Ons are not supported in container installations according to the setup guide - WTF :frowning:

Is there a technical reason for this? My QNAP is running 24/7 anyway with 16GB of Ram - I don’t want to use a Raspberry - so a VM on the QNap would be a way to get AddOns running for me?

EDIT: After reading a bit into HA-OS - AddOns a seperated in Containers themselves, so that’s why there is not container add-on support? As nested containers are quite new - so is nesting containers on the roadmap or not at all?

1 Like

I share your disappointment. Like you, I’d prefer not to run Home Assistant on a Raspberry Pi because of the unreliability of SD card storage, opting instead for a container on my QNAP. It makes me wonder why there was even a release for a container-based distribution of Home Assistant. Considering the confusion over missing add-ons, one can only imagine the countless hours people have wasted trying to figure out the issue.

Hi, I too have the problem of missing addons.
my installation is HassOS, some time ago the addons started disappearing now I can’t find anything in the collection anymore.
If I try to re-enter the repo it tells me that it is already installed, but I don’t see anything.
Those already installed continue to work, but the icon has disappeared.
I tried uninstalling Hacs and restarting, but nothing… I can’t get to the bottom of the problem!


Sam issue here on rpi5 with nvme top hat (M2 drive as primary) with HAOS 12. No add-ons (nor “dodatki” as in my polish version) available in settings.
How to enter this “secret” menu ??

I have the same issue. I am using the docker container.
Does anyone have the same issue?

I have same problem in docker container.
Must again install the Home assistant with other way?

HA container (docker) does not have add-ons. Only HA OS and HA Supervised do.

1 Like

I’m running HA on RPI4 and yesterday after I’ve upgraded to the 2024.4 I’ve not been able to see the Add-Ons and HACS is not loading the UI.

It was just browser cache!

I am having this issue

I just started a VM on my Synology NAS running a supervised HA. (I tried the docker version first only to run into the afore mentioned missing add-ons capability, so now I am running supervised on a VM)

I can install add-ons only by clicking the little “add-on” button found throughout HA documentation, or by manually navigating to the hassio URL

It is missing in the UI. Never was there from the beginning.

Any tips?

Where are you searching ?
settings → add-ons

Yes. It is not there.

Just did a fresh Docker install on Raspberry Pi 3 running 64bit Debian Bookworm. Went looking for the Settings / Addons option to install Samba so I could copy my config backup from the HA VM - and Addons is nowhere to be seen … :frowning:

Docker installs ( HA Container) do not have add-ons

Thanks Francis. The hope had been to have some other processes running on the Raspberry Pi as well, but seeing as how the Container install doesn’t seem to want to do restores either, it seems I’m heading back to HAOS.
{edited}