Home Assistant Alexa Cloud - Device is unresponsive

same if i ask to turn light on twice it works but annoying as hell

Same issues for me too:

Either Alexa telling me “Device is not responding” when in fact it the device does change state, or Alexa acknowledging the command with “ok” but the device doesn’t change state. If I issue the command straight away again then it works.

There is definitely an issue between one of the integrations: Alexa to Nabu Casa or Nabu Casa to local HA.


Experiencing the same issue on my side, didn’t dig deeper …

1 Like

Having the same experience as others. What is the most frustrating is the lack of consistency, sometimes it works okay and others it doesn’t work at all and sometimes it says it didn’t work when in fact it does.

Agreed on the consistency. I recently had a play with some of my wifi settings and changed my 5Ghz channel. I thought I had it figured out as later that day I didn’t have a single issue. The following day it was back to where it was.

It might be a good idea if we could post here when things are particularly bad to see if it affects everyone at the same time, or is dependant on installation. For me, it was particularly bad 24 hours ago.

1 Like

Hello everyone, is there any update for this? The responses are always incredibly inconsistent. The main issue is with Homematic for me, but responses are slower in general. I have even enabled reporting device states to Alexa, but it’s still terrible.

I made the following steps to improve on my Alexa responses:

​Long version (start from scratch):

  • Unexposed all domains from the “entity management” page, then I let it sync. I confirmed in the Alexa app that there were no entities appearing from HA. If you do still see them, remove them from within your alexa.amazon.com page (Smart Home > Devices > Scroll all the way down > remove all)

  • Toggled off the Alexa integration at Configuration > Cloud in the UI

  • Removed the Home Assistant skill from the Alexa app.

  • Deleted the /config/.storage/cloud file. You can also rename it if you think you might want to revert back to it. This contains what is currently being exposed and to Google/Alexa.

  • Signed out of the cloud service on my HA server and restarted HA.

  • Signed back in to the cloud service.

  • Toggled on the Alexa Integration.

  • Added the Home Assistant skill back to Alexa and authorized it.

  • Then I went back in to “manage entities” to unexpose/expose entities as needed.

Short version:

You could alternatively try only deleting the /config/.storage/cloud file and restarting HA without all the other steps and see how it goes. This will be regenerated after a restart of HA.

I still get the occasional bad response and are more likely to get it when there are more entities involved, especially when calling something more complex like a script/scene, etc. But in general actions take place much faster for me.


Just wanted to chime in as another user with this irritating issue. I’m still in my HA Cloud free trial period. No solution to this by the end of the trial and I’m taking another route, likely the complicated alexa smart home skill mentioned above.

I tried out the cloud service for two reasons: 10% because I’d rather use a cloud service over opening a HTTPS port for app access away from home, and 90% for the alexa integration. If the alexa integration doesn’t work, there’s legitimately zero reason for me to pay $60/year for the service. There’s no point.

Super damn frustrating.

1 Like

I’ve also been having this issue with Alexa saying a device is not responding even though it has clearly accepted the command.

Yesterday after doing an update to 2021.11.5, HA Cloud disappeared and all my Alexa commands failed. After much messing about deleting the .cloud directory and removing the Alexa HA skill etc. I decided to remove all the devices in Alexa and then selectively add them back in once I’d resolved the issues with HA Cloud. So far with less devices to wade through (There was a lot of unnecessary stuff in there from over the years), Alexa has become much more responsive.

It’s early days but I’d say only exposing to Alexa what you actually want to control via her is probably worth doing.

Nabucassa was down yesterday for an extended period…

IIRC there’s an issue with this that’s being investigated.

1 Like

Yeah, I figured it was a Nabu Casa issue even though I kept checking for a status update to confirm my theory but eventually as there was none I assumed it was my end and so spent a lot of time trying to fix it.

There is a strong argument for a service status page, I believe this is not the first time there have been issues with it.


Hi petro. Would this issue be tracked in github so that we could follow it and potentially assist with diagnostics?

I have no idea. I’ve just heard through the grapevine.


I don’t think the Cloud code is open source. If it were I’d be running my own system rather than paying someone else.

Very valid point.

It’s pretty annoying that I can’t control the lights with Alexa anymore…

Sad how the one feature of HA that I pay for isn’t working and there’s no info on potential fixes, but all of the free stuff is super stable (at least for me) and I can track issues/fixes in github.

Aws is having problems right now…

When in doubt, check Amazon servers.

These issues pre-date yesterdays outage by a significant margin of nearly 2 years

Odd, I’ve been using this for 5 years now with no issues. :man_shrugging: EDIT: I should clarify, all the issues I’ve had are self network inflicted or AWS services being down.