Home Assistant app for Fitbit Ionic, Versa family, and Sense


Control your Home Assistant system on your wrist!

Home Butler will automatically discover all the devices registered in your Home Assistant system. However, current version only supports these types and actions:

  • Light: on/off
  • Switch: on/off
  • Climate: auto/off

Please read this document first: https://developers.home-assistant.io/docs/api/rest
Download Link (open it on your phone): https://gam.fitbit.com/gallery/app/061320ab-b602-46e3-89b3-3a3d5f9ea3e2


The app unfortuantely doesn’t work for me… I set up the token, open the app on my watch and then it crashes after like 10 sec. Any ideas what might be wrong or how to debug? I don’t see any errors in HA and I do have a valid Let’s Encrypt certificate for my custom domain as well.

i cant even get it to work that much…
dont know what im doin wrong really…
is it still not working? any step by step guide?

is the code available opensource?


1 Like

ya i cant get this to work either. would be nice to have a setup guide or something

This is looking cool! Is the code available open source? It seems they have removed the external API documentation. Maybe also changed the API a bit?

Got this from developer
Sorry for the delay. 2020 is not easy on me…
The bug has been fixed. I was caused by a Home Assistant’s API change,
which was not announced publicly… New version is under review by
Fitbit Admin.


Very nice! :slight_smile:
Is there any chance for Versa 3 and Sense support?


Hi, the document link is broken. I’ve tried anyway to download it on my FitBit Versa, but I don’t know how to configure the app to let it work with HA.

Someone can help me please?

Hi! Thank you very much for this app! Unfortunatelly I still can´t it get working: I installed it and tried to setup the settings, but when I sync and try to open the app on my fitbit it just says “please configure your Home Asssistant settings in the fitbit app”. Do I use the right settings?


I seem to get a error in HA after inputting the correct info in the app on the phone:
“Login attempt or request with invalid authentication from ( (Fitbit/3.36 Android/29)”

I have a Versa 2 :slight_smile:

Is it still happening with v1.5.0 on Ionic, Versa 2, or Versa Lite?

I really want to. But, there is a reason… Sorry, I cannot share more information on that issue.

Yes, you are right about the API change. Try v1.5.0 if you are using Ionic, Versa 2 or Versa Lite.

A new version (v2.0.1) with new UI design (which I have to make because of the SDK 5.0 incompatibility issue). It’s being reviewed by Fitbit App Gallery admins. Should the available in a few days.

1 Like

In the “protocol” field, put “http” instead of “http://”

Examples of correct configuration:

Example 0 (local setup):
protocol: http
port: 8123
credential: aMEx13lBx…

Example 1 (public setup with domain name & SSL):
protocol: https
host: ha.example.com
port: 443
credential: aMEx13lBx…

The credential is what you generated with Home Assistant in the “Long-Lived Access Tokens” section at http(s)://your.domain.or.ip:8123/profile

1 Like

thanks! its working now with example 1!!

Version 2.0.1 for Fitbit Versa 3 and Sense is now available in Fitbit App Gallery.

1 Like

Thanks @heqian for the update, works quite well in my Versa 3!

Maybe it’s a bit too sensitive to scroll events when tapping to an icon though, and would be nice a status indicator (like a spinner when request is in progress).

Question: could you consider releasing the code as open source? A part the ethical implications, I’d like to help in contributing to it and I guess other people in the HA community could, in order to improve the devices support! :slight_smile: