Home assistant cant connect to anything cloud realted and Im at a lose

Home assistant can’t connect to any cloud integrations and I get an error trying to log into the cloud. I’m at a loss. It has been almost a week and I simply can not find a solution anywhere. And if I find anything related to my issue, it feels like I need to go to college to understand any of it. I am a tech-savvy person but home assistant is far more complex than I ever thought. I know a lot about PCs, phones, and stuff like that, But almost nothing about networking and servers etc.

Can someone please help me and try their best to make it more understandable? because I truly don’t know what else to do at this point and I just need some help.


HA Instance: HAOS (Generic x86-64)

Hardware: Running HAOS on this old HP laptop

Here are some errors:

Google Calender Intagration
Home Assistant Cloud Login
Meteorologisk institutt

Go to Settings → System → Network.

Select your adaptor and protocol (e.g. IPv4) then check your DNS settings. Try or

Okay, so I went to Settings → System → Network and changed the DSN Servers option in both IPv4 and IPv4 to both and and nothing changed.

Recent installation, flashed with Balena Etcher ?


yep. I flashed it with Balena Etcher on Ubuntu Linux about a week ago. Problem was here from the start.

1 Like

Sounds like this if so, mark Francis with the solve…

How. Many times has this come up?

1 Like

Seems a problem caused by Belana Etcher

use USBImager instead


ya, I tried reinstalling haos but it froze at 32% so I just gave up. But when booting haos back up, even tho it was 32% thought flashing the drive, hoas was still working just fine and I just needed to create an account and set everything back up like a fresh new install. But the problem still persisted.

Ill try that tomorrow and see it it works!

THANKYOU! I went onto my windows pc and used USBimager to flash HaOS onto a usb then booted on it from the old laptop, created a new account, and was greeted with the weather! After looking in integrations both radio browser and the weather integration are working! Thanks you!

1 Like

Tried it with rufus today (which worked before) and same problem