Flashing hard drive get stuck at 31% (balena fetcher)

Hi everyone,

I am a 2 year long HA user and I just bought a pre-owned HP thinclient t620 to run HA (to replace my current VM).

I performed a few checks and the thinclient works just fine.

I then proceeded to install home assistant following this guide : Generic x86-64 - Home Assistant. I first created a live Ubuntu usb drive and loaded ubuntu from the usb on the thinclient. From the ubuntu, I downloaded the HAOS image as well as balena.
Then, flashed the hard drive on the thinclient with the HAOS image using balena.

The issue is that it get stuck at 31% exactly (everything freeze, can’t move the mouse, use keyboard, nothing). This occurred twice, both time at 31%.

Anybody as any idea on what is happening and how to solve the issue?

Thanks in advance to the kind soul(s) that will help me!


1 Like

I think if you press ctrl+shift+i while Balena Etcher is running it should bring up a debug console you can monitor. Before it freezes would be a good idea :slight_smile:

There seems to be some gaps in your description. Does this PC use eMMC or mSATA SSD for the boot device?

How are you flashing the HAOS image? What are the physical steps?
Does the PC come with Windows already installed? On what boot device? Is there a manufacturer’s process to “factory” restore the OS?

When you boot Ubuntu on the USB, try installing Ubuntu. If this works then you can install HA using a Frankenstein method like VM or Docker. But, if you can install Ubuntu you should be able to install HAOS.

They are following the official guide:

Boot a live Linux USB → Flash HAOS image to system drive.

The docs describe two methods for flashing HAOS, and Etcher has two methods for flashing to the boot device. The OP already said he downloaded the binary so the Etcher question is answered.

I think this PC uses an eMMC SSD for the flash device, so my question is how is he flashing an image to the eMMC?

And they told us which one they used:

or as I summarised:

With Balena Etcher from a bootable live USB, as above.

I’m not familiar with eMMC SSD, is there something special about writing an image to it?

I have one (Zotac) micro PC that has an eMMC boot disk. I could never get anything to flash to it. It also has an internal 2.5" SATA SSD where I flashed Ubuntu and changed the BIOS to boot from the SATA SSD. In my experience, if you can flash and run Ubuntu, HAOS works as well.

Hello guys!

Thanks a lot for your reply.

Indeed, I’m following the official guide, with the Bootable “live” ubuntu option.

Strangely, I tried a 3rd time, and it got stuck at 31% again. However, I let the computer work for 1hours, unplugged the computer, replugged it, unplugged the usb, and it booted on HA. It seems that while visually everything was frozen, it actually was working in the background.

I am now on HA and most of the things seems to work. Most… Because I can’t install hacs for some reasons. Ssh returns error “unable to resolve host address : get.hacs.xyz”.

Seems like it will be a long night…


I have the exact same behaviour, and I’m not sure if everything will work.
Any solution to the incomplete flashing?


1 Like

Hi !

I dont know whether it IS incomplete or its reach completion but we just cannot see it.

Anyway, I have access to home asssistant, but experiencing some issue that might be related (or not) to this.


I just read your other topic: Need help - many issues, probably related to each other

All of your issues are DNS issues. Go to Settings → System → Network and update your DNS server there. Use or as your DNS server.

So it looks like your install did complete successfully.

Hi Tom,

Actually, I already tried or or even, but all issues remains …

I strongly believe this is a DNS issue indeed, but have no idea how to resolve it.

Any other suggestion?

I had the same issue and finally gave up the Ubuntu live install path. I removed the ssd, installed it in an USB Adapter and flashed it on my Windows PC without any Problem.

Thanks for your input

And yes, I guess that might be the route I will end up taking …

I’m confused (normal). You said that you downloaded the binary and flashed the SSD using Balena. And I asked, and got chastised for asking, how did you flash the SSD? As I understand the ThinClient, the boot device is an eMMC soldered to the board, so how did you flash it?

I flashed it from Ubuntu running on a live usb plugged and booted to the thinclient

So, to be clear, from Balena you got an option to select the target drive, and you were able to select the eMMC SSD on the HP?

Yes indeed!

And, every time you do this, it gets stuck at 31%?

At this point I would install Ubuntu Desktop to the eMMC SSD. Use the parted utility to make sure you don’t have any partitions locked by HP which could potentially reduce the accessible size of the SSD. Then, flash HAOS again.

I have exactly the same problem. I installed live Lubuntu on SD card and booted it on former Chrome-box by HP (before that I had taken care of getting rid of Chrome OS, SecureBoot, etc. on this box, formatted box’s SDD with FAT32). Then I installed Balena etcher on this live Lubuntu, downloaded HAOS image and tried (few times) to flash SSD of the box with HAOS. It gets stuck at exactly 31%.

Before I tried (as a test) to do a similar thing but with live Lubuntu booted from USB and I tried to flash SD card. It also got stuck at 31%.