Home Assistant Community Add-on: AdGuard Home

I’ve added my Home Assistant FQDN into “Settings - Filters - Custom filtering rules”, like @@||hostname.zapto.org^

Is that your problem as well ?

Tripped over this as in my previous Pi-Hole standalone instance I had added an entry in the hosts file to point the domain name to an internal IP

Add in a DNS rewrite (not the most intuitive name for it)

with the domain name you use and the IP address.

Just installed this add-on following a conversation with @frenck. I am trying to use DoH. If I enable the encryption;


I get this error

Also the notes say it will listen for DoH but does it submit upstream requests over DoH and if so on what port?

Further down it asks for certificate paths. What would the correct path for these be inside the add-on?

Fixed with „DNS rewrites“

In case anyone comes across this, the answer is blindingly simple. Under the DNS settings, when specifying the upstream DNS, if you specify one as https AdGuard then does all requests over that DoH resolver.



The lower ‘bootstrap’ setting is the DNS server used by AdGuard to find the IP of the specified upstream DNS resolver.

If you want to see this for yourself, install tshark and run this command while restarting the add-on and other than some internal docker queries, you will just see entries relating to the DoH resolver domain. For any other machine you will see incoming queries but no outgoing one on port 53.

sudo tshark -i any -f "src port 53" -n -T fields -e frame.time -e ip.src -e ip.dst -e dns.qry.name

Quite brilliant.

Is anyone else having this error when running AdGuard

INFO (MainThread) [hassio.updater] Fetch update data from https://version.home-assistant.io/stable.json
20-03-04 19:28:56 WARNING (MainThread) [hassio.updater] Can't fetch versions from https://version.home-assistant.io/stable.json: Cannot connect to host version.home-assistant.io:443 ssl:None [Try again]

in another post got this issue with PiHole Cannot connect to host version.home-assistant.io:443

I’m experiencing the same issue. After disabling the AdGuard module the hassio.updater can fetch new versions again.

This is caused by skipping the first step of the add-on installation guide. Please made sure you followed that.

yes, figured it out, but I am not sure how to set an static ip and external dns under Hass.io on Synology DSM (native package)

maybe anyone can help me out, please?

I’d ask as a separate question so it doesn’t pollute this thread. Of course “Google is your friend”. Try a search on “synology dsm static ip”.

its already set up like this, but thanks for being such helpful :wink:

1 Like

\o/ thanx for your help #rtfm :wink:

1 Like

It looks like the average processing time sensor has the wrong decimal place. I’m seeing the sensor show an average processing time of 4.58 ms whereas the AdGuard Home dashboard shows 46 ms. Am I misreading this?

Is there any ability to add a functionality for blocking self-promotion/ads from search engines? The first few links where they’re noted as ‘ads’?

Perhaps I’m missing it but I noticed that all these used to be dead from pihole but I’ve recently moved to adguard with the home assistant integration and love it but noticed these links are no longer dead and they work.


EDIT: Also I wanted to say thank you so much for this integration and hard work. I absolutely love it!

Hi all,
I’ve got this addon up and running, blocking ads on all devices connected to my router, but the client list on the dashboard only shows one client, my RPi that’s running Adguard Home.

I’ve tried to search about on how to change it but I’m still at a loss. Do I need to set a DHCP in the addon, they show as experimental? Do I need to force the DHCP leases for my router (and all connected devices) to expire? Do I need to disable DHCP on my router (I’m assuming no but figure I should through it in the mix)?

If someone can give me a simple answer that my fried little brain can comprehend that would be amazing.


Salve ho 2 domande su Adguard Home su hassio con docker su raspbian!

  1. non ho ben capito se devo cambiare il dns dentro il dhcp, ho nella voce dnsv4 (fritz box)
  2. ce un modo per ripulire la query? un reset della dashboard?

Hi I have 2 questions about Adguard Home on hassio with docker on raspbian!

  1. I don’t quite understand if I have to change the dns inside the dhcp, I have in the entry dnsv4 (fritz box)
  2. is there a way to clean up the query? a reset of the dashboard?

You both have to change the dns adress in your dhcp options of your router.
Normaly the new ip adress should be the same as the one your using to connect to your home assistant.
E.g.: if your home assistant server uses the ip set the dns server adress to this ip.


My AdGuard Home add-on is no longer listening on IPV6:
Bildschirmfoto vom 2020-04-03 11-19-39

I know that it used to listen on at least one of the local IPV6 addresses assigned to the Raspberry Pi / Hass.io instance. This must have changed recently, but I cannot identify what might have triggered that.

I’ve tried restarting the add-on, restarting Home Assistant, and a full reboot of the Raspberry Pi already, but it didn’t help. Any further ideas?

AdGuard Home seems to listen on IPV6 even if it is not showing the address on the setup screen.
At least DNS from IPV6 addresses on my local network appear in the logs and seem to be answered or filtered, respectively, by AdGuard Home.

Thus it might just be a cosmetic issue.

I have Home Assistant running on Ubuntu Server 18.04.4 LTS,
On my HA i have DuckDNS and https configured.
I installed AdGuard Home, and almost everything is fine.
I can’t open AdGuard Web UI, I’m getting 502: Bad Gateway.
It is caused by using UFW firewall on my Ubuntu Server machine. When i tried to turn it off, AdGuard Web UI begins to work. However, disabling firewall it is not an option for me.
I tried add ‘allow rules’ for port 3000 but it doesn’t help.
When i manually open https://myid.duckdns.org:3000/ ,Web UI works , but not inside Home Assistant
Port 3000 is forwarded on router to my server

What port should be opened to make Web UI work?

Heres my AdGuard config

Here is my Adguard log dump

Add-on version: 2.3.3
 There is an update available for this add-on!
 Latest add-on version: null
 Please consider upgrading as soon as possible.
 System: Ubuntu 18.04.4 LTS  (amd64 / qemux86-64)
 Home Assistant Core: 0.107.4
 Home Assistant Supervisor: 214
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] adguard.sh: executing... 
[cont-init.d] adguard.sh: exited 0.
[cont-init.d] discovery.sh: executing... 
[22:51:45] INFO: Successfully send discovery information to Home Assistant.
[cont-init.d] discovery.sh: exited 0.
[cont-init.d] nginx.sh: executing... 
[cont-init.d] nginx.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[22:51:50] INFO: Starting AdGuard Home server...
[services.d] done.
2020/04/03 22:51:50 [info] AdGuard Home, version v0.101.0, channel release
, arch linux amd64%!(EXTRA string=)
2020/04/03 22:51:50 [info] Upstream 0: https://dns10.quad9.net:443/dns-query
2020/04/03 22:51:50 [info] Go to
[22:51:50] INFO: Starting NGinx...
2020/04/03 22:51:51 [info] Starting the DNS proxy server
2020/04/03 22:51:51 [info] Ratelimit is enabled and set to 20 rps
2020/04/03 22:51:51 [info] The server is configured to refuse ANY requests
2020/04/03 22:51:51 [info] DNS cache is enabled
2020/04/03 22:51:51 [info] Creating the UDP server socket
2020/04/03 22:51:51 [info] Listening to udp://[::]:53
2020/04/03 22:51:51 [info] Creating the TCP server socket
2020/04/03 22:51:51 [info] Listening to tcp://[::]:53
2020/04/03 22:51:51 [info] Entering the tcp listener loop on [::]:53
2020/04/03 22:51:51 [info] Entering the UDP listener loop on [::]:53
nginx: [alert] detected a LuaJIT version which is not OpenResty's; many optimizations will be disabled and performance will be compromised (see https://github.com/openresty/luajit2 for OpenResty's LuaJIT or, even better, consider using the OpenResty releases from https://openresty.org/en/download.html)

If anyone got similar problem, here is my solution:

  1. check ports in use

sudo ss -tulw

  1. look for docker IP, something that starts with 172.x.x.x
  2. allow that port with UFW

sudo ufw allow from to any port xxxxx


Frenck, may I ask the technical reasons to use a static IP vs DHCP reservation? I’m curious as to why not to use DHCP static reservations.

(I’m about to redo my entire network, starting from scratch with new Unifi hardware - looking into where [i.e. vlans] to place HA)