Home Assistant Community Add-on: AdGuard Home

I’m running this add-on for a while now, without any problems.

A couple of weeks ago I suddenly had a problem streaming GoPlay (from Belgium).

The strange thing is that when this occurs, I just have to stop and restart the add-on to make it work again.

How can I resolve that ?

It works on Hassio 2024.1

alias: "ADGUARD: Youtube bloqueo/desbloqueo manual"
description: ""
trigger:
  - platform: state
    entity_id:
      - input_boolean.youtube
    to: null
action:
  - if:
      - condition: state
        entity_id: input_boolean.youtube
        state: "on"
    then:
      - service: adguard.add_url
        metadata: {}
        data:
          name: Youtube
          url: >-
            https://raw.githubusercontent.com/gieljnssns/Social-media-Blocklists/master/adguard-youtube.txt
    else:
      - service: adguard.remove_url
        metadata: {}
        data:
          url: >-
            https://raw.githubusercontent.com/gieljnssns/Social-media-Blocklists/master/adguard-youtube.txt
mode: single

After the core update (on Odroid N2) the addon doesn’t work anymore. Get message “Error fetching addon info: Unknown error, see supervisor logs”
Logfile:

Logger: homeassistant.components.hassio.handler
Source: components/hassio/handler.py:575
Integration: Home Assistant Supervisor (documentation, issues)
First occurred: 12:43:39 (11 occurrences)
Last logged: 12:59:31

/addons/a0d7b954_adguard/info return code 500
/addons/a0d7b954_esphome/info return code 500

Are there more people with this problem and how to solve this?

What do the addon logs say? Sounds like it’s not starting for some reason

I can see the addon but when I click on it the only thing I get is an error. Also no option to delete the addon.

Ok - do you have access to the HA command line via SSH or by connecting a monitor to your machine? You can access the logs via this command:

ha addons logs a0d7b954_adguard

Otherwise, there’s always 'turn it off and turn it on again. - did you try a reboot of the HA device?

After 3 times reboot still not work. Also problem to start SSH so decided to cutt off the power completly. After shut down and power cycle everthing works. So problem solved. Thnx for the support.

Can you please give more detail on the setup?

I added the Repo, added Portainer, added PixelServ-TLS docker.

When I run the docker image in Portainer it says:
Stopped for … with exit code 1

The logs say:
exec /etc/init.d/docker-entrypoint.sh: exec format error

I’d really like to get this working for AdGuard. Thanks for the tips. Wish I could get it running.

You would want to focus on getting your pixelserv docker running.

First of all, check your metal box. Is it x86 or arm?

Edit: Forgot to add - the reason I am asking x86 or arm is because the imthai docker image was for x86… and I’m sure there are arm equivalent pixelserv docker out there.

Having installed the Adguard Home add-on, I want to be able to send it cURL requests from custom switch/rest/configuration (to block specific client lists). However, I can only access the web interface through the HA admin instance (on the web interface running on 8123). How do I open Adguard to be able to query it via cURL requests (from within HA) ? where do I find the user/pass and ip/port that Adguard will receive these cURL requests on?

I am trying to configure access via username and password. I enabled the web port in the configuration but as soon as I do that the add-on won’t start anymore. I tried different port making sure that I don’t overlap with an existing service. The log file only says

[06:26:10] INFO: Successfully send discovery information to Home Assistant.
s6-rc: info: service discovery successfully started
/run/s6/basedir/scripts/rc.init: warning: s6-rc failed to properly bring all the services up! Check your logs (in /run/uncaught-logs/current if you have in-container logging) for more information.
/run/s6/basedir/scripts/rc.init: fatal: stopping the container.
s6-rc: info: service discovery: stopping
s6-rc: info: service discovery successfully stopped
s6-rc: info: service adguard: stopping

Is there anything else I have to setup first?