Home Assistant Community Add-on: iSolarCloud / Sungrow

Everyone,
Finally got around to making an HA add-on for my GoSunGrow API tool. This works for all Sungrow based solar systems.

You can pick up the add-on from my GitHub HA repo

Will be shortly creating a lovelace custom card so your output can look like this.

Anyway, enjoy…

Let me know of any issues on GitHub.

6 Likes

Looks like some great work here, any chance you could help me get this add on containerized I am a bit new to docker and struggling but really want this intergration.

Many thanks in advance

1 Like

The HA add on I created does this for you, and will run on the HA instance.

If you want to run it on another docker instance, then you can use the Dockerfile from the GoSunGrow GitHub repo.

You’ll need to set the important environment variables when starting the container.

Would be really interested to see how you go with it.

Good afternoon Mikemake , I ended up switching to supervised and have it installed but I belive I need to gather the MQTT setting as the log is erroring with the below… Any idea what I am doing wrong

Token File: /root/.GoSungrow/AppService_login.json
2022-04-26 17:05:17 Found SunGrow device 1134571_11_0_0 id:(edited out ID ) serial:(edited out serial number)
2022-04-26 17:05:17 Connecting to MQTT HASSIO Service…
Error: network Error : dial tcp 127.0.0.1:1883: connect: connection refused
Usage:
GoSungrow mqtt sync [flags]
Aliases:

I just installed the GoSungrow addon but cannot get it to connect to the EU server. I probably don’t have the right URL though, just tested a couple. Any chance somebody have got this to work on EU servers and can share the link? I have tested with: hxxps://eugateway.isolarcloud.com and hxxps://www.isolarcloud.eu but no luck. Log:

[21:50:08] INFO: Login to iSolarCloud using gateway hxxps://eugateway.isolarcloud.com …
ERROR: Post “hxxps://eugateway.isolarcloud.com/v1/userService/login”: x509: certificate is valid for *.isolarcloud.eu, isolarcloud.eu, not eugateway.isolarcloud. com
[21:50:09] INFO: Syncing data from gateway hxxps://eugateway.isolarcloud.com …
2022-05-08 21:50:09 Connecting to SunGrow…
Error: Post “hxxps://eugateway.isolarcloud.com/v1/userService/login”: x509: certificate is valid for *.isolarcloud.eu, isolarcloud.eu, not eugateway.isolarcloud. com
Usage:
GoSungrow mqtt sync [flags]
Aliases:
sync,
Examples:
GoSungrow mqtt sync
GoSungrow mqtt sync all
Flags: Use “GoSungrow help-all” for more info.
Additional help topics:
ERROR: Post “hxxps://eugateway.isolarcloud.com/v1/userService/login”: x509: certificate is valid for *.isolarcloud.eu, isolarcloud.eu, not eugateway.isolarcloud.com
[cmd] /usr/local/bin/run.sh exited 0

Summary

This text will be hidden

[cont-finish.d] executing container finish scripts…
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

For EU server make sure that you use https://gateway.isolarcloud.eu

The four servers that should work are:

Australian
https://augateway.isolarcloud.com

European
https://gateway.isolarcloud.eu

Chinese
https://gateway.isolarcloud.com

International
https:/gateway.isolarcloud.com.hk

Good afternoon Mikemake , I ended up switching to supervised and have it installed but I belive I need to gather the MQTT setting as the log is erroring with the below… Any idea what I am doing wrong

I believe you should be able to point just the MQTT server IP address at your local IP address that you use for your HA instance.

Unfortunately not, I can’t seem to get it working. :frowning:

Hi, i have some problems during the installation. I´ve got this error message after clicking on “install”.

The command ‘/bin/ash -o pipefail -c chmod a+x /usr/local/bin/run.sh /usr/local/bin/getUrl.sh && /usr/local/bin/getUrl.sh’ returned a non-zero code: 1

Any idea what i can do?

Hi, I’m getting the error

s6-overlay-suexec: fatal: can only run as pid 1

I’ve put in my credentials correctly and restarted HA

We had this problem some weeks ago when s6 was updated to v3. The add-on developer should update the add-on following the instructions here: Hello_world example addon from developer docs stopped working (s6 overlay issue?)

1 Like

They still have not done that, is it possible to do it ourselves? how hard is it?

The person that developed the add-on just has to follow the simple instructions on the site that I posted previously. That’s the solution. It must be executed by the add-on developer.

Looking at the two forks that have been created to try and solve this I’m not sure its necessarily just that. Though I may have something not setup right my end as I’m a newbie on this stuff so apologies if thats the case:

I get the same issue on each fork which has implemented the fix to test it:

[05:52:26] INFO: Setting up GoSungrow config ...
**parse error: Expected string key before ':' at line 1, column 4**
**[05:52:26] ERROR: Unknown HTTP error occured**
**[05:52:27] INFO: Writing GoSungrow config ...**
**ERROR: $HOME is not defined**
**[05:52:27] INFO: Login to iSolarCloud using gateway null ...**
**ERROR: $HOME is not defined**
**[05:52:27] INFO: Syncing data from gateway null ...**
**ERROR: $HOME is not defined**
s6-rc: info: service legacy-services: stopping
s6-rc: info: service legacy-services successfully stopped
s6-rc: info: service legacy-cont-init: stopping
s6-rc: info: service legacy-cont-init successfully stopped
s6-rc: info: service fix-attrs: stopping
s6-rc: info: service fix-attrs successfully stopped
s6-rc: info: service s6rc-oneshot-runner: stopping
s6-rc: info: service s6rc-oneshot-runner successfully stopped
1 Like

Well there seems to be another issue when starting the add-on, however the following original error seems to be solved: s6-overlay-suexec: fatal: can only run as pid 1.

The current error doesn’t seems to be s6-overlay related, it seems like an add-on configuration file error.

Hi,
are there any new information or solution to solve this error?
s6-overlay-suexec: fatal: can only run as pid 1

Hi

Have same error

on the GitHub page is already a release 2.3.1, but via the repo in homeassistant only version 2.2.0 is installed. can no one help here?

I am waiting for update too.
“s6-overlay-suexec: fatal: can only run as pid 1”

Hi all.

Im getting the eaxct same log results as D0cker5:…

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
s6-rc: info: service legacy-services successfully started
[04:21:10] INFO: Setting up GoSungrow config ...
parse error: Expected string key before ':' at line 1, column 4
[04:21:10] ERROR: Unknown HTTP error occured
[04:21:11] INFO: Writing GoSungrow config ...
ERROR: $HOME is not defined
[04:21:11] INFO: Login to iSolarCloud using gateway null ...
ERROR: $HOME is not defined
[04:21:11] INFO: Syncing data from gateway null ...
ERROR: $HOME is not defined
s6-rc: info: service legacy-services: stopping
s6-rc: info: service legacy-services successfully stopped
s6-rc: info: service legacy-cont-init: stopping
s6-rc: info: service legacy-cont-init successfully stopped
s6-rc: info: service fix-attrs: stopping
s6-rc: info: service fix-attrs successfully stopped
s6-rc: info: service s6rc-oneshot-runner: stopping
s6-rc: info: service s6rc-oneshot-runner successfully stopped

Has there been any progress on a fix or what was done to fix?

Cheers,

Jarrod.