Home Assistant Community Add-on: motionEye

thanks a lot for providing this addon.

:tada: Release v0.4.1

Full Changelog

This release fixes an issue with enabling motion_webcontrol causing the add-on to crash.

:hammer: Changes

  • :ambulance: Fixes incorrect Bashio log calls

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck


Hey Frenck

I have been trying to install this since yesterday, but both of my HA servers say that the the addon is not available for my system. Both HA’s are up to date. Is this because this has just been launched?


Define up-to-date, which version? Home Assistant needs to be at least 0.91.4 now.

my dev machine is on 91.3, My production machine is on 90.2 (yes its a bit old, but not that old)

Hmm…looks like I solved my own issue…seems that this addon only works on 91.4 or newer…thanks

I have an issue after updating the add-on. It no longer allows me to restore from a motioneye backup file.

Hello. Is it possible to get h264_omx on rpi3B+ working?

I cannot get a network share to mount so i can save recordings in my nas instead of Ha machine. Anyone get it to work? I’m using a Ubuntu vm

Seems the button “obtain key” from the file storage panel is broken. It leeds to a 404 error. I tried ti generate by another way a key but i didn’t succeed in.

Any workaround in order to obtain that key to store file on a google drive?

Hass 91.4 on RPI3b+

I finally got it… my share name did not need a /. i ended up trying to mount //ip:address//share

is there a file size limit option instead of just number of days to keep files?

:tada: Release v0.4.2

Full Changelog

:sparkles: This release adds support for the “Add to sidebar” feature that became available in Home Assistant 0.92.

Please note: You need to have Home Assistant 0.92 or newer to be able to install this update.

:hammer: Changes

  • :arrow_up: Updates Home Assistant requirement to 0.92.0b2
  • :sparkles: Adds support for showing in sidebar

Questions? Join our Discord server! https://discord.me/hassioaddons
Enjoying my add-ons? Consider supporting my work: https://patreon.com/frenck


Hi I installed the add-on, started it, but when I click on it it gives me a message “401: unauthorized” either by running it from the web ui or from the sidebar. I tried to reinstall it, but the usual error comes up …

I need to change the storage location due to space issues. What’s the simplest way to change the location? I’ve got plenty of storage outside of the docker volumes.

I’m having the same issue, I can’t obtain a key to be able to link motionEye with Google Drive. :confused:


The requested URL  `/o/oauth2/auth`  was not found on this server. That’s all we know.

Did you find a solution @ivico?

I just figured out that recent version of motionEye addon with Ingress support prevents using Snapshot URL of a camera unless you are authorized against Home Assistant UI. If you open the URL in an incognito window, you’ll get “unauthorized” error. This makes impossible, e.g., to use it as the still_image_url parameter for an HA camera.
There is a workaround: one should change addon configuration so that container port in the Network Section has a meaningful value (e.g. 8675 like Frenck suggested in the release notes). Save, restart addon, then open motionEye with URL like: <your_ha_address>:8675, then copy Snapshot URL again. This new URL will be accessible outside of HA.
Hope this helps.



Do you find it better to use the still image directly from the camera or from motion eye?

Thanks for this tip. The same thing can be used to allow authorization with Google Drive service. For anyone else that’s having the same issue.

  1. Set the motioeye port (ie. 8675).
  2. Open motionEye with URL like: <your_ha_address>:8675
  3. The authorize service for Google Drive will now work as you’re no longer using the Ingress URL.
1 Like

My camera doesn’t offer still image URL so I cannot compare. I wanted motioneye to provide one to test new stream HA feature which is only supported by the generic camera component for now. Generic camera, in turn, requires two parameters: still_image_url and stream_source. Nevermind, I failed to get it working both using rtsp stream from my camera and mjpeg stream provided by motioneye.

Did anybody manage to use camera.stream service with a motioneye stream?

Additional thoughts: if you have only one client for your camera, probably you’ll notice no difference or even motionEye may add a small delay. But for several clients motionEye should handle it better than a tiny camera microcontroller.

1 Like