Home Assistant Community Add-on: motionEye

I’m using motioneye with a Dafang Hack cameras, all of which have their own built-in motion detection. And create an MQTT binary switch for motion detection, which HA can auto-discover.

Which would be best in terms of lower CPU / RAM resource use? Let the DaFang Cameras do the motion detection or let MotionEye handle it?

The main reason for wanting to use MotionEye is that it has a very handy feature of auto-uploading stills and video to my Google Drive. So I have an off-site backup.

Thanks, currently only have one cam, and will add an additional one this summer. They are LTS cams, so probably more than I need, but they work great. Plus I get a great deal on them. I figured if I didn’t have MotionEye handle streaming it would work better (since the camera is already doing it, and supports still, ONVIF, etc).

Lately I noticed every time I go to the MotionEye add-on, I have to login over and over again. This while the remember me button is turned on. Something to do with cache or…?

I use Safari the latest version on my macOS.

use https://motioneyeip:8765

my stream still only shows a couple seconds of video then freezes with the a picture card… its fine in the actual MotionEye window

someone is kind enough to explain to me how to configure the recordings on “google drive” I have not found any documentation on the steps. Thank you

The steps are detailed in post #146

I have an issue that has persisted since I first started using the addon. Every time the addon is restarted I get a critical error which makes it unusable:

CRITICAL: media directory "/var/lib/motioneye" does not exist or is not writable

The only workaround is for me to unistall and re-install the add-on. Fortunately I have a backup config for the addon so that I can reconfigure it quickly. The above error is always for the same directory.

sorry in the post 146 I don’t see “The steps are detailed” I see this …

These are the steps to follow.


I am trying to run PS3Eye camera (USB) connected to RPI3B running HassIO 0.92.2.

I tried looking for some guidance here.

However aint got much traction.

Can someone please guide how to use PS3Eye camera to be able to use MotionEye for Motion detection. For motioneye itself I guess pretty much a lot of documentation would be availabe to make it work.


I’m still unable to get the add-on to start up. As far as I can tell everything is setup correctly.

I have /share/google_assistant.json installed and the content looks right…


Those who have it work, are you able to shed some light or share your config?

I’m using Hass.io inside Docker/Proxmox and currently running HomeAssistant 0.93.0

Is there someone who has been able to get a ESPHome ESP32 camera to work with motioneye?

I added the ESP32 camera with ESPHome. Then I added the integration, so that I have a new entity within Hassio, containing the videostream.

Now I’m struggling to find the correct settings to access this stream in motioneye. Any help would be appreciated!


Providing the ESP32 camera is broadcasting an RTSP stream, you should be able to access it in MotionEye as a Network Camera.

A quick Google search seems to imply that the following address is what you need. rtsp://yourdevipaddr:8554/mjpeg/1 the trailing address after the port number maybe different in your case.


I tried your suggestion, but I’m still struggling. Which camera type do I choose?


Also it’s unable to connect:


Greetings fellow HassOS Motioneye users.

I noticed that my CPU usage was very high and after investigating the source (thanks to @tom_l and the help on using Portainer) the culprit was confirmed to be MotionEye. Without ME running CPU is generally below 5%. However, as soon as I start up ME it rockets and is always >85% and causes the RPi to overheat.

Given I am only driving 3xRTSP camera’s off ME, I’m struggling to understand why it has such a massive impact on the RPi. Each of the cameras is configured as follows and is set to the lowest frame rate;

I am posting here in the hope that someone can confirm this is normal (or not) and if there is a parameter somewhere else I have missed.

Thanks in advance.

It is a Pi!


Thanks @frenck so I take that to mean it is “normal” for a RPi and if I really want to use ME I should consider migrating to another platform.

I tried it before,
Now I am only using hassio with adb, mariadb, MQTT server, configurator

Even than it uses 500mb ram.
With cpu @ 3% and load reaches .90.

1 Like

A pi is a small and limited computer. It can do quite a bit. But video is heavy… 3 streams and all the rest, to be honest I’m amazed it even manages to do it without instantly crashing

1 Like