Home Assistant Community Add-on: Traccar

This add-on is provided by the Home Assistant Community Add-ons project.

GitHub Release GitLab CI Project Stage Project Maintenance

Supports armhf Architecture Supports armv7 Architecture Supports aarch64 Architecture Supports amd64 Architecture Supports i386 Architecture


Traccar is modern GPS Tracking Platform, which is now available as an add-on and allows you to run your GPS Tracking software without any cloud.

Traccar supports more protocols and device models than any other GPS tracking system on the market, straight from your Home Assistant instance. You can select GPS trackers from a variety of vendors from low-cost Chinese models to high-end quality brands.

Traccar also has native mobile apps available for Android and iOS platforms so that you can track those as well. AND! With the Home Assistant traccar component (introduced in 0.83) the data in Traccar will be sent back into your Home Assistant instance as well.


The installation of this add-on is pretty straightforward and not different in comparison to installing any other add-on.

  1. Ensure you have the official “MariaDB” add-on installed and running!
  2. Search for the “Traccar” add-on in the add-on store and install it.
  3. Start the “Traccar” add-on
  4. Check the logs of the “Traccar” add-on to see if everything went well.
  5. Click the “OPEN WEB UI” button and log in using admin/admin.
  6. Be sure to change the username, email, and password!


You can always try to get support from the community here at the Home Assistant community forums, join the conversation!

Questions? You have several options to get them answered:

You could also open an issue on GitHub, in case you ran into a bug, or maybe you have an idea on improving the addon:

:information_source: At this moment our Home Assistant Community Add-ons Discord chat server and GitHub are our only official support channels. All others rely on community effort.

Repository on GitHub

Looking for more add-ons?

The primary goal of our add-ons project is to provide you (as a Home Assistant user) with additional, high quality, add-ons that allow you to take your automated home to the next level.

Check out some of our other add-ons in our Home Assistant Community Add-ons project.


About the author of this add-on

Hi there!

I am Franck Nijhof, and I have 30 years of programming experience, in many languages. I am using this experience to work on the Home Assistant project by giving back my knowledge and time to the open source community.

The add-on you are currently looking at right now was developed/packaged by me. It is not the only add-on I have created; there are many many more :wink:

However, I have a problem… I am an addict. A :coffee: addict that is. Lucky for you, I turn that C8H10N4O2 (caffeine molecule) into code (and add-ons)!

If you want to show your appreciation, consider supporting me for buying a cup of high octane wakey juice via one of the platforms below! :heart:

Sponsor Frenck via GitHub Sponsors

Support Frenck on Patreon

Enjoy your add-on, while I enjoy the brain juice. :coffee:

Thanks for all the :two_hearts:


Join our Discord server Follow me on Twitter Flollow me on Instragram Follow me on GitHub Follow me on YouTube Follow me on Twitch patreon-icon

P.S.: In case you want to ask me a question: AMA (Ask Me Anything). Most of the time I am online at the Discord chat. (I go by @Frenck in there as well).

Anyone know if it is the Traccar android client that can’t handle https or if it’s in the addon?
Trying http://my.duckdns.org:5055 in the client works, but not https://
Https:// works fine on the web UI.

Hi. Thank you very much for this awesome add-on. I’ve followed the instructions and I already have the traccar server working. But I haven’t succeded in the hassio integration part in order to use it as a device tracker.

I have used the snippet found in the documentation:

      - platform: traccar
        host: a0d7b954-traccar
        port: 8072
        username: YOUR_USERNAME
        password: YOUR_PASSWORD

But I get this error:

Error connecting to Traccar, Cannot connect to host a0d7b954-traccar:8072 ssl:None [Name does not resolve]

My android client can connect successfully to my https server (duckdns.org) in the port 8072

I’m using the Android client to connect to an nginx reverse proxy and it works fine: instead of http://myurl.duckdns.org:5055, I have https://myurl.duckdns.org

Mine worked too at the port 8072, did not think i could use the web ui port as connection port for the android client.

I just upgraded from 0.82 and i get the same error

2018-11-30 11:51:36 ERROR (MainThread) [pytraccar.api] Error connecting to Traccar, Cannot connect to host a0d7b954-traccar:8072 ssl:None [Name does not resolve]
2018-11-30 11:51:36 ERROR (MainThread) [homeassistant.components.device_tracker] Error setting up platform traccar

I did run the old custom component earlier if that might have an impact?

I get this error when i start the addon:

2018-11-30 12:24:03 WARN: One of the protocols is disabled due to port conflict

Full log here: https://hastebin.com/zafabumina.php

What are all the ports that is try to open so i can find what port is conflict


Do you know how I can edit the Traccar config files and also view the wrapper logs with this addon?


The add-on creates a “traccar.xml” file inside your /config/ directory. This is where you should make any config changes, and changes here will override default values in the default config file. If you some reason you need to edit the actual default config file (should not be nessessary, AFAIK) the default config file is stored in “/etc/traccar/hassio.xml”

As for the wrapper logs, I’m not sure.

1 Like

cool, thanks for that… it would be good to get a view of the logs, I will have a dig around…

mcfrojd, did you ever get this running? I have spent a couple of hours and cannot.

Current error is “Error setting up platform traccar”. No other information in hass log. Is there another place to look?

OK, finally got traccar platform working. Using internal IP, but was being forced to https. had to set ssl: true and verify_ssl:false. Full working config:

  • platform: traccar
    host: ‘192.168.0.xxx’
    port: 8072
    ssl: true
    verify_ssl: false
    username: redacted
    password: redacted
1 Like

Thanks @jaalperin I confirm that this configuration is working for me too:

  - platform: traccar
    host: ''
    port: 8072
    ssl: true
    verify_ssl: false
    username: !secret traccar_user
    password: !secret traccar_password
1 Like

I can’t get it to work :confused: I tried with both internal IP and DNS

Any ideas?

Anyone else have this error, i dont know what it impacts, i can start the addon but i have problems with using google map instead of open street map. But that might be something else.

Updated to the latest hass.io 83.3 and seems to work fine now.


I have traccar working fine, it’s using SSL with a valid public cert and devices are reporting to it but I just can’t get the device_tracker integration to work :frowning:

This is the only entry I get in the home-assistant.log:

2018-12-05 22:35:01 ERROR (MainThread) [homeassistant.components.device_tracker] Error setting up platform traccar

I’m using the following config as per @jaalperin and @jvmonjo as i was getting the error [pytraccar.api] Error connecting to Traccar, Cannot connect to host a0d7b954-traccar:8072 ssl:None [Name does not resolve]

  - platform: traccar
    host: ''
    port: 8072
    ssl: true
    verify_ssl: false
    username: !secret TraccarUser
    password: !secret TraccarPass

Does anyone have any ideas?



Here’s my full config:

  • platform: traccar
    ssl: true # since http is forced to https
    verify_ssl: false # so traccar won’t attempt to resolve IP with DNS
    host: !secret traccar_host
    port: !secret traccar_port
    username: !secret traccar_username
    password: !secret traccar_password
    interval_seconds: 120
    consider_home: 60
    track_new_devices: yes

which seems to be the same as yours.

Has anything showed up in known_devices.yaml (with track = false)?
Assuming the Traccar server is running as a hassio addon, try Also try adding http:// or https:// to host.

Restart both HA and the addon (to make sure all changes get recognized). I’m sur I didn’t fo this enough.

Sorry to suggest what you may have already tried. That’s the extent of it from me. Took me hours before I stumbled onto settings that worked for me.