Home Assistant Community Add-on: Z-Wave to MQTT

Hi everybody,

I would like to integrate the shutter modules.

Z2M recognizes the FGR-222 as dimmers:
So, here are the JSONs it automatically generates:

So I can easily delete them and recreate them to correspond to the “standard” home assistant
and make it a cover type.

In the home assistant docs, everything is in YAML and I don’t see how to make a JSON.
Once the JSON is created, it will be automatically pushed into the Home assistant and appear as a beautiful shutter :wink:

Anyone have an example of formatting to do in this case?



Can anyone please help?

I still have a couple of devices that don’t have all options.
I think it is because of the device_classes.xml file that can’t be found, error Failed to load device_classes.xml.
Tried the config path /usr/src/app/config and /usr/local/etc/openzwave.

Thanks in advance.

Yeah I’ve just found this as well - there is a proposed fix here: https://github.com/hassio-addons/addon-zwave2mqtt/pull/44

Other option is to set the config path in the openzwave2mqtt webui.

Click Settings -> ZWave and enter /usr/etc/openzwave under config path.

Thank you very much foxy82, you’re a lifesaver, changing the config path to this did the trick. Finally it works and the last two devices have all options.

Happy easter!

I have a z-Wave Switch which seems to be not yet covered by ozw 1.6
it is a Hauppauge mySmarthome switch reporting type=000e and unknown id=0059. It seems identical to the Pan11 Smart Energy Plug Switch which is with id=0011 in the database.

What is the best approach to get this device included using the zwave2mqtt add-on
I am running the newest 0.6 version.

Thanks for the advice

I spend my whole evening figuring out why me newly added battery devices did move to dead after a while… Apparently this has been fixed in 3.0.4, where this addon is still using 3.0.3. Newest release is 3.1.0 (5 hours ago), so I will just wait until the addon will be updated. :slight_smile:

Mine is using 3.0.2.

How and when will this be upgraded?

Gave it a push…

I’m dying for this update too… I wish there was more instructions than “Feel free to help out!”, as it feels like GFY from the repo maintainer. The Contributing doc doesn’t exactly outline what “standard maintenance” occurs, so an enthusiast is left to reverse engineer the repo.

Is this all we are looking at?

  1. Bump zwave2mqtt/Dockerfile line 42 to v3.1.0.tar.gz
  2. What about line 31? open-zwave/archive/ ?

I think we all appreciate the hard work work that goes into the addons, but there are some critical fixes here that we need to run our homes that are stuck downstream. I would be happy to submit a PR myself for this, but I’m stuck between “Feel free to contribute!” and being grumped at for even trying…?


Is it not possible to installl Zwave2MQTT yourself in a Docker, then you totally free to update when there is a update… The Add-On is also install a version into a Docker, So you can do it ourself right?

I would like that for qt-zwave2mqtt

as you can with any addon, so why are there addons?

I dont get what you mean

Maybe to make it easier for people who don’t know how to do it?

Since a few day in all browsers and all PC’s and mobile app I have all missing icons. reboot, restart, not helping.

Ok in the add-on I can use
and then add my configs for open zwave are there? I don’t think mine are updating or I can’t use that location please let me know what is mapped to this container for storage

1 Like

Is the Config Path correct:

Settings >. Zwave > Config Path


I had same problem in beginning. Removed all my nodes, add this path. Restart
Add Nodes again.

Since then there also more configuration options for my nodes, and all info is correct now for months

I use qt openzwave now. Much better.

It turned out that the icons were fetched from Internet and thus not always available. It was somewhere sorted but since I am not using this anymore I do not have the issue anymore :slight_smile:

@poudenes but where can I see those file to edit in Hassio?

I think I got it worked out Now to Solve my Lock issue Schlage Locks keep losing thier configuration due to them losing their Manufacturing/ Device ID. I think thats a OpenZwave issue.
The conatiner is actually Mapped to /config and /share I went into the Docker and checked for sure so just dropped the /config/zwave/configs folder in the Settings and made sure I had the update database set and they were pulled down to that folder.