Home Assistant Community Add-on: ZeroTier One

This add-on is provided by the Home Assistant Community Add-ons project.

GitHub Release GitLab CI Project Stage Project Maintenance

Supports armhf Architecture Supports armv7 Architecture Supports aarch64 Architecture Supports amd64 Architecture Supports i386 Architecture

Radically simplify your network with a virtual networking layer that works
the same everywhere.


ZeroTier delivers the capabilities of VPNs, SDN, and SD-WAN with a single system. Manage all your connected resources across both local and wide area networks as if the whole world is a single data center.

People use ZeroTier to seamlessly connect laptops, desktops, phones, embedded devices, cloud resources, and apps any way they want anywhere they go. It transforms the entire world into a single data center, to which you can now add your Home Assistant instance using this add-on.


The installation of this add-on is pretty straightforward and not different in comparison to installing any other add-on.

  1. Search for the “ZeroTier One” add-on in the Hass.io add-on store and install it.
  2. Create a free account at zerotier.com and get a network ID.
  3. Set the “network_id” add-on option with your network ID.
  4. Start the “ZeroTier One” add-on
  5. Check the logs of the “ZeroTier One” add-on to see if everything went well.
  6. The instance will show up in your ZeroTier account.

:books: Please read the documentation for more information about the use and configuration of this add-on.


You can always try to get support from the community here at the Home Assistant community forums, join the conversation!

Questions? You have several options to get them answered:

You could also open an issue on GitHub, in case you ran into a bug, or maybe you have an idea on improving the addon:

:information_source: At this moment our Home Assistant Community Add-ons Discord chat server and GitHub are our only official support channels. All others rely on community effort.

Repository on GitHub

Looking for more add-ons?

The primary goal of our add-ons project is to provide you (as a Home Assistant user) with additional, high quality, add-ons that allow you to take your automated home to the next level.

Check out some of our other add-ons in our Home Assistant Community Add-ons project.


About the author of this add-on

Hi there!

I am Franck Nijhof, and I have 30 years of programming experience, in many languages. I am using this experience to work on the Home Assistant project by giving back my knowledge and time to the open source community.

The add-on you are currently looking at right now was developed/packaged by me. It is not the only add-on I have created; there are many many more :wink:

However, I have a problem… I am an addict. A :coffee: addict that is. Lucky for you, I turn that C8H10N4O2 (caffeine molecule) into code (and add-ons)!

If you want to show your appreciation, consider supporting me for buying a cup of high octane wakey juice via one of the platforms below! :heart:

Sponsor Frenck via GitHub Sponsors

Support Frenck on Patreon

Enjoy your add-on, while I enjoy the brain juice. :coffee:

Thanks for all the :two_hearts:


Join our Discord server Follow me on Twitter Flollow me on Instragram Follow me on GitHub Follow me on YouTube Follow me on Twitch patreon-icon

P.S.: In case you want to ask me a question: AMA (Ask Me Anything). Most of the time I am online at the Discord chat. (I go by @Frenck in there as well).

Thanks for another great add-on :+1:

After setting up config and starting the add-on I get nothing in the log, but the hassio system log is showing:

19-04-02 21:01:44 INFO (SyncWorker_0) [hassio.docker.interface] Clean hassioaddons/zerotier-amd64 Docker application
19-04-02 21:01:45 ERROR (SyncWorker_0) [hassio.docker] Can't start addon_a0d7b954_zerotier: 500 Server Error: Internal Server Error ("linux runtime spec devices: error gathering device information while adding custom device "/dev/net/tun": no such file or directory")

Details of my system:

hassos 2.11
arch x86_64
python_version 3.7.2
HA version 0.90.1

Any ideas what is happening here?

Interesting @gerard33. I did test it on HassOS (live on stream today):

I’m going to update HassOS and see if that might be related.

I was on hassos 2.10 and got the error there as well. I then updated to 2.11 to see if that would fix anything, which apparently it didn’t :grin:

I am running hassos on Proxmox VM btw.

Edit: on my dev HA where Hassio runs on Ubuntu 18.04 the add-on is working fine :thinking:

@gerard33 Not sure if Proxmox is related and/or if the vmdk build os HassOS are different.

Strange, I’m getting the same error as @gerard33:

19-04-02 21:47:08 ERROR (SyncWorker_5) [hassio.docker] Can't start addon_a0d7b954_zerotier: 500 Server Error: Internal Server Error ("linux runtime spec devices: error gathering device information while adding custom device "/dev/net/tun": no such file or directory")

Running HassOS 2.11 on VMware ESXi 6.5

arch x86_64
dev false
docker true
hassio true
os_name Linux
python_version 3.7.2
timezone America/Los_Angeles
version 0.90.2
virtualenv false

Add-on config:

  "network_id": "<redacted>",
  "port": 9993,
  "api_auth_token": ""

VM Specs:
4GB memory
64GB storage IDE
Boot EFI
NIC E1000E

You both use the same type of HassOS build, thanks! That is useful information.

:warning: I’ve now received 4 reports on the following error:

19-04-02 22:01:52 ERROR (SyncWorker_9) [hassio.docker] Can’t start addon_a0d7b954_zerotier: 500 Server Error: Internal Server Error (“linux runtime spec devices: error gathering device information while adding custom device “/dev/net/tun”: no such file or directory”)

This seem to be happing that run HassOS on a VM (like Proxmox or ESXi). I’m currently looking into what causes this issue. HassOS for other devices (e.g., Raspberry Pi) are working just fine. So this might be a HassOS issue.

:information_source: The above issue have been solved in HassOS v2.12

1 Like

How this addon compares to Nabu Casa Remote UI?

At first look it seems better cause it support addons and its free, but it received score 3 in Hass.io security rating, does it mean it less secure than Remote UI?


So My Hass.io is running only accessible by IPv6. Does this mean from my IPv4 only mobile I could use zero-tier to connect?

That would be awesome! I need to investigate this but thanks for another great addon right on the heels of vscode!

probably we need to add --device=/dev/net/tun to docker to create the tun

So added the app on my iPad and vpn and it’s showing as well in zerotier account - both authorised… but if I put the ipaddress in my browser on mobile it won’t connect? Is this not how it’s supposed to work?

ZeroTier creates a VLAN with the connected machines. So look on your zerotier account page (scroll down to ‘members’) for the ip address of your hass.io addon (it will be different than the ip address of your lan at home) and type that into your ipad browser adding “:8123” while connected to the zerotier network

example: at home I use a standard setup, but in my zerotier account page, all connected devices are getting 10...1 ip addresses

ZeroTier isn’t so much providing a VPN to your home as it is creating a little LAN on the internet that many devices can connect to and exist as if they were on the same LAN

I was trying to connect to the right IP address… the zerotier one. adding :8123 didn’t help.

hmm… since you use an ipv6 address for hassio, did you put in the brackets?

You mentioned your mobile is ipv4 only, with a bit of googling, I’m not sure it can connect directly to your ipv6-only HASS

You’ve probably already read some of this since you have an ipv6 server, but here’s a bit I found on connecting ipv4 to ipv6: https://stackoverflow.com/questions/16480729/connecting-ipv4-client-to-ipv6-server-connection-refused

I was using an IPv4 address…

Quite right… that is actually the exact problem I’d like to solve using this addon…

I will try IPv6 and see if it works…

EDIT: Tried IPv6 doesn’t work either

It doesn’t, Nabu Casa Remote is a forwarding service. ZeroTier One is a virtual networking tool.

It is not better, different. The Hass.io security rating is based on the things the add-on gets access to. The more access to hardware and or privileges, the rating drop. This add-on obviously needs to get access to the network stack and therefore it requires some privileges and hardware access. This does drop the rating but does not mean it is unsafe.

No that is not it, the tun device itself is missing from the kernel as it seems. I’m looking into HassOS to see if I can add support for it. Currently, only OVA based HassOS seems to be affected.


Thanks for the addon, was waiting a long to get the vpn to my home.
I can access from phone with zerotier client to my rpi with HA via local address (10.0.0.blah) but want to be able to access other devices on my LAN (10.0.0.x/24)
I tried adding a route to 10.0.0.x/24 via 172.something (the vpn address of my ha rpi) but no luck, tried to enable ethernet bridge (i think additional configuration should be done on addon/rpi side, anyway not sure regarding this one if i need it).

So, any though how I can access the rest of my LAN via Zerotier vpn connection?


1 Like

I would also want to know if this is possible with this add-on!

Thanks a ton for this addon, I was missing it on my RPi since I switched to hass.io from a plain pip install.