Home Assistant Companion Apps: New and Upcoming Features

Hi, when I try to make a widget for entity state and select and entitiy and givd it a name, there is no button to place the widget somewhere…

How can I place such a button?

Btw, a service call works good.

This will be fixed in the android release, its currently fixed in the beta version.

Ok , thus its not me :slight_smile:

Thank you for your link to the camera proxy. I solved the problem, the images needs to have sizes that can maintain aspect ratio when scaled.
640x480 (VGA, default) 640*480, ratio 10x7,5 is not working without crop due to android notification scaling problem, the notification image is not shown. Correct ratio has to be created with camera proxy using the camera proxy crop function in some way?

1024x768 (XGA)1024 x768, ratio 16x12 - OK No scaling problem. Notification image is scaled properly without crop, (can devide with 64 to get ratio).

Could you share the camera proxy configuration you have? Maybe that can be something we add to the companion docs to help people out that are looking for similar results :slight_smile:

- platform: proxy
    entity_id: camera.s_cam_1
    name: s_cam_1_frontdoor_notification 
    max_image_width: 192
    image_quality: 50```
1 Like

Ok, now with android update to 2.2.0-269-full my existing widgets all lost their icons.

Placing a widget entity state now works but it does not give the proper status. When I “press” the widget it updates the status.

The icons may still be there, can you take a screenshot and open a bug on github?

The state usually takes a bit to update when we place the widget, I always see the correct state when I place the widget on the home screen.

When I place a new widget they are there. I was talking about existing widgets, those icons are (all) gone. Taking a screenshot will not add more information.

no worries, thanks for letting us know!

Thanks and thanks for all this great stuff!

Just updated the app. Still no icons back… :slight_smile:

Another thing… would it be an option to have a combined button showing the state of an entity and being able to control that entity?

Thus a widget for a light switch showing if it is on or off and pressing it to turn it on or off (and show it)?

Guess that will not happen. It’s quite clear - if you look at github - that there is mainly only one user responsable for this blockings, lockings and so on.
Sad thing no one will say anything against it even if it violates the code of conduct :pensive:


As I gather, the iOS version doesn’t support biometrics. Are there plans to add support?

Hi, is anybody else having problems with push notifications on ios since the app has been updated. since the app update non of the notification come trough. Node red shows that the notification has been sent, i have checked all the phone settings and also renewed the Push ID.

Check to see if you have a duplicate mobile app integration. I didn’t heed the warning to remove the original integration first, and just logged in again, and found that my device was indeed duplicated. And Node-RED was trying to send the notification to the old integration. To fix it, I removed both, reset the app and logged in again.

Other than that, you might need a restart.

Yes thanks just had a look and The integration has mine and the wife’s mobile app in twice. I’ll delete them and start again. Thanks for your help.

I have an older unused Android v4.2.2 tablet.
Is there a version of this app that works with this version?
If possible, I would like to use it as an extra wall mounted system and since it’s a only 7" it would be nice if this could be in kiosk mode with the app.
I don’t think this is possible with a browser so therefor this path.

Is it normal that after disabling some sensors on the app and after restarting HA, the disabled sensors are still present in developers/states? Do i need to force close the app and then run again to make these changes reflected also in the HA frontend?

Sensors are not removed when disabled from the app