Home Assistant Companion (IOS) : Alamofire.AFError 13

I’m back using Cloudflare with HTTPs (I was using Nabucasa for a while), I managed to setup everything. even the iOS app, but now I have this error

Failed to Connect
URLSessionTalk failed with error: An SSL error has occurred and a secure connection to the server cannot be made.

Error code:
Alamofire.AFError 13

For information Home assistant and my IOS device are on two different VLAN
Both have DNS filtering using a external DNS server

I can manage to connect using a web browser on the same iPhone but not the app.
I don’t think that the HA server have some DNS traffic block (according to the logs, but I might have missed something) and on the iPhone client, I tried with a VPN to bypass the DNS but I also get an error.

Cloudflare have some WAF rules, but same issue when disabled.

I’m having the same issue! Connecting to HA via cloudlfare tunnel at http://ha.MyDomain.com and it works perfectly on a browser. However, with the iOS app I get the following error:

Having the same issue after having a power outage.
Tried to restore and all.
Works on all devices except my iPhone.

I have the same issue after a power failure. Works fine in browser

Similar error on ipad. Fine on android phone and tablet.

‘ObjectMapper failed to serialize response’
Alamofire.AFError 10

Someone suggested adding


into configuration.yaml has fixed it for some, but didn’t fix it for me. Re-installed app several times, over several months, still same. just about given up now.

I had the same problem today.
Solved by changing the network settings inside companion app from Nabusa Cloud to my external url in the server profile setting

Hello! How do you access network settings in the companion app if you can’t connect to the server? There are no options available… Can you please be more specific? Thanks!

I was able to solve the error by first connecting internally via the IP (without https) and then in the APP setting → Server → External URL I removed the check mark for Home Assistant Cloud.

Even after a reinstallation, the check mark seemed to be still set

1 Like

Thank you, ever since trialling cloud I have had weird issues.

This one worked for me as well