Home Assistant Core -- TrueNAS CORE Community Plugin

Troy - really appreciate the massive effort you’ve put into making a Freenas plugin for HA. Can’t thank you enough.

Does anyone have any experience of installing Zigbee2mqtt on Freenass? I’m trying to hook up some Xiaomi sensors. The official instructions over at www.zigbee2mqtt.io give guidance on running on a bare-metal Linux and virtualized environments, but as we know Freenas is basically Freebsd and I am out of my depth with that, the syntax and commands are not the same and although I can handle using the command line I tend to struggle a bit at the best of times.

Is it necessary to install Zigbee2mqtt in a separate jail from the main HA jail?
Is it possible to install Hass.io on freenas? Zigbee2mqtt is available as an official addon for that.

Any help much appreciated


  • What kind of zigbee hub do you have? Is it a USB device?

With a few extra steps – USB devices like the HUSBZB-1 can be used by HA directly.

  • Is there a reason you do not connect directly to HA?
  • Is there a reason you want ( or need ) to use Zigbee2mqtt?

I’m asking so I can understand if you have a different use case that would require Zigbee2mqtt.

If you want to install Zigbee2mqtt I would strongly recommend a separate jail

In any case – To connect a USB zigbee or zwave hub, to any jail on FreeNAS

This is something separate – I can only say where to look.

Yes – but there is no way to access your usb zigbee device

1 Like


My device is USB - a GBAN GB2530 which according the Zigbee2mqtt github page is compatible.

According to my understanding, I need to use Zigbee2mqtt to use Xiaomi sensors. My device has been flashed with the relevant co-coordinator firmware.

I tried adding it direct to HA as a ZHA integration but no dice. I believe I have the custom ruleset working as when I type “usbconfig” in the HA jail I can see the device listed as "“silicon labs cp2102 usb to uart bridge controller at usbbus1, cfg=0 md=host spg=full (12mbps) power=on (100mA)”

But when I try add /dev/cuaU0 it doesn’t work even although I can see cuaU0 in the /dev folder in the jail.

Anyway, happy to go with a dedicated jail for Zigbee2mqtt if that is best.

Yes this means the ruleset is setup correctly

Ok – Check back in a day or two… I’ll have a look at the installation instruction and get something put together for you.

1 Like

Hi Troy,

Thanks for your wonderful works. I’ve followed your instructions and everything is working perfectly.

I’m so new to this. I’ve used to add things in hass.io add-ons store and I think there is no add-ons store in this kind of setup. Can you please point me to the right direction on how to do these things?

Samba share
Setup SSL
Integrate with Duck DNS

Thanks a lot,

  • Klang

You are correct – There is no add-on store. Having the add-on store can definitely be a great advantage, especially for new users. However most anything provided by the add-on store can be installed and configured separately. For example, ssh and samba are both provided by FreeNAS – So there is no need to have seperate “add-ons” for these.

– In terms of Home Assistant Add-ons, these are just separate containers, and specifically with the “Home Assistant Supervised” you get the ability to manage and have basic configuration of these separate contains through Home Assistant.

– In this setup you would be looking for other FreeNAS plugins. Two common examples, there are FreeNAS plugins for Mosquitto and Node-Red. Using the FreeNAS plugins will be more along the line of a manual setup. Also there are very few FreeNAS plugins compared to the number of Home Assistant Add-ons.

I see you have already found this post about about running Home Assistant Supervised on FreeNAS. Are you switching to use this approach instead?

If you are going to stick with the FreeNAS plugins I can help you get Samba share working

Is this for remote access? I had this working several years ago, I don’t remember it being terrible to setup. I’ll have to look for the link I followed. Honestly, I have been supporting HA through NabuCasa since it started. I realize it may not be for everybody, but in my opinion it’s the best way to both support Home Assistant and get secure remote access that just works.

Hi Troy,

Thanks for your reply.

And yes, I’m experimenting the Freenas VM approach.

Let me tell you that I was so impressed when I first restart HA with your setup. It was mind blowing fast like 2-3 seconds compare to the Rasberry Pi 3 which would take about … forever.

Unfortunately, since I’m not the expert, I think I’m leaning to Hass.io with add-ons store for now.

Thanks a lot for your help,

  • Klang

Was installing “Z-Wave over MQTT Integration”. That requires to install openzwave daemon from a custom repository (seems very easy with hass.io, but can’t find any instruction when you don’t have hass.io). Any idea how to do that?


Hi Troy,
Many thanks for your work on this! It makes life very easy to installed HA!
There is one thing I just can not get AppDaemon running? I managed to create a token for this app & placed it into secretes. Try to start AppDaemon from side panel, it give me a blank page with nothing happening.
Try to go back to Freenas shell to see status --it say not running–
try to remove and reinstalled again, but still wouldn’t run?
Is there anything I have done wrong?
many thanks

I’m trying to figure this out myself – If ( and that’s a big if ) I can get it working I’ll make a seperate FreeNAS plugin to make it easier to install…

For now, I’m just using a dedicate RPI 3 – running raspbian-lite w/docker. So far it’s been working great w/HA on the FreeNAS

The side panel is just an Iframe link – You would need to use the FreeNAS shell ( Technically the jail shell ) to start appdaemon. The side panel will not unless appdaemon is already running

Usually it’s because the secrets is missing but since you added that already :thinking: – Let me give a quick test and make sure nothing has changed with the latest release of appdaemon … Just waking up here. Might be a few hours …

@Raymond_Cheung, I’m so sorry – I got completely sidetracked and forgot to report I installed AppDaemon with no issues…

Were you able to get this running yet? So the most likely cause it’s not running something in the configuration … I can try to help you get it sorted if your still troubleshooting it

I’m also unable to get Appdaemon running. Navigating the the appropriate url doesn’t work. Have tried restarting appdaemon, and also reinstalling it. If I select start, or restart, it says its starting but selecting the status option always shows it as not running. Any ideas?

EDIT: I worked it out. It seems setting time zone is critical for it to run and there is nothing in the documentation about setting time zone location properly. Using the default America/chicago allows it to run. I’m in UK/London, which didn’t work. I needed to change this to Europe/london.

Troy - I’m going to need your help again (sorry!)

In your original install thread you helped me get a hass-apps working as outlined in this post:

However, I can’t get it working with your new 11.3 install. I’ve followed the same procedure except that to get into the jail I just used the jexec command as your original help would just lead me to your scripted menu system. Can’t get Schedy to work. Would really appreciate your help (again!) :slight_smile:

Hi Troy,
Got it running now! It is the changing of the location data that is the corporate. In my area I change to New Zealand/Auckland which didn’t work. So revert back to the default America/Chicago. But anyway that will do for now.

Hi Troy, is there anyway to have IDE or a good text editor running on the HA core? Our current configurator is not very good. Under hassio it’s very easy but HA core looks impossible.
What editor are you using & hows that installed?

So basically what’s going on here … When appdaemon is pip installed (on any system), there are no configuration files provided … I have put together and included the configuration files that come with the FN plugin based on the AppDaemon configuration docs found here – I’m not sure where to find the correct format for each of your correct TZ locations but that should just be a general question for the appdaemon folks.

Really, this FN plugin has only added a pretty menu for convenience. There is still a serious lack of documentation of my part to explain everything that’s always been included since my first guide for FN 11 … But it boils down to this – The FN plugin is basically just a script to create a virtualenv and do a simple pip install – Just like the manual installation guides – The only thing I have really “created” are the FreeBSD init scripts used to run these programs. Even the HA Docs for FN use my init script – only difference are two variables, the default user and location of the virtualenv. – I some point, I swear I’ll get this documented to bridge that gap between clicking the install plugin button and understanding where to go next.

I’ll have a look and see if I can get it installed again – Also

iocage console homeassistant

Press 0 will exit the menu and you will be at the jail’s command line.

I agree about the configurator. I only use it for small edits – I do not have a way to include an IDE or better editor into HA core ( something available from the HA sidebar ) – Something like what is provided by the Hass add-on, would be ideally provided in this case by a separate FreeNAS plugin instead.

I edit my config over the network - I’m using “Code - OSS”, It is simply the Linux version of “VS Code” – I have the editor installed on my desktop computer and I created a file share on FN to the location of the HA configuration. The FN plugin will already have set the group permissions for to rw so there should be no need to mess with permissions – I have created the hass group with an ID 8123 on my FreeNAS and added myself ( the user I connect to my FN shares with ) to the hass group I created on FN. This setup is using the group permissions to share write access to the files with HA – It is important do not set, change, modify or any way alter the permissions from the FreeNAS UI and especially not from Windows. This again, I apologize, is something I have covered in previous guides but have failed to updated for 11.3

Thanks Troy. Any help wold be appreciated.

On a separate note, for some reason I don’t appear to be able to create a mount point inside the HA plugin jail to access all the config files on a samba share. I can’t create the mount as it needs to be an empty destination directory, and I can’t create the mount in a fresh jail before installing the plugin because the HA plugin won’t install into an existing jail. Not sure how to get this working either.

EDIT: I clearly needed more coffee before posting - of course, I can just create a share into the jail itself rather than creating a mount point. Doh!

Are you getting any errors when trying to install hass-apps or after it is installed? I have gone this far with no errors. Unfortunately, I’m not using hass-apps so I’m not sure how to further test if this is working.

iocage console homeassistant
## Press `0` to exit the menu

su - hass
  source /srv/appdaemon/bin/activate
  pip3 install --upgrade hass-apps
  deactivate && exit

lol, it’s ok. This trick you have discovered has only worked starting with FN 11.3 – Previous versions of FN would require the separate dataset if you wanted to share over the network.

There are still advantages to having a separate dataset for the configuration but it is no longer required.

EDIT: I think I have a week before I possibly go back to work – I’ll try to prioritized some remaining time off for getting my documentation updated.

Thanks Troy. I think it was an issue with the appdaemon installation not working properly. After a complete wipe and reinstall of the whole jail it appears to be working. The trouble with hass-apps is there is very little to help troubleshoot the install other than automations/schedules not working.