Home Assistant Desktop (macOS, Windows and Linux) - quick and easy access to HA

Home Assistant Desktop is a small desktop application that lives in the system tray / status bar and gives you quick access to your home assistant instance without the need to open the browser.

Everytime I wanted to switch off a light while sitting in front of my computer, I struggeled with opening the browser so I decided to make my (and hopefully many other) lives a little bit easier!

video

*As I don’t have time anymore, the project was forked and will be maintained by @iprodanov *

40 Likes

Thank you for this app i have been using it for the last day now and its perfect.
Its quick to link up and i like the toggling the app from the menu icon.
If you could do one more add on is i use it on my laptop which i take out on site. So can you add in the option of choosing connections one for local and one for wan.

Again its better than having to open up a browser to link to HA. :+1: :+1:

Thank you for your feedback! I will look into this tomorrow :slight_smile:

1 Like

not a big fan of Electron usually but this is great!

1 Like

This is fantastic. Thank you!

2 Likes

v1.2.1 released

  • supports multiple instances now (idea by cameron)
  • optimized updating
  • usability improvements
1 Like

Thanks Mate cant wait to try it. :+1: :beers:

Edit: Just downloaded the new version and its even better. Thanks for doing the extra url instance.

1 Like

This is what i get:

Schermata 2020-05-20 alle 19.04.07

Is there a way to change the theme as in this way on my side all is difficult to see!

EDIT: solved… i must choose to not hover. In this way i can access to my account and change theme…

1 Like

what the hell … Thanks so much!

1 Like

For some reason, the UI is showing up as Chinese for me ? I’ve been using this great app for the past couple of weeks and it’s been great. But all of a sudden, the language changed to Chinese and I cannot find any setting to change it back.

1 Like

I can’t reproduce the issue. Is chinese your system language? If so, this should be the reason. As an easy workaround I would just log in and change the Home Assistant users language to english.
Besides that I would recommend to save the login, so you dont have to deal with loging in again.

No, English is my system language. I’m being using your app for a few weeks now and it’s been working fine. Anyway, I found the issue. It’s quite weird. For the same user that I use to log into HA, in your app, the default language somehow changed to Chinese (I didn’t do it). But that same user, when I log into HA using a browser has the language set to English. I don’t understand how the same user can have two different languages set as their default in the same instance of HA.

Anyway, in your app, I changed the language back to English and it’s fine now.

Thank you so much for this app, I use it daily and it works perfect.

Sometimes, I might get errors like this.
The only way to get rid of them is to stop the app through Task Manager and restart it.


Just letting you know.

Thanks for the great work!

UPDATE v1.3.0

  • added instance auto switching
  • improved window scaling and general usability
  • fixed some bugs (see github issues for more info)

https://github.com/mrvnklm/homeassistant-desktop

I did not fix this in particular in the new version, but it might be fixed due some changes. Please open a github issue with an explanation how to reproduce or when this error usually occurrs!

Thanks. This is very useful :ok_hand:

1 Like

@mrvnklm
Hey! I have some problem with your app – I’m stuck on “enter URL” screen. I tried putting:

None of it works. Normally I use “https://hostname.local:8123” or “https://IP_ADDRES:8123” and it works without issues in web browsers or mobile app.

1 Like

Hey there filip,

Did you manage to fix this as I am having the same issue!

This is really cool. I will give it a try!

I switched to official native macOS app.

1 Like