Home Assistant Fresh Install ERR_CONNECTION_REFUSED - 2020

Hello All -
I had hassio running on a pi4, needed to replace the SD card and since replacing I can NOT get into homeassistant. I have been trying for a couple days to get into the front end. Of course I don’t have cables to connect a monitor, mouse, and keyboard. I installed raspian buster, and was able to get into the pi. Formatted sd card and flashed latest version from https://www.home-assistant.io/getting-started/
1 - New Sandisk Extreme 64gb card
2 - pi4, 4gb
Used etcher to flash SD card
Added ssh file
Network is a unifi network

Put SD card in pi
Connected power cord
Connected cat6 cable
Booted up

Have waited over an hour, multiple times and still can NOT get in.

I keep getting the following error:
This site can’t be reached
192.168.X.X refused to connect.
Checking the connection
Checking the proxy and the firewall

I have tried to use:
ip address:8123

Can not connect through SSH

Anyone have any ideas?
Thank you!

I assume you can ping the PI?
Did you try https://developers.home-assistant.io/docs/operating-system/debugging/#ssh-access-to-the-host ?

Obviously, that assumes the SDCard is not just faulty… No unusual LED’s on the PI?

I will give that page a try and see what happenes.
To answer you question:
I was able to install Buster on the card and run the PI no problem.
I am currently able to ping the pi, but when trying to login a “ERR_CONNECTION_REFUSED” error

It is so weird because the PI was up and running fine for a few weeks. Card went bad, replaced it and now I cant get it.
My network assigns a static IP

If so I don’t see another way than to ssh onto the PI (port 22222) and check the HA logs…

Yeah I will give that a try, I am also going to run to Staples and see if I can grab a micro hdmi-hdmi cable. Thanks for the help!

So I connected a monitor to it, and it looks like it stops at 23.968942 hassio: port 2 (vethe7360d5) entered forwarding state. Gonna let it sit for a little while and see what happens

So it is actually stuck in a constant IPC6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Power save enabled loop!

Just sits here spitting out this error

Same for me!
Tried both static and auto ethernet and wifi.

I joined this club again for the 3th time since I started in HomeAssistant, it’s getting boring always running into this issues. After random flashes or microSD cards it usually starts working for me.
But now stuck after the microSD decided to give up on me.

maybe late but i had the exact same issue.
turned out that it was my DNS.
the DNS was still set to the address of the raspberri pi because that used to be filtering my network using adguard. because that DNS was unreachable the pi wasnt able to sync time correctly with the internet and thus the docker stack initialization fails.
set DNS to router address and it was solved.

I fought with this for a lot longer than I care to admit to - longer than it should have taken. The fix (at least for me) was to take Chrome out of “secure DNS” mode. I have separate internal and external DNS servers for my own domain, each containing the respective internal and external IP’s of my HassOS instance. I could ping by name but only browse by IP (which means my ssl certs aren’t getting used). On a whim, I created entries in my local hosts file and suddenly everything worked as it should. Given this isn’t an acceptable solution for me, I narrowed the problem down to Google Chrome (and other browsers) trying to protect me from myself. A bit of searching on how to modify the settings in got me to where I can fix this once and for all. Hope this helps others.

Oh, and browser vendors? You’re really making a strong case for us to look elsewhere.