Home Assistant Installation Dell Wyse 3040

i am trying to intstall Home Assitant on a Dell wyse 3040.
These are the steps that i haven done, but them installtion always stops at the end and says “Waiting for the Home Assistnat CLI to be ready…”

This is what i haven done:
On my Windows Laptop:

  1. Flashed a 8gb usb drive with Ubuntu 22.10

On the Dell Wyse 3040:
2. Booted from the usb drive and chosse the option “try ubuntu”
3. Download BalenaEtcher
4. Flashed to the internal drive the folowning link:https://github.com/home-assistant/operating-system/releases/download/9.4/haos_generic-x86-64-9.4.img.xz
5. Stoped Ubuntu and put the usb drive out
6. Started the dell and the message “Waiting for the Home Assitant CLi to be ready” displays.
I am thankful for any tipps!

1 Like

Do you have it plugged in to an ethernet cable?

How long have you waited?

Yes a Ethernet cable is connected, i have waited over 15 minutes

1 Like

Perhaps here? Wyse Thin Client Home Assistant OS installation instructions

Dunno. Put the message into google and see what comes up.

Did the thread I pointed to help?

The main problem was that the flash in ubuntu was not completly done.

How does HA run on this? Is 8GB of storage enough? Please share your experience! I’m intersted


Hey, sorry fot the late anwser.
For me the 8Gb are at the moment enough space.
I have installed HACS, made a custom dashboard and made some own automations and I am only ussing 60% percent of the storage.
Storge is for me no problem, but the installtion on the dell wyse 3040 was a huge pain.

1 Like

I am considering getting one of these Wyse 3040 boxes. Isn’t it possible to boot HA from a flash drive or a usb drive from one of these? Thinking ahead of the Wyse storage limit.

1 Like

I tried booting HAOS direclty from an USB drive several times. But it was not working.

I’ve just went through the process and installed Debian with HA (and a few others) in Docker container. It turned out to take quite a lot of space and I was left with not much free space. So I’ve removed the swap partition and now it has ~2GB free space. This is just enough to be able to upgrade HA as the image is taking well over 1GB. Overall the installation with Debian is super smooth and boots up nicely without any tinkering.
Then I’ve tried to get something smaller and I’ve installed Alpine Linux. With automated install it creates a 2GB swap partition. To get rid of it is a bit of manual disk partitioning as there is no wizard type of process in the install scripts. I’ve reduced the size of swap partition and now I have 6.2 GB root partition with ~3GB free space. So 1GB more than the Debian install.

Both work all ok now, they use up to 1GB memory (HA ~300MB only). I’ll probably put the alpine version to production location (secondary one, need just a few devices, remote access etc)

BTW, this terminal is great, 10x10x3cm and takes only 3W on average and 4W under load

I`ve spend several days trying to install HAOS on my Wyse 3040 and this is how I’ve achieved it:

I use two USB sticks. One with Ubuntu installed and one with the Balena and img.xy file. I am using older versions of Ubuntu and Balena and that was the trick to make it work.

First make a bootable Ubuntu USB drive. I used a 32GB USB 3.0 drive.

  1. Flash a USB drive with ubuntu-18.04.6-desktop-amd64

  2. Create a second USB stick and download the next files:

Then setup your Wyse 3040. Enter the BIOS by pressing [F2] during boot and make sure boot from USB is turned on. The Bios password is Fireport Then boot from the USB 3.0 port (the blue one) with the Ubuntu drive.

On the Dell Wyse 3040:
2. Boot from the usb drive and choose the option “try ubuntu”
3. Plug in the second USB drive with the BalenaEtcher software on it. Right click on the file and give permission to execute the file. Then Run.
4. When Balena is running, select the HAOS file, point to the right destination and go!
5. My installation stopped at 30% and after 20 minutes I pulled the USB out, rebooted the device and voila; Home Assistant is running!

The howto is for installing haos, not debian or alpine.

Hello I’m new here and I’m also searching for a solution
I have the same set-up too with dell Wyse 3040
I’ve follow your step but im stuck at step 5
The device is froze up and the procedure stuck at 4%.
I’ve try several times and the results end up the same
I don’t know that i have faulty device or not (emmc?)
But before I wipe out all data for HA OS. I used to install debian and it’s work fine. Anyways help would be appreciated. Thanks

. Sorry for my English, English is not my first language.

Once install how is the performance of the device?

I’m stuck at step 4.
My Ubuntu live recognizes only 2gb of storage on my 3040 emmc and therefore won’t flash it (HAos is ~6gb).
Any thoughts?

Where does it say it only has 2G? My reading says it should either have 8 or 16.

I’ve tried Disks and Balena in several Ubuntus (Desktop 22, 18, 16) and gParted in latest xubuntu-minimal
Dell doesn’t offer support anymore for this product.

Where do you see your available storage?

lshw is my usual tool. Pipe it through less, ie


Lshw less doesn’t show capacity of emmc
So I posted this